
newgensoft.com 

NewgenONE OmniOMS 

Composition Designer 

User Guide 

Version: 12.0 

https://newgensoft.com/


NewgenONE OmniOMS Composition Designer User Guide Version: 12.0 Page 2 

Disclaimer 
This document contains information proprietary to Newgen Software Technologies Limited. The user 

may not disclose or use any proprietary information or use any part of this document without written 

permission from Newgen Software Technologies Limited. 

Newgen Software Technologies Limited makes no representations or warranties regarding any 

software or to the contents or use of this manual. It also specifically disclaims any express or implied 

warranties of merchantability, title, or fitness for any particular purpose. Even though Newgen 

Software Technologies Limited has tested the hardware and software and reviewed the 

documentation, it does not guarantee or imply that this document is error-free or accurate regarding 

any particular specification. As a result, this product is sold as it is, and the user, the purchaser, is 

assuming the entire risk as to its quality and performance. Further, Newgen Software Technologies 

Limited reserves the right to revise this publication and make changes in its content without any 

obligation to notify any person of such revisions or changes. Newgen Software Technologies Limited 

authorizes no Newgen agent, dealer, or employee to make any modification, extension, or addition to 

the above statements. 

Newgen Software Technologies Limited has attempted to supply trademark information about 

company names, products, and services mentioned in this document. Trademarks indicated below 

were derived from various sources. 

Copyright © 2024 Newgen Software Technologies Ltd. All Rights Reserved. 

No part of this publication may be reproduced and distributed without the prior permission of Newgen 

Software Technologies Limited. 

Newgen Software, Registered Office, New Delhi 

E-44/13

Okhla Phase- II

New Delhi 110020

India

Phone: +91 1146 533 200

info@newgensoft.com

mailto:info@newgensoft.com


NewgenONE OmniOMS Composition Designer User Guide Version: 12.0 Page 3 

Table of contents 
1 Preface .....................................................................................................................................................8 

1.1 Revision history ................................................................................................................................................................ 8 
1.2 Intended audience............................................................................................................................................................ 8 
1.3 Documentation feedback ................................................................................................................................................. 8 

2 Introduction ..............................................................................................................................................9 

3 Accessing OmniOMS Composition Designer ............................................................................................. 10 

4 Object gallery .......................................................................................................................................... 12 
4.1 Dataset or database ....................................................................................................................................................... 13 

4.1.1 Creating new DB dataset ....................................................................................................................................... 13 
4.1.2 Importing XSD ........................................................................................................................................................ 22 
4.1.3 Importing JSON ...................................................................................................................................................... 24 
4.1.4 Batch generation using JSON-DB dataset .............................................................................................................. 26 
4.1.5 Check-in dataset .................................................................................................................................................... 31 
4.1.6 Configuring dataset field properties ...................................................................................................................... 32 

4.2 Object ............................................................................................................................................................................. 35 
4.2.1 Output management system ................................................................................................................................. 35 
4.2.2 Enterprise layout components ............................................................................................................................... 43 
4.2.3 Enterprise master layout ....................................................................................................................................... 44 

4.3 Properties ................................................................................................................................................................. 44 
5 PreMenu options .................................................................................................................................... 49 

5.1 File menu ........................................................................................................................................................................ 49 
5.1.1 Save ........................................................................................................................................................................ 50 
5.1.2 Importing word file ................................................................................................................................................ 51 
5.1.3 Exporting templates ............................................................................................................................................... 52 
5.1.4 Importing template ................................................................................................................................................ 54 
5.1.5 Importing PDF file .................................................................................................................................................. 57 
5.1.6 Templates migration .............................................................................................................................................. 59 
5.1.7 Exit ......................................................................................................................................................................... 60 

5.2 Edit menu ....................................................................................................................................................................... 60 
5.3 View menu...................................................................................................................................................................... 61 

5.3.1 Show highlighters................................................................................................................................................... 62 
5.3.2 Draw grid................................................................................................................................................................ 62 
5.3.3 Font style gallery .................................................................................................................................................... 63 
5.3.4 Dataset gallery ....................................................................................................................................................... 64 
5.3.5 Component gallery ................................................................................................................................................. 65 
5.3.6 Version explorer ..................................................................................................................................................... 66 
5.3.7 Recycle bin ............................................................................................................................................................. 68 
5.3.8 Header and footer ................................................................................................................................................. 71 
5.3.9 Pre-footer............................................................................................................................................................... 72 
5.3.10 Ask Marvin ............................................................................................................................................................. 73 

5.4 Insert menu .................................................................................................................................................................... 78 
5.4.1 Text ........................................................................................................................................................................ 78 
5.4.2 Rich text box .......................................................................................................................................................... 84 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 4 

5.4.3 Drawing .................................................................................................................................................................. 93 
5.4.4 Barcode .................................................................................................................................................................. 94 
5.4.5 QR code .................................................................................................................................................................. 96 
5.4.6 IM barcode ............................................................................................................................................................. 99 
5.4.7 Symbol ................................................................................................................................................................. 100 
5.4.8 Digital signature ................................................................................................................................................... 101 
5.4.9 Image ................................................................................................................................................................... 102 
5.4.10 Container ............................................................................................................................................................. 105 
5.4.11 Copy-paste controls ............................................................................................................................................. 111 
5.4.12 Table of Contents ................................................................................................................................................. 113 

5.5 Format menu ................................................................................................................................................................ 115 
5.5.1 Aligning left .......................................................................................................................................................... 116 
5.5.2 Aligning center ..................................................................................................................................................... 119 
5.5.3 Aligning right ........................................................................................................................................................ 121 
5.5.4 Aligning top .......................................................................................................................................................... 123 
5.5.5 Align bottom ........................................................................................................................................................ 125 
5.5.6 Aligning middle .................................................................................................................................................... 127 
5.5.7 Specifying same height ........................................................................................................................................ 129 
5.5.8 Specifying same width ......................................................................................................................................... 131 
5.5.9 Specifying same height and width ....................................................................................................................... 133 
5.5.10 Specifying equal vertical space ............................................................................................................................ 135 
5.5.11 Specifying equal horizontal space ........................................................................................................................ 137 
5.5.12 Support for Arabic and other foreign languages ................................................................................................. 138 

5.6 Function menu ............................................................................................................................................................. 139 
5.6.1 Rule function ........................................................................................................................................................ 140 
5.6.2 Arithmetic function .............................................................................................................................................. 157 
5.6.3 Annexure configuration ....................................................................................................................................... 164 
5.6.4 Metadata library .................................................................................................................................................. 165 

5.7 Tools menu ................................................................................................................................................................... 170 
5.7.1 Configuration manager ........................................................................................................................................ 170 
5.7.2 Auto relativity and alignment .............................................................................................................................. 171 
5.7.3 Password designer ............................................................................................................................................... 171 
5.7.4 Sample PDF stamp ............................................................................................................................................... 177 
5.7.5 PDF security parameters ...................................................................................................................................... 178 
5.7.6 Edit master query................................................................................................................................................. 182 
5.7.7 Watermark configuration .................................................................................................................................... 182 
5.7.8 Exporting XML schema ......................................................................................................................................... 186 
5.7.9 Decision table library ........................................................................................................................................... 187 
5.7.10 Spell check ........................................................................................................................................................... 193 

5.8 Help menu .................................................................................................................................................................... 193 
5.9 Data masking ................................................................................................................................................................ 194 

6 Toolbars ................................................................................................................................................ 196 
6.1 Standard toolbar .......................................................................................................................................................... 196 
6.2 Objects.......................................................................................................................................................................... 202 

6.2.1 Dynamic rich text ................................................................................................................................................. 203 
6.2.2 Mapping rich text box to RTF labels..................................................................................................................... 206 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 5 

6.3 Statement navigator ..................................................................................................................................................... 207 
6.4 Page navigator .............................................................................................................................................................. 207 
6.5 Formatting toolbar ....................................................................................................................................................... 207 

7 Design reports ....................................................................................................................................... 215 
7.1 Create PDF or HTML or Message report ...................................................................................................................... 215 
7.2 Design PDF or HTML or Message report ...................................................................................................................... 221 
7.3 Save PDF or HTML or Message report .......................................................................................................................... 222 
7.4 Create WhatsApp report .............................................................................................................................................. 223 
7.5 Fillable PDF ................................................................................................................................................................... 229 

7.5.1 Design on canvas.................................................................................................................................................. 230 
7.5.2 Design on PDF ...................................................................................................................................................... 235 

7.6 Insert new page ............................................................................................................................................................ 236 
7.7 Continuation page ........................................................................................................................................................ 240 
7.8 Viewing associated components .................................................................................................................................. 241 

7.8.1 Navigating to a component.................................................................................................................................. 242 
7.8.2 Previewing a sample report with an upgraded component ................................................................................ 244 
7.8.3 Enforcing upgrades in a report ............................................................................................................................ 245 

7.9 Viewing associated master layouts .............................................................................................................................. 246 
7.9.1 Navigating to a master layout .............................................................................................................................. 246 
7.9.2 Enforcing upgrades in a report ............................................................................................................................ 247 
7.9.3 Removing associated master layout .................................................................................................................... 247 

7.10 Pre-printed stationery ............................................................................................................................................... 248 
7.11 Design cover page...................................................................................................................................................... 248 
7.12 Design trailer page ..................................................................................................................................................... 252 
7.13 Email notification ....................................................................................................................................................... 254 
7.14 Container groups ....................................................................................................................................................... 255 
7.15 Nested container ....................................................................................................................................................... 261 
7.16 Applying URL shortening ........................................................................................................................................... 263 

8 Sending report templates for approval .................................................................................................. 264 
8.1 Mapping approval workflow with communication group ............................................................................................ 265 
8.2 Creating a new report .................................................................................................................................................. 266 
8.3 Saving report templates ............................................................................................................................................... 266 
8.4 Check-in reports ........................................................................................................................................................... 268 
8.5 Sending report template for approval.......................................................................................................................... 269 
8.6 Viewing approval summary .......................................................................................................................................... 271 
8.7 Baselining report .......................................................................................................................................................... 273 

9 Add jobs ............................................................................................................................................... 274 
9.1 Create print job ............................................................................................................................................................ 274 

9.1.1 Registering OmniDocs cabinet with CCM cabinet using immune user ................................................................ 281 
9.2 Create email job ........................................................................................................................................................... 282 
9.3 Create message job ...................................................................................................................................................... 287 
9.4 Create WhatsApp job ................................................................................................................................................... 290 
9.5 Create on demand job .................................................................................................................................................. 296 

9.5.1 Mail or archival .................................................................................................................................................... 296 
9.5.2 Message or WhatsApp ......................................................................................................................................... 308 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 6 

9.6 Copy-paste job.............................................................................................................................................................. 314 
10 Importing templates through MS Excel .................................................................................................. 315 

11 Sample templates ................................................................................................................................. 323 

12 Enforce Dataset ..................................................................................................................................... 326 

13 Add and manage layout components ..................................................................................................... 327 
13.1 Creating a new component ....................................................................................................................................... 328 
13.2 Adding components to a report ................................................................................................................................ 330 
13.3 Saving report segment as a component .................................................................................................................... 331 
13.4 Viewing associated reports ....................................................................................................................................... 331 

13.4.1 Navigating to a report .......................................................................................................................................... 332 
13.4.2 Enforcing upgrades in a report ............................................................................................................................ 332 

13.5 Modifying a component ............................................................................................................................................ 333 
13.6 Deleting a component ............................................................................................................................................... 334 

14 Add and manage master layouts ............................................................................................................ 334 
14.1 Creating a new master layout.................................................................................................................................... 335 
14.2 Adding master layouts to a report............................................................................................................................. 336 

14.2.1 Linking master layout ........................................................................................................................................... 337 
14.2.2 Importing a master layout ................................................................................................................................... 337 

14.3 Viewing associated reports ....................................................................................................................................... 339 
14.3.1 Navigating to a report .......................................................................................................................................... 339 
14.3.2 Enforcing upgrades in a report ............................................................................................................................ 340 

14.4 Modifying a master layout......................................................................................................................................... 340 
14.5 Deleting a master layout ........................................................................................................................................... 341 

15 Contract designer .................................................................................................................................. 342 
15.1 Contract properties ................................................................................................................................................... 354 

15.1.1 Defining mandatory fields .................................................................................................................................... 359 
15.2 Apply numbering ....................................................................................................................................................... 360 
15.3 Show version history ................................................................................................................................................. 367 
15.4 Import word file ......................................................................................................................................................... 368 

16 Letter designer ...................................................................................................................................... 369 
16.1 Letter properties ........................................................................................................................................................ 384 

16.1.1 Defining mandatory fields .................................................................................................................................... 390 
16.2 Apply numbering ....................................................................................................................................................... 391 
16.3 Check-in and check-out letters .................................................................................................................................. 394 
16.4 Show Version History ................................................................................................................................................ 398 
16.5 Import Word File ....................................................................................................................................................... 399 

17 Rights management .............................................................................................................................. 400 
17.1 Assigning rights on root level .................................................................................................................................... 401 
17.2 Assigning rights on a category ................................................................................................................................... 401 
17.3 Assigning rights on a communication group ............................................................................................................. 402 
17.4 Assigning rights on a report ....................................................................................................................................... 403 
17.5 Assigning rights on layout components ..................................................................................................................... 404 
17.6 Assigning rights on master layouts ............................................................................................................................ 406 

18 Maker checker ...................................................................................................................................... 409 
18.1 Sending report or component for approval .............................................................................................................. 410 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 7 

18.2 Reviewing pending requests ...................................................................................................................................... 411 
19 Table .................................................................................................................................................... 412 

19.1 Edit query .................................................................................................................................................................. 426 
19.2 Apply masking............................................................................................................................................................ 428 
19.3 Rule association ......................................................................................................................................................... 431 
19.4 Dynamic table ............................................................................................................................................................ 432 
19.5 Split column details ................................................................................................................................................... 433 
19.6 Table grouping ........................................................................................................................................................... 435 
19.7 Table pop-up menu options ...................................................................................................................................... 437 
19.8 Cell format copy and paste ........................................................................................................................................ 440 
19.9 Table alignment and positioning ............................................................................................................................... 443 
19.10 Cell border removal ................................................................................................................................................... 448 
19.11 Nested table .............................................................................................................................................................. 450 
19.12 Mapping table to RTF or HTML labels ....................................................................................................................... 451 
19.13 Apply URL shortening in a table ................................................................................................................................ 453 

19.13.1 Apply URL shortening to data field added to a table cell .................................................................................. 453 
19.13.2 Apply URL shortening using macro fields .......................................................................................................... 453 
19.13.3 Apply URL shortening using hyperlink .............................................................................................................. 454 

20 Data security compliance ...................................................................................................................... 455 

21 Integrating Amazon S3 and MS Azure sites ............................................................................................. 460 
21.1 Mapping the sites in jobs ........................................................................................................................................... 460 

22 Importing PDF in CDG ............................................................................................................................ 467 
22.1 PDF objects supported in import ............................................................................................................................... 467 
22.2 Procedures of importing PDF .................................................................................................................................... 467 

22.2.1 Pre-import activities .......................................................................................................................................... 468 
22.2.2 Importing a PDF................................................................................................................................................. 469 
22.2.3 Handling PDF import errors .............................................................................................................................. 472 

22.3 Review of the imported template ............................................................................................................................. 473 
22.3.1 Improper alignment of the objects ................................................................................................................... 474 
22.3.2 Text objects extracted line-by-line .................................................................................................................... 475 
22.3.3 Mapping customer data to the data fields ........................................................................................................ 478 

22.4 Converting the input PDF using MS Word ................................................................................................................. 479 
22.5 Limitations of importing a PDF .................................................................................................................................. 479 

Annexure ................................................................................................................................................... 480 

 

  



NewgenONE OmniOMS Composition Designer User Guide Version: 12.0 Page 8 

1 Preface 
This guide provides information on the functioning of NewgenONE OmniOMS Composition Designer. 

NOTE: 

To ensure you are referring to the latest and most recent revision of this guide, download it from one of the following 

locations: 

• Newgen Internal Doc Portal, if you are a Newgen employee.

• Newgen Partner Portal, if you are a Newgen partner.

1.1 Revision history 
Revision date Description 

October 2024 Initial publication 

1.2 Intended audience 
This guide is intended for system administrators, developers, and all other users seeking information 

on how the various features of OmniOMS Composition Designer function and to aid them in 

configuration, maintenance, and development. The reader must be comfortable understanding 

computer terminology. 

1.3 Documentation feedback 
To provide feedback or suggestions for improvement on technical documentation, email 

docs.feedback@newgensoft.com. 

To help capture your feedback effectively, share the following information in your email: 

• Document name

• Version

• Chapter, topic, or section

• Feedback or suggestions

https://newgenindia.sharepoint.com/sites/NewgenProductDocumentation/SitePages/NewgenONE-Learning-Library.aspx
https://partners.newgensoft.com/
mailto:docs.feedback@newgensoft.com
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2 Introduction 
OmniOMS provides a user-friendly interface Composition Designer to format, group, summarize, and 

arrange data into the desired output format and results. Composition Designer is used to gather data 

and design output based on data sources, such as Oracle and SQL. 

This document includes descriptions of the following: 

• Starting OmniOMS 

• Object Gallery 

• Menu Options 

• Toolbars 

• Design Reports 

• Sending Report Templates for Approval 

• Add Jobs 

• Importing Templates through MS Excel 

• Add Components 

• Contract Designer 

• Letter Designer 

• Rights Management 

• Maker Checker 

• Table 

• Data Security Compliance 
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3 Accessing OmniOMS Composition Designer 
To access OmniOMS Composition Designer, follow the below steps: 

1. Click Start menu, go to Programs > Newgen OmniOMS > OmniOMS Designer > CDG. The 

OmniOMS login screen appears. 

 

 
Figure 3.1 

 

2. Specify your Login ID and Password. The Cabinet Name appears by default. 

3. Click Connect to proceed further. The Two-Step Authentication screen appears. 

 

NOTE: 

If the specified user is already logged in to OmniOMS CDG, an error dialog appears. Click Yes to disconnect the existing session 

and continue with the login process. 

 

 

NOTE: 

The Two-Step Authentication screen appears only when the Two Factor Authentication is enabled in the OmniOMS Admin 

Workspace. If it is not enabled, you get redirected to the Composition Designer home screen. 
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4. Enter the OTP sent to your registered email ID or mobile number. 

5. Click Verify to complete authentication. The Composition Designer home screen appears. 

 

NOTE: 

• Use the Resend OTP option to resend an OTP to your registered mobile number. This option appears when the OTP 

validation time expires.  

• Use the Back option to go back to the OmniOMS login screen. 

Figure 3.2 

 

NOTE: 

The Restore Previous Session dialog does not appear if you are doing login for the first time. 

 

6. In Restore Previous Session dialog box, click: 

• Yes – to restore the last session. It opens the report where you left it during the last session. 

• No – to start a new session. 

• Select the Remember choice checkbox to allow the system to remember your selection of 

restoring session for future logins. 
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The Composition Designer comprises of the following three sections:  

1. The Object Gallery appears on the left side of the screen. It allows you to view, manage, and define 

various design objects and dataset that get used for designing the output.  

2. The Canvas appears on the center part of the screen where you design your output in the form of 

documents using various menu options and tools available in CDG.  

3. The Floating tabs appears on the right side of the screen. It allows you to drag-drop approved 

objects for designing output. 

 

It provides the following Menu options: 

• File 

• Edit 

• View 

• Insert 

• Format 

• Function 

• Tools 

• Help 

 

It also contains the following Toolbars used to design the documents: 

• Standard Toolbar 

• Formatting Toolbar 

• Objects 

• Statement Navigator 

• Page Navigator 

 

4 Object gallery 
Object Gallery is used to View, Manage, and Define various design objects and dataset that would be 

used for designing the output. 

Object Gallery consists of Three Tabs: 

• Dataset/Database 

• Object 

• Properties 
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4.1 Dataset or database 
Dataset is a set of database tables that will be used for fetching variable values at run time.  

Reports and components created within a Communication Group would use this associated dataset for 

variable fields mapping. 

The Dataset tab when clicked opens the Field Explorer to manage datasets in OmniOMS. 

 
4.1.1 Creating new DB dataset 
To create a new dataset in OmniOMS, follow the below steps: 

1. Click Dataset to open the related tab and then right-click the root folder to create a new DB Dataset.  

2. Go to New→DB Dataset. A new dataset has been created. 

 

 
Figure 4.1 

 

 
Figure 4.2 
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3. The Relationship Manager Wizard screen is invoked to select the appropriate Data Source Name and 

specify the Login details. 

4. Host Name/Server IP and Server Port are auto populated and are given in read-only mode. The Host 

Name/Server IP and Server Port information is pulled from the OmniOMS Configuration details. Refer 

OmniOMS 12.0 Composition Designer Installation and Configuration Guide. 

5. Select Secured checkbox for using PCI-DSS enabled cabinet. 

6. Click on Get Cabinets to fetch a list of cabinets and then associate the desired cabinet to OmniOMS. 

7. Select the desired Cabinet Name from the dropdown list. 

8. The Database Type of the selected cabinet is fetched and shown automatically. 

 

 
Figure 4.3 

9. Click Next. All the tables present in the selected database are populated.  

10. Select the table that you want to add to Dataset, from the list box on LHS and click >. 
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Figure 4.4 

 

11. Click >> to add all the tables in the list without selecting them. 

12. Click <to remove a selected table from the list. 

13. Click <<to remove all the tables from the list. 

 

 
Figure 4.5 
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14. Click Back if you want to go to the previous step. 

15. Click Finish to finish and save the settings else click Cancel. The Define Relations screen appears, 

displaying the selected tables, as shown in the following figure:  

 

 
Figure 4.6 

 

16. Associate the selected tables using a unique field. This field will act as a link between multiple tables 

of a dataset. 

17. Link the tables by using the following steps: 

a) Select the checkbox corresponding to the primary key field in the master table. The 

corresponding query for the action is displayed below, in the screen, as shown in the following 

figure: 
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Figure 4.7 

 

b) Drag the mouse from the primary key field to the foreign key field in the transaction table to 

link two tables, as shown in the following figure: 

 

 
Figure 4.8 
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18. Select the checkboxes of the fields that you want to use in report design. 

19. You can click Add Table to open the Relations Selection dialog box for adding more tables. 

20. Click OK to save. The message box appears asking whether you want to save the changes or not. 

21. Click Yes to save the changes. Designed relation saved successfully message appears: 

22. Click OK on the message box. Click OK again in Define Relations screen. The datasets that you defined 

are added in the Field Explorer.  

 

 
Figure 4.9 
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4.1.1.1 Dataset field rights 
Users have been given the option to give rights for the columns from the table to mark it as Read-Only 

Columns when Creating/Modifying a Dataset. 

To Define Dataset Field Rights: 

1. Follow the steps from 1 to 13 of Create New Dataset section. 

2. Once the user clicks on Finish button in Relationship Manager Wizard screen, Define Relation screen 

appears. 

 

 
Figure 4.10 

 

3. Here, select all column option will be available to the user for selecting the columns inside the table. 

4. Click on Field Rights button to set the selected columns as read-only. Dataset Field Rights dialog box 

appears. 
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Figure 4.11 

 

5. To add columns as read-only fields: 

Select the desired columns from Fields and click on Add to add them to Read-only Fields section. 

 

 
Figure 4.12 
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6. To remove read-only fields: 

i. Select the desired read-only columns from the list of Read only Fields. 

ii. Click Delete to remove the read-only rights. 

 

 
Figure 4.13 

 

7. Click OK to save the changes. A dialog box appears whether you want to save the changes or not. 

Click Yes to confirm. 

8. The designed relation is now saved successfully message appears. Click on OK to close the message 

box. 

 

To Modify the Designed Relation: Modification can be done in Check out mode only. 

1. Right-click on the Dataset. 
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2. Select the Modify option. Modify Relation screen appears. 

3. Click on Field Rights. 

4. Modify the changes as required and save it. 

 

4.1.2 Importing XSD 
The Dataset can also be created by importing an XSD (XML Schema Definition) file. 

To Import XSD: 

1. Select a Folder in the Object tab. 

2. Click on Dataset tab and then right-click on Dataset Collection.  

3. Go to New→Import XSD. 

 

 
Figure 4.14 

 

4. A new dataset is created as shown in the figure: 

 

 
Figure 4.15 
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5. Rename it as required and press Enter. As soon as you press Enter on your keyboard, a dialog box 

appears. 

 

 
Figure 4.16 

 

6. Click on Browse File button. Open dialog box appears. 

7. Navigate to the XSD file that you want to import for the Dataset and click Open. 

8. The path of the selected XSD file appears in Browse File textbox. 

 

 
Figure 4.17 

 

9. Click OK. A message box appears displaying that XSD imported successfully. Click OK to close the 

message box. 

10. The Dataset created by importing XSD appears under Dataset Collection. 

 

 
Figure 4.18 
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4.1.3 Importing JSON 
The Dataset can also be created by importing JSON file. 

To Import JSON: 

1. Select a Folder in the Object tab. 

2. Click on Dataset tab and then right-click on Dataset Collection.  

3. Go to New→Import JSON. 

 

 
Figure 4.19 

 

4. A new dataset is created as shown in the figure: 

 

 
Figure 4.20 

 

5. Rename it as required and press Enter. As soon as you press Enter on your keyboard, a dialog box 

appears. 
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Figure 4.21 

 

6. Click the Browse File button. An open dialog box appears. 

7. Navigate to the JSON file that you want to import for the Dataset and click Open. 

8. The path of the selected JSON file appears in Browse File textbox. 

 

 
Figure 4.22 

9. Click OK. A message box appears displaying that JSON imported successfully. Click OK to close the 

message box. 

The Dataset created by importing JSON appears under Dataset Collection. 

 

 
Figure 4.23 
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4.1.4 Batch generation using JSON-DB dataset 
This chapter explains the following: 

• Creation of JSON-DB Dataset 

• Check-in JSON-DB Dataset 

• Associating Dataset with Communication Group 

• Creating report under selected Communication Group 

• Previewing report 

• Batch generation using JSON-DB 

 

To create a new JSON-DB dataset and perform batch generation using it, follow the below steps: 

Creating JSON-DB Dataset 

1. Open the Dataset tab, then right-click Dataset Collection node.  

2. Click New, then select JSON-DB Dataset. A new dataset gets added to the list. 

 

 
Figure 4.24 

 

3. Rename the dataset as per your requirement. 

4. Click the dataset name. The Relationship Manager Wizard appears. 

It displays the database configuration details, that is, the hostname or server IP address and the port 

number of the database. 

5. Click Get Cabinet to select the cabinet in which the data table is present. The Cabinet Name and 

DataBase Type details appear. 
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NOTE: 

You must maintain a table in the selected cabinet containing two columns, wherein one column contains the Master Key, and 

the other column contains the data stored (as per the JSON Schema) corresponding to the specified master key . For 

previewing data in OmniOMS CDG, you need to provide the master key to view the data stored in the corresponding column 

of the data table. 

 

 
Figure 4.25 

 

6. Click Finish. The JSON DB Dataset Details dialog appears. 

The name of the selected cabinet appears. 

7. The Table Name dropdown contains all the tables present within the selected cabinet. Select the 

table where the data is present.  

8. Select the name of the Master Key Column where master keys stored. 

9. Select the name of the JSON Data Column where data is stored corresponding to the master keys. 

10. Click Browse to upload the JSON Schema based on which the data was stored in the table. 
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Figure 4.26 

 

11. Click OK. A dialog indicating successful saving of JSON-DB Dataset details appears. 

12. Click OK to close the dialog. 

 

Check-in JSON DB Dataset 

13. Right-click the dataset name under Dataset Collection node. 

14. Click Check-in. The Check-in Information dialog appears. 

The Check-in Version appears by default.  

15. Enter Check-in Comments and click OK. 
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Associating Dataset with Communication Group 

16. Click Objects to open the related tab.  

17. Select the required Category and then the Communication Group with which you want to associate 

the created JSON-DB dataset. 

The Dataset Gallery appears on the right-side of the screen. 

18. Search the dataset set by name and select it. The Associate Dataset with Communication Group 

dialog appears. 

19. Click Yes to confirm association. A dialog indicating successful association appears. 

20. Click Ok to close the dialog. 

 

Creating report under selected Communication Group 

21. Right-click the required baseline report node under the selected communication group. 

22. Click New → Report → select how you want to create report (say DesignonCanvas). A new report 

gets added to the list. 

 

 
Figure 4.27 

 

23. Rename the report as per your requirement. 
 

Previewing report 

NOTE: 

The designing of report occurs on the basis of JSON associated to the Communication Group. 

 

24. Expand the created report node. Then, expand the New Page node. 

25. Click Layer. 
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26. Click Dataset to open the related tab. Expand the created dataset node to view the fields defined 

within the uploaded JSON schema. 

27. Drag and drop the required fields on the canvas. 

28. Click the preview icon  present in the standard toolbar. The preview for the first master key 

defined within the data table appears by default. 

29. To preview for a specific master key, click the preview dropdown and select the Preview without 

Pre-print Layer. The Enter Request Information dialog appears. 

30. Enter the required Master Key and click OK. The preview appears. 

 

NOTE: 

If the input JSON for the selected master key does not comply with the associated JSON schema, the JSON Validation Error 

appears. Click “Ok” to close the dialog and enter valid JSON input (as per schema). 

 

Batch generation using JSON DB Dataset 

31. Right-click Jobs under the selected communication group.  

32. Select New → select the type of job you want to create (say Print Job). The Configure Print Job dialog 

appears. 

33. Enter Name of the report. 

34. Select the baseline Report. 

35. Select the Output Format of the report. 

36. Select the Filename, then click Browse to select the Output File Path. 

In the Filtration Criteria section, the Original Query appears by default. It allows batch generation of 

the selected jobs for all the master keys present in the table. 

37. (Optional) To run batch generation for specific keys, enter the Filter Condition.  

For example, when masterkey < = 5. 
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Figure 4.28 

 

38. Click OK. A dialog to confirm the changes made to the job configuration appears. 

39. Click Yes to confirm the job details. 

 

NOTE: 

To run the job for batch generation, you must associate it with a schedule in OmniOMS Admin Workspace. 

4.1.5 Check-in dataset 
To check-in a Dataset: 

1. Go to Object Gallery→Dataset Collection. 

2. Select the dataset to be checked-in and right-click on the dataset. 

3. Click Check-In to check in the selected dataset. 
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Figure 4.29 

 

4. Specify Check-in Comments that you want to demonstrate for the dataset. 

 

 
Figure 4.30 

 

5. Click OK to complete the dataset check-in process. 

 
 

4.1.6 Configuring dataset field properties 
The OmniOMS Composition Designer allows you to configure the properties of imported XSD and 

JSON. 
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To configure the dataset field properties, follow the below steps: 

1. Importing an XSD only enables the Set Field Type button. Open Dataset Field Properties to view all 

the dataset fields associated with the particular XSD. Then, click Set Field Type. 

 

 
Figure 4.31 

 
It allows mapping of the following: 

• Read only: Allows the mapping of read only data fields. 

• Date type: Allows the mapping of date type data fields. 

• List type: Allows the mapping of list type data fields. After specifying list box field, you need to 

specify list items associated to that list box field. 

Select fields and arrange them in the respective columns. Click Delete to delete the mapping of data 

field. After placing the data items, the fields appear in an arranged order. 
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Figure 4.32 

 

Click Ok and then Save to save the designed relation. You need to Check-in → Baseline → create an on-

demand job to run it in the Communication Editor. 

 

4.1.6.1 Setting display name for data fields 
A display name or alias name is an alternative name given to a data field. It provides a more user-

friendly or descriptive label for the data field. CDG provides the capability to customize the display 

names of data fields that are visible when you access a letter or contract in the Communication Editor. 

 

To set display name for data fields, follow the below steps: 

1. In the Dataset pane, right click the required JSON or XSD dataset and select Dataset Field 

Properties. The Define Relations dialog appears. 

2. Click Set Field Type. The Set Field Type dialog appears. 

3. Click Set Display Name. The Set Display Name dialog appears. 

4. In the Display Name column, specify the required alias name(s) against the required data field(s). 

For example, for a data field named company name, you can specify a display name Organization 

Name. 

5. Click OK. The display name(s) gets saved. 
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6. Click OK to close the Set Fields Type dialog. 

7. Click OK to close the Define Relations dialog. 

 

NOTE: 

For a checked-in report, perform the check-out operation before setting display name for data fields.  

 

4.2 Object 
The object contains the following folders: 

• Output Management System 

• Enterprise Components 

 

4.2.1 Output management system 
The Output Management System consists of the following objects: 

Category: The category tab allows you to create different categories as per the requirement under the 

Output Management System. The category will act as folder segregation so that a user can specify a 

different name for a different category like Mutual Fund, Loans, and more. Category can contain multiple 

Communication Group. 

Communication Group: Communication Group would act as a package for communication. All the 

Reports, Components, Jobs will be defined within a communication groups. 

Output Format: The Output format folder is created automatically in a category.   

Reports: A report can be designed by drag-drop components from the component gallery or by directly 

using controls to design a report. Components having the same dataset as that of communication group 

can be used for designing a report. 

Jobs: A job is a part of the Communication Group, and the jobs folder gets created when a New 

Communication Group is created. You can create multiple jobs as per the requirement. Jobs will be 

scheduled through Cycle Management for a Production run. These jobs will be rule-driven and will decide 

the type of output that will be generated i.e. print, e-mail or text. 
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Components: A Component acts as a report sub-part and facilitates report designing. You can design 

various components in Composition Designer. You can add images, captions, database fields and create 

a component. 

Note 

• Communication designer templates are visible as reports, but the design itself is not accessible. You can only 

preview the template. 

• Only datasets associated at the communication group level are visible. 

• Components and Master Templates are the same but cannot be reused in a CDG template. 

 

4.2.1.1 Category 
To define a new category and create a communication group: 

1. Right-click on Output Management System and select New->Category to define a new Category. 

 

 
Figure 4.33 

 

2. As soon as a Category is created, an Output format is created below the Category. 

 

 
Figure 4.34 
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4.2.1.1.1 Output formats 

The Output Format folder gets created automatically within a category. It supports the following type of 

output formats: PDF, DOC, Docx, xlsx, xls,or csv. 

 

NOTE: 

PS is the only output format that supports Bundle. 

 

To create a new PDF, Doc, Docx, xlsx, xls,or csv output format, follow the below steps: 

1. Right-click Output Format → New→Output Format. The Output Format dialog appears. 

 

 
Figure 4.35 

 

 
Figure 4.36 

 

2. Enter the Name, Description and select Output Type as PDF, DOC, DOCX, XLSX, XLS, or CSV as per 

your requirement using the dropdown. 

A dialog box appears asking whether to change the settings or not. Click Yes to save the changes.  

A dialog indicating the successful submission of information appears. 
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NOTE: 

To set the output format other than PDF, you need to change the value of tags EnableExcelOutput and EnableWordOutput to 

Y in CDG.ini during the configuration. 

 
4.2.1.1.2 Communication groups 

To create a new Communication Group: 

1. Right-click on Category to create a new Communication Group as shown below: 

 

 
Figure 4.37 

 

2. Creating a new Communication Group opens the available Dataset Gallery on the RHS of the 

composition designer. 
 

 
Figure 4.38 

3. The Communication Group has the following design objects: 

• Reports 

• Jobs 

• Components 
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4. Associate a dataset from the available datasets with a Communication Group. Reports and 

Components created within a particular Communication Group will be using the associated dataset 

only. 

5. Select the dataset to be linked and click on Link Dataset with Communication Group. 

 
Figure 4.39 

 

 
Figure 4.40 

6. Click Yes to associate the dataset with the Communication Group. 

7. The Dataset successfully associated with the communication group message appears.  

 
4.2.1.1.2.1 Reports 

Refer section Design Reports. 

 

4.2.1.1.2.2 HTML reports 

Refer section Design Reports. 

4.2.1.1.2.3 Message reports 

Refer section Design Reports. 
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4.2.1.1.2.4 Letter reports 

Refer section Letter Designer. 

 

4.2.1.1.2.5 WhatsApp reports 

Refer section Create WhatsApp Report. 

4.2.1.1.2.6 Jobs 

Refer section Add Jobs. 

 

4.2.1.1.2.7 Components 

Refer section Add Components. 

 

4.2.1.1.2.8 Contracts 

Refer section Contract Designer. 

 

4.2.1.1.2.9 Letters 

Refer section Letter Designer. 

 

4.2.1.1.2.10 Importing excel 

Refer section Import Excel. 

 

4.2.1.2 Sorting objects and datasets 
OmniOMS CDG allows you to sort the list of objects and datasets using: 

• CDG.ini  

• Composition Designer UI 

 

Sorting objects or datasets using CDG.ini 

By default, the list of objects or datasets is sorted by name. Use the SortbyDate and OrderbyDescending 

parameters to sort objects and datasets by date or by descending order. 

 

Following table describes the parameters used to sort list of objects or dataset: 
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Functionality Settings 

Name 
Mandatory 

(Yes/No) 
Description Valid Values 

Default 

Values 

SortbyDate Yes Enables or disables the sorting of reports and 

dataset by creation date and time.  

• If SortbyDate = Y, then reports and dataset 

get sorted by creation date and time. 

• If SortbyDate = N, reports and datasets 

maintain their default sort, that is by 

name. 

‘Y’ or ‘N’ N 

OrderbyDescending Yes Enables or disables the sorting of reports and 

dataset in descending order. In combination 

with the SortbyDate parameter, it generates the 

following results: 

• If SortbyDate = Y and OrderbyDescending = 

N, then reports and dataset get sorted in 

ascending order of creation date and time. 

• If SortbyDate = Y and OrderbyDescending = 

Y, then reports and dataset get sorted in 

descending order of creation date and 

time. 

• If SortbyDate = N and OrderbyDescending 

= N, then reports and dataset get sorted in 

ascending order of name. 

• If SortbyDate = N and OrderbyDescending 

= Y, then reports and dataset get sorted in 

descending order of name. 

‘Y’ or ‘N’ N 

 

Sorting objects or datasets using UI 

To sort objects or dataset in descending or ascending order using UI, follow the below steps: 

40. Right-click Output Management System under Object Gallery. 

41. Click Sort By, then select: 

• Ascending – to sort the list of objects or dataset in ascending order by date or name  
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• Descending – to sort the list of objects or dataset in descending order by date or name. 

 

 
Figure 4.41 

 

NOTE: 

The sorting of list of objects or dataset depends on the value assigned to “OrderbyDate” parameter. 

• If OrderbyDate is set as Y, then the list gets sorted by date in ascending or descending order. 

• If OrderbyDate is set as N, then the list gets sorted by name in ascending or descending order. 

 

4.2.1.3 Searching reports 
OmniOMS CDG allows you to search the required report by name. The search gets executed at the report 

node level. 

 
To search the required report, follow the below steps: 

1. Select the required Category → Communication Group → Report. The filter icon appears on the 

upper-right corner of the Object Gallery. 

 

 
Figure 4.42 

2. Click the filter  icon. The Filter Properties dialog appears. 

The name of the selected Category and Communication Group appears. 
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3. Enter the name of the report that you want to search in the Report Name Contains field. 

 

 
Figure 4.43 

 

NOTE: 

• Use the “Clear Filter” option to remove the filter applied to the report list. 

• The “Clear All Filter” option is also available upfront. To clear all the filters applied to the reports list, Right-click “Output 

Management System” → “Clear All Filters”. 

 

 
4. Click OK. The list of reports gets filtered based on the specified criteria. 

 

NOTE: 

• The Report Name field is not case sensitive.  

• Also, you can mention the complete report name, or anything related to get the required search results. For example, if 

you want to search a report named Elite Home Loans, you can either enter the complete name or type any part of the 

name (say Loans) to get the required search result. 

 

4.2.2 Enterprise layout components 
For information on the enterprise layout components, refer to the Add and manage layout 

components section. 
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4.2.3 Enterprise master layout 
For information on the enterprise master layouts, refer to the Add and manage master layouts section. 

4.3 Properties 
The Properties tab displays the information about the document selected in the Reports tab. Click 

Properties tab to view the Properties tab. 

 

NOTE: 

The Properties tab appears only when the Maker Checker is enabled. 

 

 
Figure 4.44 

 

Right-click the required report in the Objects pane and click Properties. 

The Report Properties dialog appears. It displays the following details of the selected report: 

• Name of the Category 

• Name of the Report Type 

• Name of the Author who has designed the template 

• Date and time on which it was created 

• Date and time on which template was last modified 

• Name of the user who has modified the template 

• Date and time on which template was last accessed 

• Size of the report 
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• Approval status  

 

You can modify the following properties of the report: 

• Report Title 

• Report Author 

• Report Subject 

• Report Keyword 

• Report Language (in case of accessible PDFs, this field decides the language used for read out loud 

feature) 

 

Select the Right to Left Text Direction checkbox to change the direction of text from Right to Left. By 

default, it is Left to Right. 

Select the Accessible PDF checkbox to create an accessible PDF. 

 
Figure 4.45 

 

General Tab displays the basic information of Report. User can select the checkbox for Right To Left Text 

Direction for writing text from right to left direction. 
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Details Tab 

 

 
Figure 4.46 

 

In this tab, the user can select to Enable Demand Request to enable Report for On-demand generation. 

Specify Product Name, Product Description and select Output Format. 

 

In the case of HTML Report Properties and Message Report Properties, the user can select Enable 

Tracking to enable mail tracking (read, unread and bounce) and SMS tracking (delivered and 

undelivered), respectively. Refer to the below figures: 

 

    Figure 4.48 

 

 
Figure 4.47 
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Paper Setup Tab: 

 

 
Figure 4.49 

 

1. Select the required Paper Size option from the combo box. The available options are: Letter, Legal, 

Tabloid, A3, A4, A5, B5, and Custom. 

2. Select the Dimensions (in inches) of the page. Use the up and down button to change the dimensions. 

The Dimensions field gets activated only when Custom is selected from Paper Size. 

3. Select the required Orientation of the page from the displayed options. 

4. Set the Margin (in inches) of the Header and Footer of the document by using the up and down 

buttons. 

5. If you want the header or footer to appear from second page onwards, select the Show 

Header/Footer from 2nd page checkbox. 

6. Click OK to apply the settings else click Cancel. 
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Notification Tab: 

 

 
Figure 4.50 

 

1. Click on the Notification tab to add an E-mail notification. 

2. Specify the To and CC details. 

 

NOTE: 

To fields are enabled after selecting the Email Notification Required checkbox. The CC fields are enabled after selecting 

Approval Requester or Approver or both checkboxes. 

 

3. Click on OK. This will enable the product to send an e-mail notification to the selected list to notify 

the completion of generation, e-mail or printing services. 

 

Metadata Tab: 

The Metadata tab allows you to configure the metadata tag values for the report. For information on 

how automation  
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Accessibility 

The Accessibility tab enables you to make PDFs accessible to everyone, including individuals with special 

needs. For example, a blind person can access PDF content using a voice feature. 

To enable the accessibility feature, follow the below steps: 

1. Right-click the required report in the Objects pane and click Properties. 

2. Click the Accessibility tab to enable accessibility in PDF. 

3. Select the Enable Accessibility in PDF checkbox to enable the feature. 

4. (Optional) Select the Right to Left Table Reading Order checkbox to set the reading order in a 

table from the right to left column. This is primarily used for languages that support right-to-left 

writing. 

5. Click OK to save the details. 

NOTE: 

The accessibility tab only displays in the textbox, rich text box, table cells, and images section after you enable it from 

the report properties pane. 

 

5 PreMenu options 
Composition Designer provides the following Menu options: 

• File 

• Edit 

• View 

• Insert 

• Format 

• Function 

• Tools 

• Help 

 

5.1 File menu 
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The File Menu contains options related to the handling of documents such as Save, Import Word File, 

Export Templates, Import Template, and Import PDF File etc. The File menu is shown in the following 

figure: 

 

 
Figure 5.1 

 
The File Menu has the following options: 

• Save: Saves the current document. 

• Import Word File: Allows you to import a contract designed in MS Word file. 

• Export Templates: Allows you to export templates to your machine. 

• Import Template: Allows you to import template from your machine. 

• Import PDF File: Allows you to import a PDF directly. 

• Exit: Exits from the Composition Designer. 

 

5.1.1 Save 
To save a document, select File→ Save or press the Ctrl+S key. 

 

 
Figure 5.2 
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5.1.2 Importing word file 
You can import a Contract designed in MS Word file. 

To Import Word File: 

1. Create the Contract Layer.  

2. Following dialog box appears. 

3. Select Using Word File radio button. 

4. Click on ellipsis button present in front of Using Word File option. 

 

 
Figure 5.3 

 

5. Open dialog box appears. Select the required word file. 

The required word file gets uploaded, and its status appears on the screen. 

 

 
Figure 5.4 
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6. Or select the Contract Layer (Communication Group → Report Designs → Contract → Page → 

Layer) to which you want to import the word file. 

 

 
Figure 5.5 

 

7. From the File menu, select Import Word File. 

8. Open dialog box appears. Navigate to the file that you want to import and click Open.  

9. The imported file appears. 

 

 
Figure 5.6 

 

5.1.3 Exporting templates 
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The export templates feature allows you to export a single or multiple templates from the Composition 

Designer to your local machine. The user can view all the available templates in the Template Gallery. 

To Export Templates: 

1. Select the required Template and then create its Baseline. 

 

 
Figure 5.7 

 

2. From the File menu, select Export Templates. Template Export dialog box appears. 

 
Figure 5.8 

 

3. Select the required checkboxes and click Export. Browse For Folder dialog box appears. 
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4. Select the folder where you want to save the template and click OK. 

5. Data fully exported message appears. Click OK to close the message box. 

6. Click Cancel to close the Template Export dialog box. 

 

NOTE: 

The exported template is saved as an MDB (Microsoft Access Databases) file. 

 

5.1.4 Importing template 
The import template option allows you to import reports, layout components, and master layouts for 

the selected Communication Group. The names of the Category and Communication Group must be the 

same to that of the names of Category and Communication Group existing in the template to be 

imported. 

 

NOTE: 

• To import a report template, you must first export it to your local machine.  

• You can carry templates exported from Oracle and import in Postgres environment. 

 

To Import Template: 

1. Create a Category with the same name to that of the Category existing in the template to be 

imported. 

2. Within this Category, create a Communication Group. The name of this Communication group has 

to be same as that of the Communication Group in the template to be imported. 

3. Select the Communication Group. 

4. From the File menu, select Import Template. Open dialog box appears. 

5. Select the file to be imported and click Open. 

6. Import Template dialog box appears. 
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Figure 5.9 

 

7. This dialog box consists of the following fields:- 

 

Fields Description 

New Template Select this checkbox, if the template is to be imported as an altogether new Template. 

New Version Select this checkbox, if the template is to be imported as a new version of the imported 

template. 

Category This is a static system-defined field, which defines the category of the template.  

Communication Group This is a static system-defined field, which defines the communication group of the 

template. 

Template Name This is a static system-defined field that provides the template name which is imported. 

Job This is a static system-defined field that defines the job of the template which is to be 

imported. 

Import Decision Table Select this checkbox, if the associated Decision Table is to be imported along with the 

template. 

Import Output Format Select this checkbox if you want to import the output format associated with the template. 

Import Numerical 

Sequence Details 

Select this checkbox if you want to import the numbered list sequence along with the 

template. Refer Apply Numbering. 

Import Dataset Select this checkbox, if the associated Dataset is to be imported along with the template. 

New Dataset Select this checkbox, if the associated Dataset is to be imported as the new Dataset. 
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New Version Select this checkbox, if the associated Dataset is to be imported as the new Version. 

Associate Dataset with 

the Communication 

Group 

Select this checkbox, if the Dataset is to be associated with the Communication Group. 

Modify Dataset Details Click on this to update the DB Credentials. 

 

8. If Modify Dataset Details button is clicked, Update DB Credential dialog box appears. 

9. This dialog box consists of the following fields:- 

 

Fields Description 

Available DSN DSN implies a Data Source Name. Enter the database details here. 

Database Type Select the Database Type from the available dropdown list. 

Server IP Enter the Server IP Address.  

Service Name Enter the Database Service Name, if applicable. 

Port No. Enter the Port Number. 

Username Enter the Username of the database. 

Password Enter the Database Password. 

 

 
Figure 5.10 

10. Check the checkboxes of the required reports and click Import. 

11. Import operation completed successfully message appears. Click OK to close the message box. 
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5.1.5 Importing PDF file 
You can import a previously designed PDF document with Import PDF File. 

To import a PDF: 

1. Whilst selecting the default layer, go the File menu and select Import PDF File.  

 
Figure 5.11 
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The following screen appears. 
 

 
Figure 5.12 

 

2. Select the option Over Write Data if you want to overwrite the previous data or select the option 

Append Page Then Import Data. 

Click Next. The following screen appears. 

 

 
Figure 5.13 
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3. Click the Select File to Import button to select the PDF to be imported. 

Navigate to the file that you want to import and click Open. The path of the selected file is displayed 

in the Select File to import field. 

4. Enter Password of the chosen PDF, if the PDF is password protected. 

5. Under Page Options, enter the pages range that you want to import. It can be any of the three 

options: 

i. All Pages 

ii. Pages 

iii. Page range 

6. PDF Object can import Text, Round Rectangle, Rectangle or/ and Image; select the checkbox to 

import any one or all of the objects. 

7. Click Finish to complete the Import process. 

 

5.1.6 Templates migration 
To Migrate contracts from any other database, carry out the following steps:- 

1. Associate the required database in the OMS Services. 

2. Click on File→ Export Migration. 

3. Migrate Templates dialog box appears. 

 

 
Figure 5.14 
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4. Select the required Template. 

5. Click on Migrate button. 

 

5  

Figure 5.15 

 

5.1.7 Exit 
To exit from the Output Management System, select File → Exit. 

5.2 Edit menu 
The Edit menu contains options to edit the added components in the design. The Edit menu is shown in 

the following figure: 

 

 
Figure 5.16 

 

The Edit menu has the following options: 
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• Undo: This option is used to reverse your last action. Ctrl+Z keyboard keys can also be used to 

perform this option. 

• Redo: This option is used to reverse your last Undo. Ctrl+Y keyboard keys can also be used to perform 

this option. 

• Cut: This option is used to cut the selected component. 

• Copy: This option is used to copy the selected component. 

• Paste: This option is used to paste the cut/copied component at a specified point. 

• Select All: This option is used to select all the components. Ctrl+A keyboard keys can also be used to 

select all the components. 

• Delete: This option is used to delete the selected components. 

 

5.3 View menu 
The View Menu contains options related to the designing and viewing of documents. The View menu is 

shown in the following figure: 

 

 
Figure 5.17 

 

The View menu contains the following options: 
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• Show Highlighters 

• Draw Grid 

• Report Browser 

• Font Style Gallery 

• Dataset Gallery 

• Component Gallery 

• Paragraph Gallery 

• Version Explorer 

• Recycle Bin 

• Header And Footer  

• Pre-footer 

 

5.3.1 Show highlighters 
The Show Highlighters option is used to display/hide the boundary of a container in the design mode or 

preview mode. 

 
5.3.2 Draw grid 
The primary purpose of the Draw Grid feature is to assist you in aligning and positioning elements with 

precision during report design.  A grid consists of a series of evenly spaced horizontal and vertical dots. 

When you draw an element, say a Rectangle on the design area, it automatically snaps or aligns to the 

nearest point on the grid. If you move or resize an existing element, it automatically aligns with the 

gridlines. This feature is useful for creating uniform designs without having to manually adjust elements 

in the report.  

 

To draw a grid, follow the below steps: 

 

1. In the Object Gallery → Object pane, navigate to the required report. 

2. Go to the View menu and click Draw Grid. 

3. Select one of the following grid options: 
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• 5 X 5 Grid — This grid comprises five evenly spaced vertical and horizontal dots, creating a grid of 25 

cells. Multiple such grids cover the entire design area. 

• 10 X 10 Grid — This grid includes ten evenly spaced vertical and horizontal dots, creating a grid of 

100 cells. Multiple such grids cover the entire design area. 

• 15 X 15 Grid — This grid consists of fifteen evenly spaced vertical and horizontal dots, creating a grid 

of 225 cells. Multiple such grids cover the entire design area. 

• 20 X 20 Grid — This grid incorporates twenty evenly spaced vertical and horizontal dots, creating a 

grid of 400 cells. Multiple such grids cover the entire design area. 

The selected grid appears in the design area. 

To remove the grid from the design canvas, go to the View menu and select Draw Grid. Then, 

deselect the chosen grid option from the list. 

 

5.3.3 Font style gallery 
Font Style Gallery is used to display pre-configured font style. User can set Font Size, style, back color, 

fore color and save it as a format with a specific name to be displayed in Font style Gallery. Font styles 

from Gallery can be applied to text and database fields. These are typically used to adhere to branding 

guidelines so that every user across the organization can use pre-configured styles. 

 

 
Figure 5.18 
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Adding Formats 

To add formats in the formats gallery: 

4. Select an object or textbox placed on the design canvas. 

5. Right-click the object. 

6. From the shortcut menu, select Save Format. The Format Name dialog box appears, as shown. 

 

 
Figure 5.19 

 

7. In the Format Name textbox, type the name of the format. 

8. Click OK. The format name is added in the Font style gallery dropdown list available on the 

Formatting toolbar. 

 

5.3.4 Dataset gallery 
The Dataset Gallery option is displayed on the RHS of the composition designer. It shows the complete 

list of all the available datasets as per the batch size that can be changed by the user. 

 

 
Figure 5.20 
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5.3.5 Component gallery 
The Component Gallery displays all the components (Local Components and Enterprise Components) 

with versions. You can drag and drop components from Component Gallery. 

 

 
Figure 5.21 
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5.3.6 Version explorer 
The Version Explorer pane displays the different versions of an object (report, component, and master 

layout). Whenever you check in an object, a new version of the object is created in the repository. 

 

For example, an employee at a financial organization, responsible for designing templates for customer 

communication, can leverage the Version Explorer pane. This pane allows them to view and manage 

various versions of objects, including reports, components, and master layouts, thereby enhancing 

decision-making and facilitating content customization for optimal communication with customers. 

 

To view the different versions of an object, follow the below steps: 

1. From the Object pane, right-click a specific object. The list of different operations appears. 

 
Figure 5.22 

 

2. Select Show Version History. The Version Explorer pane appears at the bottom of the page 

displaying the following details:  

• Version — Displays the selected object version number. 

• Check In Date — Displays the object checked-in date. 

• Check In By — Displays the user name who checked in the object. 
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• Check In Comments — Displays the brief description of the checked-in object. 

Additionally, in the Version Explorer pane, you can select any specific version and perform the 

permitted operations using the following buttons: 

• Baseline — This button allows you to set the selected object version as a finalized 

version report or component. 

When you select the Baseline button, the Baseline Information dialog appears. In the Baseline 

Comments section, you can provide a brief description of the selected object version to save as 

a baseline. Click OK to finalize. 

 

NOTE: 

Only the most recently checked-in version can be baselined.  

 

• View — This button allows you to view the design of the selected object version. 

When you click the View button, a preview of the selected object version appears on the design 

canvas. Furthermore, to preview the selected version in PDF format, you can click the Preview 

Report icon   located in the upper-right corner of the page. 

• Check Out — This button allows you to check out the selected object version. 

When you click the Check Out button, the Composition Designer dialog appears. Click Yes to 

proceed with the check-out. 

Upon checking in the object, a new object version gets created and appears in the Version 

Explorer pane. From there, you have an option to baseline it if necessary. 
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5.3.7 Recycle bin 
 

The Recycle Bin serves as a temporary repository for deleted items, that is, reports, layout components, 

and master layouts. When you delete these items, they get transferred to the Recycle Bin, giving you the 

choice to either restore or permanently delete them from the system. 

 

To access the Recycle Bin, click the Recycle Bin option located below the Object Gallery pane. If this 

option is not visible, navigate to the View menu and select Recycle Bin. The Recycle Bin pane appears at 

the bottom of the screen. Alternatively, you can use the keyboard shortcut Alt + Shift + T to instantly 

open the Recycle Bin. 

 

Restoring a deleted item 

To restore a deleted item, follow the below steps: 

 

1. In the Recycle Bin pane, select the checkbox against the required item. 

2. Click Restore. A dialog indicating the successful restoration of the item appears.  

3. Click Yes if you want to continue restoring item. Alternatively, click No to remain on the currently 

opened page. 

 

NOTE: 

On restoring a report associated with a master layout or a component, that are currently in the deleted state. Then, in such 

a case, the applied master layout and the component also get restored along with the report.   

 

Deleting an item permanently 

To delete an item permanently, follow the below steps: 

 

1. In the Recycle Bin pane, select the checkbox against the required item. 

2. Click Delete. A dialog confirming the deletion of the item appears.  

3. Click Yes to confirm. A dialog indicating the successful removal of the item from the recycle bin 

appears. 

4. Click OK to close this dialog. 
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NOTE: 

You cannot delete a master layout or a component, that is, associated with a report. So, in such a case, you need to delete 

the report first to eliminate the dependency, to proceed further. 

 

5.3.7.1 Deleting a component 
 

To delete a component, follow the below steps: 

 

1. From the Object pane, right-click the required layout component: 

For local layout:  

a) Expand the required category > communication group > Layout Components node. Then, right-

click the required local layout component.   

For enterprise layout component: 

b) Expand the Enterprise Layout Components node and then right-click the required enterprise 

layout component.  

2. Select the Delete option from the context menu. 

NOTE: 

Ensure the component is in a checked-out state.   

 

A delete dialog appears. 

3. Click Yes to confirm. The component gets deleted and moves to the recycle bin. For information on 

how to restore or permanently delete a component from the recycle bin, refer to the Recycle Bin 

section. 

NOTE: 

An informative message appears when you attempt to delete a layout component linked to one or more reports. In this 

case, unlink the component from the report(s) first and then proceed with the deletion. 
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5.3.7.2 Deleting a master layout 
To delete a master layout, follow the below steps: 

 

1. From the Object pane, right-click the required master layout: 

For local master layout:  

 

Expand the required category > communication group > Master Layouts node. Then, right-click the 

required local master layout.  

For enterprise master layout: 

 

Expand the Enterprise Master Layout node and then right-click the required enterprise master 

layout.  

2. Select the Delete option from the context menu. 

NOTE: 

Ensure the master layout is in a checked-out state.   

 

A delete dialog appears. 

3. Click Yes to confirm. The master layout gets deleted and moves to the recycle bin. For information 

on how to restore or permanently delete a master layout from the recycle bin, refer to the Recycle 

Bin section. 

NOTE: 

An informative message appears when you attempt to delete a master layout linked to one or more reports. In this case, 

unlink the master layout from the report(s) first and then proceed with the deletion. 
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5.3.8 Header and footer 
The Header and Footer are enabled at Reports → Report level. Select View →Header and Footer to 

show Report Header and Footer to enable users to add design objects to the Header and Footer area. 

 

Header 

 
Figure 5.23 

Footer 

 

 
Figure 5.24 

NOTE: 

Adding header and footer to report that includes a master layout is not possible. 
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5.3.9 Pre-footer 
A pre-footer is a section of your report that appears just above the footer. You can insert a pre-footer to 

display important information before the users reach the bottom of the page. For example, a pre-footer 

can include an employee’s signature and declaration. Adding pre-footers to reports captures user 

attention, thus increasing user engagement.  

 

NOTE: 

Pre-footers are only applicable to Design on Canvas, Contract, and Letter type reports. 

 
Pre-footers are also helpful in scenarios when the content inside it might vary depending on the data 

bound. For example, you want to display employee information in a table at the bottom of the report 

page. However, the size of the table might change depending on the data inside. So, in such a case, the 

pre-footer automatically adjusts its size depending on the content within the table.  

 

NOTE: 

Pre-footer supports only static tables. 

 

This topic contains the following sections: 

• Designing a pre-footer 

• Adding a pre-footer to report 

 

Designing a pre-footer 

To design a pre-footer, perform the following steps: 

1. From the left pane, select the required report from the list.  

2. Go to the View menu and then select Pre-Footer from the list.  

On selection, a tick mark appears next to the Pre-Footer.   

3. On the right, the design canvas page appears. This page is divided into two portions, one is the 

printable area that contains the report content, and the other is the pre-footer area where you 

can design that section.   

4. Adjust the size by dragging the edges of the pre-footer area.  
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5. Drag-drop the required controls from the Toolbox to the design canvas and configure their 

related properties. 

6. Click Save to confirm the changes. 

7. Then, go to the View menu and then select Pre-footer to exit its design canvas. 

 

Adding a pre-footer 

To add a pre-footer to your report, perform the following steps: 

1. From the left pane, right-click the report and select Properties from the list. 

The Properties dialog appears. 

2. Navigate to the Paper Setup tab of the Properties dialog. 

3. Under the Pre-footer section, select the required option for displaying the pre-footer in your 

report: 

• Show Pre-footer on first page — Adds the pre-footer at the bottom of the first page of your 

report. 

• Show Pre-footer on last page — Adds the pre-footer at the bottom of the last page of your 

report. 

4. Click OK to save the changes.  

 

NOTE: 

Ensure the size of pre-footer does not exceed the calculated limit, which is determined by subtracting the combined height 

of the header and footer from the overall page size. 

 

5.3.10 Ask Marvin 

Marvin is a sophisticated artificial intelligence technology that offers a range of features to generate 

content by enhancing your content creation process. It provides functions like accommodating various 

content requirements, ranging from creating messages and letters, translating the content in different 

languages, and summarizing text.  
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For example: In the banking sector NewgenONE Marvin used to create content for notifications, 

promotional emails, disclaimers, loan reminders, and welcome letters.  

The main attributes MARVIN offers in CDG: 

• Content Generation — Automatically create content for various templates and communication 

types based on user input and industry specifics. 

• Content Improvement — Refine and enhance existing content to make it more effective and 

engaging. 

 

 

 

Generating content with Marvin 

Content generation with Marvin is used for creating communication materials, including welcome 

letters, payment reminders, and promotional content. It allows for extensive customization of 

communication styles, with the added capability of generating content in multiple languages. MARVIN 

also allows you to control the content’s length and tone. This feature streamlines the drafting process 

for communication templates by enhancing efficiency and saving time. 

This topic consists of two main features: 

• Generating content 

• Viewing prompt history 
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Generating content 

To generate content using NewgenONE Marvin, perform the following steps: 

1. Create the required template in the communication group.  

2. Click on Ask Marvin located on the right side of the page, The Ask Marvin pane appears.  

Note 

To enable all Marvin options, it is mandatory to create a text box or a rich text box. 

3. Click on the Content Generation tab. The content generation screen appears  

4. To generate content, enter the following details: 

Fields Description 

Industry  Specify the industry for which you want to 

generate content. There are two options available 

banking and insurance in CDG. Click on the 

dropdown to select the industry. 

Communication Type  Specify the tone in which you want to 

communicate your content. For example: formal 

or casual language. You can select this from the 

dropdown 

Word Count Specify the word count limit between 1 to 500 for 

generating content. 

Output Language Specify the language in which you want to 

generate content. Currently, in three languages, 

you can generate content Hindi, English, and 

French. 

Uniqueness  Specify the uniqueness of the generated content. 

You can set it by using the slider. 

Tone Specify the tone for the generated content. For 

example: Tone can be formal, warning, optimistic, 

and many more. Click on the box to select the 

specific tone. 

Additional Inputs  Specify the additional requirements that you want 

to incorporate in the generated content. 

 

5. Click on Generate to generate the content. You generate content within the control RTB and 

further utilize it in the template. 
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Viewing prompt history 

NewgenONE Marvin has the functionality of saving the generated content as a prompt history. You can 

view this by clicking on the prompt history icon . This allows you to reuse any of the previously 

generated content. In prompt history, the last 50 versions of the generated content are stored, and you 

can select anyone and reuse it. The history section only displays when the rich text box is created. 

To view the prompt history, perform the below steps: 

1. Click on the  to open the prompt history tab. 

2. Hover over to the previously generated content version and click Select to reuse the content. 

3. (Optional) Click Delete, if you want to delete the content. 

 

Content Improvement 

NewgenONE Marvin consists of the ability to improve and refine the existing content. It helps in 

improving your generated text and enhances the reading experience. 

This topic consists of two main features: 

• Improving content  

• Viewing prompt history 
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Improving content 

To improve the generated content using NewgenONE Marvin, perform the below steps: 

1. Create the required template in the communication group.  

2. Click on Ask Marvin located on the right side of the page, The Ask Marvin pane appears. The 

content can only be generated when a text or rich text box control selection is necessary. 

3. Click on the Content Improvement tab. The content improvement screen appears. 

4. In Select Improvement Type section, contains the following details: 

Fields Description 

Fix Spelling and Grammar  It allows you to correct all the spelling and remove 

grammatical issues automatically. To enable it, 

click on the box. 

Simplify Language It allows you to simplify the content in complex 

language and make it more simplified. 

Message Length Optimization It allows you to reduce the length of the content, 

according to your requirement.s 

Tone It allows you to change the tone of the content. 

You can choose the tone from 6 different options:  

Formal, Warning, Crisp, Professional, Optimistic, 

and Persuasive.  

Language Translation It allows you to translate the content to any 

selected language from the following options: 

English, Hindi, and French. 

Additional Inputs  Specify the additional requirements that you want 

to incorporate in the generated content. 

 

5. Click Generate to apply the changes to the content. The previous content is replaced with new 

content. 

Viewing prompt history 

For more details, refer to the section Viewing prompt history. 
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5.4 Insert menu 
The Insert menu allows you to insert various objects in a document, such as Text, Rectangle, and 

Barcode. The Insert menu is shown in the following figure: 

The following are the options of the Insert menu: 

• Text: Allows the user to enter text in the document. 

• Drawing: Allows the user to draw various shapes in a document. 

➢ Line: Allows the user to draw a line in a document. 

➢ Rectangle: Allows the user to draw a rectangle in a document. 

➢ Circle: Allows the user to draw a circle in a document. 

➢ Rounded Edged Rectangle: Allows the user to draw a rectangle with round edges. 

• Barcode: Allows you to create barcode in documents. 

• Symbol: Allows the user to insert various symbols in the document.  

 

5.4.1 Text 
To enter text in the report, follow the below steps: 

1. Click the  text icon in the Object Toolbar and draw a text box on the canvas.  

2. Enter the required text. 

 

 
Figure 5.25 
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A save design dialog appears at regular intervals prompting you to save the design changes. Click Yes to 

save the changes or No to proceed with designing without saving the changes. 

 

5.4.1.1 Orientation 
To set text orientation to display text at some specific angle: 

1. Select Text Box and Right-click and choose Orientation . 

2. The Placement and Size dialog box appears. This is to display text at some specific angle. 

 

 
Figure 5.26 

 

3. Specify Placement (Left, Top), Size (Height, Width), Units (Pixel, Inches, and Centimeter) and 

Rotation (Angle) and click OK else click Cancel. 

 

5.4.1.2 Right to left 
By Default, Text Direction option will be LTR (Left to Right) 

User can set RTL option in two ways. 

1. Set Text Direction as RTL for all Text at Report Level. 
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Figure 5.27 

 

2. Set Text Direction of individual Text and Field. 

This option will be available only if “set Text Direction as RTL for all Text" is not applied on Report 

Level. 

 

 
Figure 5.28 
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5.4.1.3 Adding bookmarks 
While creating accessible PDFs, you can add bookmarks to the text.  

 

NOTE: 

To know how to enable creation of accessible PDFs, refer to Enable creation of PDF-UA compliant PDFs 

 

To add bookmark to the text, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Properties. The Bookmark Properties dialog appears. 

3. Select the Enable Bookmark checkbox. 

4. Enter the bookmark Name. 

 

 
Figure 5.29 

 

5. Click OK to complete bookmark addition. 

 

5.4.1.4 Associating hyperlink 
While creating accessible PDFs, you can associate hyperlinks with a report.  

 

NOTE: 

To know how to enable creation of accessible PDFs, refer to Enable creation of PDF-UA compliant PDFs 

 

To associate hyperlinks, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Hyperlink. The Hyperlink dialog appears. 

3. Select the Use Hyperlink in HTML Output checkbox. 
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4. Enter the hyperlink. 

 

 
Figure 5.30 

 

5. Click OK to complete the hyperlink addition. 

 

5.4.1.5 Properties 
You can define the properties of the textbox. Two tabs General and Table of Contents are present in 

the properties section. By default, the general tab appears. 

 
General  

In the general tab, you can apply branding.  

Apply branding is a custom feature consisting of pre-defined formatting like font size, color, font type, 

and many more, that are preset in the database and applicable for all the content present in table cell, 

rich text box, or text box that are mapped with it. This feature is only applicable for PDF, letter and 

contract-type reports.  

To apply the branding, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Properties. The Textbox Properties dialog appears. 

3. Select the Apply Branding checkbox. 

4. Specify the Attribute from the drop-down. It consists of attributes that are mapped with 

formatting in the database. 

5. Click OK to save the details. 
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Table of Contents 

To add a text box as the table of contents, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Properties. The Textbox Properties dialog appears. 

3. Select the Include in Table of Contents checkbox. 

4. Specify the heading of the textbox. 

5. Specify the level of heading from the dropdown between 1 to 5. 

Accessibility 

To enable hierarchy in the text box, follow the below steps: 

1. Select the Enable Hierarchy checkbox to set the level of the textbox. 

2. Specify the level of heading as per the hierarchy. 

To enable a bookmark in the text box, follow the below steps: 

1. Select the Enable Bookmark checkbox to set the level of the textbox. 

2. Specify the Name of the bookmark. 

 
5.4.1.6 Defining dynamic content 
The dynamic content ability of the textbox control allows you to display content that changes based on 

certain rules, conditions, and data. In Composition Designer, you can map the control with the Admin 

Workspace content through direct mapping or using a decision table.  

This feature is useful when generating reports that display real-time data.  

• Direct Mapping — Use this method to map the textbox control directly with the text uploaded 

to Admin Workspace.  

• Decision Table — Use this method to display the text in the Textbox control based on certain 

rules and conditions defined in the decision table. The Textbox control is mapped with the text 

uploaded to the Admin Workspace. 

For more information, see NewgenONE OmniOMS Admin Workspace User Guide. 

 

Mapping control through direct mapping 

To map the TextBox control through direct mapping, perform the below steps: 
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1. On the design canvas, right-click the control and select Dynamic Content from the list. 

The Dynamic Content dialog appears. By default, the Mapping Type and Label Name fields appear 

disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 

3. Set Mapping Type to Direct Mapping. 

4. Select the required text from the Label Name dropdown. The Label Name dropdown displays a list 

of text uploaded to the Admin Workspace.  

5. Click OK to save the changes. 

 

NOTE: 

After applying direct mapping to a control, you cannot use it in the decision table. 

 
Mapping control using a decision table 

To map the TextBox control using a decision table, perform the below steps: 

1. On the design canvas, right-click the control and select Dynamic Content from the list. 

The Dynamic Content dialog appears. By default, the Mapping Type and Label Name fields appear 

disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 

3. Set Mapping Type to the Decision Table. 

4. Enter the name of the control in the Label Name field. This label name can further be used in 

decision tables for applying rules and conditions on the control. For more information, see Decision 

table library. 

5. Click OK to save the changes. 

5.4.2 Rich text box 
To enter rich text in the report, follow the below steps: 

1. Click the  rich text icon in the Object Toolbar and draw a rich text box on the canvas.  

2. Enter the required text. 

A save design dialog appears at regular intervals prompting you to save the design changes. Click Yes 

to save the changes or No to proceed with designing without saving the changes. 
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5.4.2.1 Adding hyperlinks to rich text 
While creating a report, you can use a rich text box to add hyperlinked text within the report. You can 

either add a hyperlink to a selected text within the rich text box or apply a hyperlink to the entire box. 

You can also apply URL shortening on the added hyperlink. 

 

NOTE: 

For information on creation of accessible PDFs, refer to Enable creation of PDF-UA compliant PDFs 

 

To add to a hyperlink to a selected text in a rich text box, follow the below steps: 

1. Create a new rich text box or select an existing one.  

2. Select the required text. 

3. Right-click the selected text and select Hyperlink. The Hyperlink dialog appears. 

In the Name field, the selected text appears in the editable mode. 

4. Select the Type as: 

• Static URL – to enter a specific URL and hyperlink the text to it. 

a. In the Target field, specify the target URL. 

• Macro Field – to hyperlink the text to a dynamic data field. In this case, the web address or URL 

can change. The Target field appears disabled. 

a. Click the horizontal browse icon . The Database Field Browser appears. 

b. Expand the required table node and select the required data field. 

c. (Optional) Select the Shorten URL checkbox to shorten the URL value of the selected data 

field.  

d. Click Select. The selected data field now appears in the Target field. 

5. Click Ok. The selected text gets hyperlinked. A dialog asking to save the changes made to the report 

appears.  

6. Click Yes to confirm. 
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5.4.2.2 Adding macro fields to rich text 
Macro fields allow you to dynamically insert values or data into the text content of the box. 

Additionally, you have the option to add dynamic URLs within the rich text box and even shorten them 

for improved aesthetics and usability. 

 

To add to a hyperlink to a selected text in a rich text box, follow the below steps: 

1. Create a new rich text box or select an existing one.  

2. Right-click the rich text box and select Macro Fields. The Database Field Browser appears. 

3. Expand the required table node and select the required data field. 

4. (Optional) Select the Shorten URL checkbox to shorten the URL value of the selected data field.  

5. Click Select. The macro field gets added to the rich text box.  

7. Click the save icon . A dialog asking to save the changes made to the report appears.  

8. Click Yes to confirm. 

 

5.4.2.3 Configuring rich text box properties  
The properties dialog for the rich text box provides options to configure the following: 

• Mapping content from source and apply  

• Enable dynamic rich text box 

• Set relativity of a rich text box with other controls 

• Map RTF content to a rich text box 

• Add bookmarks to a rich text box 

• Adding dynamic content 

• Configure paragraph properties for a rich text box 

 

5.4.2.3.1 Mapping content from the source and apply to brand 

To map content from the source, follow the below steps: 
 
1. Create a new rich text box or select an existing one.  

2. Right-click the text box and select Properties. The Textbox Properties dialog appears. 

3. Select the Mapping Content from Source checkbox. 

4. Choose anyone from Text Gallery or RTF. 
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5. Select the mapping type from the following option. 

• Direct Mapping 

• Decision Table Mapping 

6. Specify the Label Name.  

Apply Branding  

For details refer to the Properties section. 

To apply the branding, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Properties. The Textbox Properties dialog appears. 

3. Select the Apply Branding checkbox. 

4. Specify the Attribute from the drop-down. It consists of attributes that are mapped with 

formatting in the database. 

5. Click OK to save the details. 

 

5.4.2.3.2 Enabling dynamic rich text box 

A dynamic rich text box automatically adjusts its size, or dimensions based on the content specified 

within it. This ensures that the rich text box can accommodate the text without truncating or hiding 

any of its contents. Dynamic resizing allows for a better user experience by preventing overflow or the 

need for scrolling within the text box when the content exceeds its original dimensions. 

 

To enable a dynamic rich text box, follow the below steps: 

1. Open the required report. 

2. Create a new rich text box or select an existing text box.  

3. Right-click the rich text box and select Properties. The Rich Text Properties dialog appears. 

4. Go to the Relativity tab and select the Dynamic Rich Textbox checkbox. 

The Name fields display the name of the selected rich text box. It is modifiable. 

5. Click OK. The Rich Text Box Properties dialog closes. 

6. Click the save icon . The dynamic rich text box is enabled. 
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5.4.2.3.3 Setting relativity of a rich text box with other controls 

The relativity feature allows you to adjust the spacing between the rich text box and other controls on 

the PDF reports. It enables you to specify the required margin surrounding the rich text box. 

 

To set the relativity of a rich text box with other controls on the design canvas, follow the below steps: 

1. Open the required report. 

2. Create a new rich text box or select an existing text box.  

3. Right-click the rich text box and select Properties. The Rich Text Properties dialog appears. 

4. Go to the Relativity tab and select the Dynamic Rich Textbox checkbox. 

The Name field displays the name of the selected rich text box. It is modifiable. 

5. Select the Relative To checkbox.  

6. From the Page dropdown, select the required page containing the rich text box. 

 

NOTE: 

If the Spill in Page feature is enabled, the dropdown menu consists of both the current page and the previous page as 

options. Accordingly, the controls appear in the subsequent dropdown. 

 

7. From the Control dropdown, select the required dynamic control. The available options are Table, 

Container, Component, and RichTextBox. 

The Objects dropdown menu consists of a list of dynamic that are positioned above the selected 

rich text box on the design canvas. For example, if you have a Table control positioned above the 

selected rich text box, the Objects dropdown menu displays a list of dynamic tables located above 

it on the canvas. 

8. From the Objects dropdown, select the required object. 

9. In the Relative Space fields, specify the relative space between the controls in pixels. 

10. Click Add. The specified relative control appears in the list. 

11. Click OK. The Rich Text Box Properties dialog closes. 

12. Click the save icon . The changes made to relativity properties get saved. 

 

5.4.2.3.4 Mapping RTF content to rich text box 
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The OmniOMS Composition Designer allows you to link the content of a rich text box to external RTF 

(Rich Text Format) content using RTF Labels.  

During the preview of a report, you have the ability to view the content retrieved from the RTF label. 

However, the actual fetching of the content from the RTF label occurs in real time during the batch 

generation process. This means that when batch report generation occurs, the dynamic content gets 

fetched and inserted into the associated rich text box based on the selected RTF labels. 

This ensures that the content displayed within the rich text box is updated and accurately reflects the 

information retrieved from the specified RTF labels. 

 

NOTE: 

To know add, modify, delete, or fetch external content in the RTF labels, refer to the OMS external content library section in 

NewgenONE OmniOMS 12.0 Developer Guide. 

To enable rich text box to RTF labels, follow the below steps: 

1. Open the required report. 

2. Create a new rich text box or select an existing text box.  

3. Right-click the rich text box and select Properties. The Rich Text Properties dialog appears. 

The General tab appears by default. If not, click General to open it. 

4. Select the Enable RTF Content checkbox.  

The Content Type appears selected as RTF Content. 

5. From the Label Name dropdown, select the required RTF label. 

6. Click OK. The Rich Text Box Properties dialog closes. 

7. Click the save icon . The rich text box gets mapped to the RTF content. 

 

5.4.2.3.5 Adding bookmarks to a rich text box 
For accessible PDFs, adding bookmarks to the rich text box enhances the user experience and 

facilitates efficient navigation through the report, ensuring that all users can access and engage with 

the content effectively.  

 

NOTE: 

For information on enabling accessible PDFs, refer to the Enable creation of PDF-UA compliant PDFs section. 
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To add bookmark to the rich text, follow the below steps: 

1. Open the required report. 

2. Create a new rich text box or select an existing text box.  

3. Right-click the rich text box and select Properties. The Rich Text Properties dialog appears. 

The General tab appears by default. If not, click General to open it. 

4. Select the Enable Bookmark checkbox.  

5. In the Name field, specify the name of the bookmark. 

6. Click OK. The Rich Text Box Properties dialog closes. 

7. Click the save icon . The bookmark get added to the rich text box. 

 

5.4.2.3.6 Defining dynamic content 

The dynamic content ability of the RichText Box control allows you to display content that changes based 

on certain rules, conditions, and data. In Composition Designer, you can map the control with the Admin 

Workspace content through direct mapping or using a decision table.  

This feature is useful when generating reports that display real-time data.  

• Direct Mapping — Use this method to map the RichText Box control directly with the text 

uploaded to Admin Workspace.  

• Decision Table — Use this method to display the text in the RichText Box control based on certain 

rules and conditions defined in the decision table. The RichText Box control is mapped with the 

text uploaded to the Admin Workspace. 

For more information, see NewgenONE OmniOMS Admin Workspace User Guide. 

Mapping control through direct mapping 

To map the RichText Box control through direct mapping, perform the below steps: 

1. On the design canvas, right-click the control and select Properties from the list. 

The RichText Box Properties dialog appears. By default, the Mapping Type and Label Name field 

appear disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 91 

3. Select Text Gallery. This implies you want to map the control with the text uploaded to the Text 

Gallery of the Admin Workspace. 

4. Set Mapping Type to Direct Mapping. 

5. Select the required text from the Label Name dropdown. The Label Name dropdown displays a list 

of text uploaded to the Admin Workspace. 

6. Click OK to save the changes. 

Mapping control using a decision table 

To map the RichText Box control using a decision table, perform the below steps: 

1. On the design canvas, right-click the control and select Properties from the list. 

The RichText Box Properties dialog appears. By default, the Mapping Type and Label Name field 

appear disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 

3. Select Text Gallery. This implies you want to map the control with the text uploaded to the Text 

Gallery of the Admin Workspace. 

4. Set Mapping Type to the Decision Table. 

5. Enter the name of the control in the Label Name field. This label name can further be used in decision 

tables for applying rules and conditions on the control. For more information, see Decision table 

library. 

6. Click OK to save the changes. 

 

5.4.2.3.7 Configure paragraph properties 

For letter and contract type reports, the Rich Text Box properties dialog also provides the option to 

configure the paragraph properties. 

To configure the properties of a paragraph for a letter or contract, follow the below steps: 

1. Open the required report. 

2. Create a new rich text box or select an existing text box.  

3. Right-click the rich text box and select Properties. The Rich Text Properties dialog appears. 

In General tab, the paragraph appears enabled by default. 

4. In the Name field, specify the name of the paragraph or clause. 
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5. From the Inherit Property dropdown, select one of the following options: 

• Previous – Inherit properties defined for the previous rich text box on the canvas. 

• Next – Inherit properties defined for the rich text box present next on the canvas. 

The Level dropdown displays the level as defined in the multilevel list for the report.  

6. From the Level dropdown, select the required level for the paragraph. 

7. Select: 

• Editable – Allows modification of the paragraph in the Communication Editor during runtime.  

 

NOTE: 

• The option to define sections as editable or non-editable in the Define Sections feature becomes available only after 

marking a paragraph as editable. 

• By default, the macro fields in an editable paragraph are non-editable and it cannot be changed by the user. 

 

• Removable – Allows deletion of the paragraph in the Communication Editor during runtime. 

• Skip Numbering – Removes the numbering from the paragraph while retaining the indentation 

as defined at the report level in the Define new multilevellist dialog. 

8. Click OK. The Rich Text Box Properties dialog closes. 

9. Click the save icon . The changes made to the paragraph properties get saved. 

 

5.4.2.3.8 Table of contents 

To add rich text box as a table of contents, follow the below steps: 

1. Create a new text box or select an existing text box.  

2. Right-click the text box and select Properties. The Textbox Properties dialog appears. 

3. Select the Include in Table of Contents checkbox. 

4. Specify the heading of the textbox. 

5. Specify the Level for the heading from the dropdown between 1 to 5. 
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5.4.2.3.9 Accessibility 

To enable hierarchy in the text box, follow the below steps: 

1. Select the Enable Hierarchy checkbox to set the level of the textbox. 

2. Specify the level of heading as per the hierarchy. 

To enable a bookmark in the text box, follow the below steps: 

1. Select the Enable Bookmark checkbox to set the level of the textbox. 

2. Specify the Name of the bookmark. 

 

5.4.3 Drawing 
To draw various shapes in a document: 

1. Select Insert→Drawing→Line or click on  Line on the toolbar and bring the mouse pointer on 

the blank canvas on RHS of the Component Designer. The mouse pointer changes to the ‘+’ sign. 

2. Click and then drag on the canvas to draw a line. 

 

 
Figure 5.31 

 

3. Similarly, select Insert→Drawing→Rectangle and Insert→Drawing→Circle and 

Insert→Drawing→Rounded Edged Rectangle to draw a rectangle, rounded-edged rectangle and 

circle. These options are also available on the toolbar. 
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Figure 5.32 

5.4.4 Barcode 
To insert a barcode: 

1. Select Insert→Barcode and click on the canvas to display the Barcode Properties dialog box. You can 

also click on  Barcode on the toolbar. 

 

 
Figure 5.33 

Presentation Section 

1. Specify the Encoding for barcode by selecting the required option from the combo box. 

2. Specify the Orientation for the barcode from the combo box. The available options are Landscape, 

Portrait, Orient 180, and Orient 270. 
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3. Check the Display Text Label to display the label of the text. 

4. Check the Display End Characters to display the last characters in the barcode. 

5. Check the Append Page No to append page number in barcode logic to detect the last page of PDF. 

 

Printing Type 

1. Select Simplex Printing for printing on a single side. 

2. Select Duplex Printing to print on both sides. 

 

Section Type 

1. Section Type is a dropdown menu with the following options: 

2. Select Static Text to define a static text barcode. 

3. Select Data Field and select the Table, Column from the dropdown menu and specify the Start Offset 

and Length. 

4. Select System Field to specify a system field values available. 

5. Click the Add Column in Barcode button to display the selected column in the Barcode Column 

Sequence table, as shown in the following figure: 

 

 
Figure 5.34 
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6. You can add multiple columns in the Barcode Column Sequence table. The length of these columns 

is added and displayed in the Barcode Length field, as shown. 

7. Click  to move the selected column up in the Barcode Column Sequence table. 

8. Click  to move the selected column down in the Barcode Column Sequence table. 

9. Click  to delete the selected column from the Barcode Column Sequence table. 

 

5.4.5 QR code 
QR Code is provided in composition designer to enable the user to draw document (report) with QR Code 

Bar Code. QR Code can store static data, URL, and data from the database. 

 

To insert a QR Code: 

1. Select Insert→Barcode or go to Objects Toolbar and click on  (Barcode). 

2. Click on the canvas to display the Barcode Properties dialog box. 

3. Select the Barcode Type as  2D Barcode to insert a QR Code as shown below: 

 

 
Figure 5.35 
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4. Specify Printing Type. 

• Select Simplex Printing for printing on a single side. 

• Select Duplex Printing to print on both sides. 

5. Select Append Hashcode checkbox to enable encryption of the QR code. Enter the text to be used 

for Hashcode generation. 

 

 
Figure 5.36 

 

6. Choose the Section Type from the dropdown menu as Static Text, Data Field or System Field. 

 

 
Figure 5.37 

 

7. When Section type is Data Field, the corresponding Table and Column data is displayed, select the 

same and click on Add Column in barcode. 
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Figure 5.38 

 

8. When Section Type is System Field, the corresponding System Field is to be selected from the 

dropdown menu, select the same and click on Add Column in barcode. 

 

 
Figure 5.39 

 

9. Click OK to save the specified properties. 
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5.4.6 IM barcode 
This feature is provided in composition designer to enable the user to draw document (report) with IM 

Barcode. IM stores information for Barcode Identifier, Mailer Id, Service Type, Zip Code and Sequence 

Number. 

A Barcode Identifier is assigned by the United States Postal Service to encode the presort identification 

that is currently printed in human-readable form on the optional endorsement line (OEL). 

Service type identifier A three-digit value represents both the class of the mail (such as first-class, 

standard mail, or periodical), and any services requested by the sender. 

Mailer id A six- or nine-digit number assigned by the United States Postal Service identifies the specific 

business sending the mailing. 

Sequence Number A mailer-assigned six- or nine-digit ID specific to one piece of mail, to identify the 

specific recipient or household. 

Zip Code The full eleven-digit form includes the standard five-digit ZIP code, the ZIP + 4 code, and a two-

digit code indicating the exact delivery point. Zip code to be mapped with a database field. 

 

 
Figure 5.40 
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5.4.7 Symbol 
To insert a symbol: 

1. Select Insert → Symbol, the following character map window opens up: 

 

 
Figure 5.41 

 

2. Select the font from the available options and select the Characters to copy as shown below: 

 

 
Figure 5.42 
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Figure 5.43 

 

5.4.8 Digital signature 
CDG offers the capability to enhance security by incorporating a digital signature into your PDF report. 

A page in a report can have multiple digital signatures of the same type, that is, either PFX or HSM. These 

digital signatures can be placed on the page, container header, or container footer. 

 

NOTE: 

• You can use only one type of digital signature, that is, either PFX or HSM, throughout the report. 

• A component can have only one digital signature. 

• You cannot add a rule to a page with a digital signature. 

 

To add a digital signature, follow the below steps: 

 

1. From the Object Gallery pane, open the required report. 

2. In the Objects Toolbar, click the Digital Signature icon . 

3. Drag the mouse pointer to the design area while keeping the button pressed and stretch it according 

to your estimated requirement. The Digital Signature dialog appears. 

4. From the Label Name dropdown, select the required digital signature to add to the report. 
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5. Click OK to confirm and save the specified signature. 

6. Save the report. 

For information on how to add and configure a digital signature, refer to the NewgenONE 

OmniOMS Admin Workspace User Guide. 

 

5.4.9 Image 
You can insert an image to the statement for various purposes like promotional events, offers, 

advertisements, and so on. The Add Image option is available in the toolbar of the CDG. Use this option 

to insert an image directly into a report. 

 

To insert an image into a report, follow the below steps: 

1. Click the  image icon in the Object Toolbar and draw an image on the canvas. The Image Source 

dialog appears. 

2. In the Mediums section, select: 

• Embed Image – to select an image from your system that remains the same across all statements. 

➢ Click Browse to select the Image File Path. 

• Watch Folder – to select an image from a folder that might changes for each statement 

depending on the watch folder path. 

➢ Click Browse to select the Watch Folder Path. 

• Image URL – to select an image from a URL that might changes for each statement depending on 

the Database field or the URL path. 

➢ Enter the Image URL. 

 

NOTE: 

When selecting an image in HTML reports, you can only choose from the Image URL option. The Embed Image and Watch 

Folder options appear disabled. 

For HTML reports,  

The Image Preview appears. 

3. Select Image Type as: 
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• Artifact – when you do not want to add a description about the image. 

• Non-Artifact – when you want to add a description about the image. 

➢ Enter a description of the image in the Alternate Text box. 

You can use the image type feature in the header and footer section of the report. If applied to the 

header it will only display on the top of the first page and if applied at the footer it displays at the bottom 

of the last page of the report. 

NOTE: 

The Image Type and Alternate Text field appears only when you create accessible PDFs. To know how to enable creation of 

accessible PDFs, refer to Enable creation of PDF-UA compliant PDFs. 

 

4. Click OK to save the changes made. 

 

 
Figure 5.44 

 

NOTE: 

➢ Use the Add Macro option to add macros to the selected image, such that, image gets retrieved automatically from the 

database during run time. 

➢ If image size is more than the page size, then the Image Preview does not appear, and it does not get printed on the PDF 

as well. 
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5.4.9.1 Defining dynamic content  
The dynamic content ability of the Image control allows you to display image that changes based on 

certain rules, conditions, and data. In Composition Designer, you can map the Image control with the 

Admin Workspace content through direct mapping or using a decision table.  

This feature is useful when generating reports that display real-time data.  

• Direct Mapping — Use this method to map the Image control directly with the image uploaded 

to Admin Workspace.  

• Decision Table — Use this method to display the image based on certain rules and conditions 

defined in the decision table. The Image control is mapped with the image uploaded to the Admin 

Workspace. 

For more information, see NewgenONE OmniOMS Admin Workspace User Guide. 

 

Mapping control through direct mapping 

To map the Image control through direct mapping, perform the below steps: 

1. On the design canvas, right-click the control and select Dynamic Content from the list. 

The Dynamic Content dialog appears. By default, the Mapping Type and Label Name fields appear 

disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 

3. Set Mapping Type to Direct Mapping. 

4. Select the required image from the Label Name dropdown. The Label Name dropdown displays a 

list of images uploaded to the Admin Workspace.  

5. Click OK to save the changes. 

 

NOTE: 

After applying direct mapping to a control, you cannot use it in the decision table. 

Mapping control using a decision table 

To map the Image control using a decision table, perform the below steps: 

1. On the design canvas, right-click the control and select Dynamic Content from the list. 
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The Dynamic Content dialog appears. By default, the Mapping Type and Label Name fields appear 

disabled. 

2. Select the Mapping content from Source checkbox to enable the dynamic content feature. 

3. Set Mapping Type to the Decision Table. 

4. Enter the name of the control in the Label Name field. This label name can further be used in 

decision tables for applying rules and conditions on the control. For more information, see Decision 

table library. 

5. Click OK to save the changes. 

5.4.10 Container 
For generating different types of output, you can use various objects—line, circle, rectangle, and so on— 

available in OmniOMS. A container is an object that is used to display a similar type of data in the form 

of a table. For example, the transactions made on a card number can be displayed in a container. 

Different properties of a container can be used to design different types of output templates. 

To place a container, you need to select it on the Objects toolbar and click inside the canvas. On Right-

clicking, the container placed on the canvas and selecting Properties from the shortcut menu, the 

Container Property dialog box appears, as shown. 

 

 
Figure 5.45 
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The Container Property dialog box contains the following fields and buttons: 

Container Name: This textbox is used to provide the name of the container. 

 

Position Tab 

a) Spillover to next page: This checkbox, when selected, allows you to specify how data that spills over 

to the next page will be placed in the page. On selecting this checkbox, the following two fields 

become enabled: 

b) Next Page Position: This dropdown list is used to select the position of spillover data in the next page 

as: 

• Page Top Position (After Page Header) 

• Container start position 

c) Start Each Instance from New Page: This checkbox, when selected, implies that data associated with 

each instance should appear on a new page. 

d) Start all new instances on New Page: This checkbox, when selected, implies that data associated 

with all the instances will appear on a new page. 

e) Repeat Container: This checkbox, when selected, implies that the special symbol which implies the 

data is continued is repeated on its every page. 

f) Relative To: Select it to associate any relative table/container with the respective container. 

g) Table: Select this checkbox and select the required table from its dropdown list, to associate any 

relative table with the respective container. 

h) Container: Select this checkbox and select the required container from its dropdown list, to associate 

any relative container with the respective container. 

i) Add: Select the required Table/Container from its respective dropdown list, and click on this button 

to add it. 

j) Delete: Select the required Table/Container and click on this button to delete it. 

k) Relative Space: This textbox is used to specify the margin between the relative container and the 

current container. 

You use a relative/parallel container in cases when you want to display data of a customer, pertaining 

to different account types or card types, in a single statement. For example, a customer ID 005 has 
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three different accounts in the same bank—two saving accounts and one current account. The same 

customer also holds a gold credit card of the bank. You can place different containers on the same 

statement to display information specific to each account type and the card type. 

l) Region Bounds: This checkbox, when selected, allows you to specify the region in which data is to be 

displayed in the container body. On selecting this checkbox, the following two fields become 

enabled: 

• Height: This textbox is used to specify the height. 

• Width: This textbox is used to specify the width. 

 

NOTE: 

If you do not specify region bounds, the container height and width become dynamic, and accordingly, if rows of data do not 

fit in one page, the rows can be displayed in another page. 

 

m) OK: This button is used to save the container properties and close the dialog box. 

n) Apply: This button is used to save the container properties. 

o) Cancel: This button is used to cancel the specified container settings and close the dialog box. 

Spill Over Tab 

 

 
Figure 5.46 
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a) Division Setting: This checkbox, when selected, is used to specify the number of columns, in a page, 

in which data rows can appear. On selecting this checkbox, the following two fields become enabled: 

• Division Count: This dropdown list is used to select the division count from 1 through 5. You can 

select a maximum of 5 divisions. 

• Left Margin: This textbox is used to specify the margin between the divisions. 

b) Fix Maximum Transaction Count in Detail Section: This checkbox, when selected, is used to specify 

the maximum number of transactions that can be processed in a container. 

• Transaction Count: This textbox is used to specify the maximum number of transactions. 

c) Show Page Level Aggregate: 

• Show Cumulative Value: This checkbox, when selected, is used to display the summation of the 

quantitative parameter in the container at the end of every page. 

 
No Transaction Tab 

 

 
Figure 5.47 
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a) Suppress Container for null detail: This checkbox, when selected, would suppress the container field 

if it contains a NULL value i.e. if the container holds a NULL value then it would not be visible in the 

output file. 

b) Suppress Container for blank detail: This checkbox, when selected, would suppress the container 

field if it does not have any data as input and is blank. 

c) Show No Transaction Notifications: This checkbox, when selected, the user would be able to display 

a fixed static data in the container field even if there is no data. The data to be displayed can be 

specified in the following sub-fields: 

• Text to Display: Specify the text to be shown in the container field. 

• Font Properties: Set the font to be used for the container field. 

• Fore Color: Specify the font color for the container field. 

• Back Color: Specify the background color of the container field. 

• Orientation: Specify the angle at which the text would be displayed in the container field. 

• Preview: Preview the field. 

 
Presentation Tab 

 

 
Figure 5.48 
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a) Use Multiple Colors for Transaction 

b) Sequence Settings 

• Ignore Container for Sequence-If checked, running sequence for the container will not be 

applicable in output 

• Ignore Container for Detail Row- If checked, row numbering for container detail row will not be 

applicable in output 

• Restart Detail Row No-If Checked, detail row numbering will start from 1 for each container 

• Restart Container Sequence- If Checked, container numbering will start from 1 for each container 

• Type of Sequence-Sequence can be of two types: 

➢ Numeric 

➢ Alphabets 

c) Draw Border: This property is used to draw a border around the container with multiple line format 

supported. 

 

Modify Master Tab 

 

9  

Figure 5.49 
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a) Master Query: Master Query is the query that is automatically generated by the system. 

b) New Master Query: New Master query is a user-defined query. If the user wants to make some 

changes to the default master query, it is the New Master Query. User can check the ‘use User 

Defined Query’ checkbox and defined a query. In a new master query, data is populated based on 

the new query. 

 

NOTE: 

• The container should have at least one data-field for it to get displayed in the PDF. 

• Dynamic Container – It is an advanced feature that makes the container modifiable. That is, a dynamic container makes 

all the content visible within a cell by displaying it on multiple lines. 

 

 

 

5.4.11 Copy-paste controls 
This feature allows users to copy and paste of multiple controls globally, across the CDG. 

To perform copy and paste of multiple controls, follow the given steps: 

1. Go to a report and open its layer. 

2. Select the multiple controls and do a right-click. 

3. Click on Copy option from the pop-up menu or use the shortcut key (Ctrl+C). 
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Figure 5.50 

 

4. After copying the controls, go to another report of any communication group and open the design 

layer in which the copied controls are to be pasted. 

5. Right-click on the canvas and select Paste option from the pop-up menu or use the shortcut key 

(Ctrl+v). 

 

 
Figure 5.51 
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5.4.12 Table of Contents 

The table of contents (TOC) features allow you to create an index page displaying headings and sub-

headings. It helps in making the navigation and search of data easier. When you add a TOC (Table of 

Contents) to a page, you cannot draw any other annotations on that page. Additionally, you cannot hide 

the TOC page using rules. Only text, table, and rich text are defined as headings or sub-headings. 

To create a TOC, perform the following steps: 

1. Click the  in object toolbar and draw a TOC on the canvas. Table of Contents pop-up windows 

appear. 

 
2. Enter the Title of TOC in the Title box. It is mandatory to provide a title for the TOC. 

3. Click on Font Properties and specify the font type, style, and size, then click OK.  

 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 114 

Note 

Font Properties are only applicable for setting the properties for the title of the TOC. You can modify the font 

size with levels. The change applies to the first line. 

 

4. Select the required separator from the Content Separator dropdown  

5. (Optional) Select the Show Page Numbers checkbox, if you want to display the page numbers. 

6. (Optional) Select the Show Level Numbering checkbox, if you want to display the numbering with 

the headings. 

7. In Level Details section, contains the following fields: 

Fields Description 

Levels It defines the hierarchy of the headings in the TOC. 

There are a total of 4 levels of headings supported 

in CDG level 1 to 4. You cannot add or remove 

levels but you are allowed to configure numbering 

style, indentation, and font size for a particular 

level. 

Numbering Style It is used for setting a numbering style for a 

specific level heading. To set the Numbering Style, 

click on the dropdown and select the suitable 

numbering style. 

Indentation It is used for representing the hierarchical 

structure of the document headings. To set the 

Indentation, click on the text box and enter the 

value of indentation in inches. By default, 1 inch is 

set for all levels. 

Font Size It is used to set the font size of the headings. To 

set the Font Size, click on the dropdown and select 

the required size, or click on the box and enter the 

size. It can be modified for all levels. 

 

7. Click OK to save the properties. 
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5.5 Format menu 
The Format menu allows you to format the documents by providing various options for field alignment 

and resizing. The Format menu is shown in the following figure: 

 

 
Figure 5.52 

 

The Format menu has the following options: 

 

 
Figure 5.53 

 

1. Align: Allows the user to align the text fields used in the document. 

• Left: Aligns the text fields with the left position of the last selected text field. 

• Center: Aligns the text fields with the center position of the last selected text field. 

• Right: Aligns the text fields with the right position of the last selected text field. 

• Top: Aligns the text fields with the top position of the last selected text field. 

• Bottom: Aligns the text fields with the bottom position of the last selected text field. 

• Middle: Aligns the text fields with the middle position of the last selected text field. 

2. Make Same Size: Allows the user to set the same size for all the text fields used in a document. 
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Figure 5.54 

 

• Height: Sets the height of the text fields according to the height of the last selected text field. 

• Width: Sets the width of the text fields according to the width of the last selected text field. 

• Both: Sets the height and width of the text fields according to the height and width of the last 

selected text field. 

3. Equal Spacing: Allows the user to align the textboxes at equal spacing. 

 

 
Figure 5.55 

 

• Vertical: Allows the user to set the equal spacing between selected fields vertically. 

• Horizontal: Allows the user to set the equal spacing between selected fields horizontally. 

5.5.1 Aligning left 
To align the text fields to the left position: 

1. Select the text fields that you want to be left-aligned. For example, in the following figure, select the 

Name text field first. 

2. Press and hold the CTRL-key. 

3. Select the text field with which you want to align other text fields. For example, in the following 

figure, select the Age text field. 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 117 

 
Figure 5.56 

 

4. Select Format → Align → Left to left-align the text fields i.e. Name according to the last selected text 

field, i.e. Age as shown in the following figure: 
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Figure 5.57 

 

NOTE: 

The Format → Align → Left option should be used for the text fields, which are arranged in the same vertical position. This 

is because if the selected text fields share the same horizontal space then this option causes overlapping of the text fields 
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5.5.2 Aligning center 
To align the text fields to the center position: 

1. Select the text fields that you want to be center aligned. For example, in the following figure, select 

the Name text field first. 

2. Press and hold the CTRL-key. 

3. Select the text field with which you want to align another text field. For example, in the following 

figure, select the Age text field. 

 

 
Figure 5.58 
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4. Select Format → Align → Center to center align the text fields i.e. Name according to the last 

selected text field, i.e. Address as shown in the following figure: 

 

 
Figure 5.59 

 

NOTE: 

The Format → Align → Center option should be used for the text fields, which are arranged in the same vertical position. 

This is because if the selected text fields share the same horizontal space then this option causes overlapping of the text 

fields. 
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5.5.3 Aligning right 
To align the text fields to the right position: 

1. Select the text fields that you want to be right aligned. For example, in the following figure, select 

the Name text field first. 

2. Press and hold the CTRL-key. 

3. Select the text field with which you want to align the other text fields. For example, in the following 

figure, select the Age text field. 

 

 
Figure 5.60 
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4. Select Format → Align → Right to right-align the text fields i.e. Name according to the last selected 

text field, i.e. Age as shown in the following figure: 

 

 
Figure 5.61 

 

NOTE: 

The Format → Align → Right option should be used for the text fields, which are arranged in the same vertical position. This 

is because if the selected text fields share the same horizontal space then this option causes overlapping of the text fields. 
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5.5.4 Aligning top 
To align the text fields to the top position: 

1. Select the text fields that you want to be top-aligned, holding the CTRL-key. 

 

 
Figure 5.62 

 

2. Keeping the CTRL key pressed; select the text field with which you want to align these text fields. For 

example, in the above figure, select the Employee ID text field in the end. 
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3. Select Format → Align → Top to align the text fields with the top position of the last selected field, 

i.e., the Name, Age, and Address text fields are aligned according to the top position of the Employee 

ID field, as shown in the following figure: 

 

 
Figure 5.63 

 

NOTE: 

The Format → Align → Top option should be used for the text fields, which are arranged in the same horizontal position. 

This is because if the selected text fields share the same vertical space then this option causes overlapping of the text fields. 
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5.5.5 Align bottom 
To align the text fields to the bottom position: 

1. Select the text fields that you want to be bottom aligned by holding the CTRL-key. 

 

 
Figure 5.64 

 

2. Keeping the CTRL key pressed; select the text field with which you want to align these text fields. For 

example, in the above figure, select the Name text field in the end. 
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3. Select Format → Align → Bottom to align the text fields with the bottom position of the last selected 

field, i.e. the Name, Age and Address text fields are aligned according to the bottom position of the 

Employee ID field, as shown in the following figure: 

 

 
Figure 5.65 

 

NOTE: 

The Format→ Align → Bottom option should be used for the text fields, which are arranged in the same horizontal position. 

This is because if the selected text fields share the same vertical space then this option causes overlapping of the text fields. 
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5.5.6 Aligning middle 
To align the text fields to the middle position: 

1. Select the text fields that you want to be aligned in the middle position. 

 

NOTE: 

To select multiple text fields, select the first field, press CTRL key and then select other text fields holding the CTRL Key. 

 

 
Figure 5.66 
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2. Select Format → Align → Middle to middle align the text fields. 

 

 
Figure 5.67 
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5.5.7 Specifying same height 
To set a specific height of all the text fields: 

1. Select the required text fields, the height of which is to be set, by holding the CTRL key and clicking 

each of them, as shown in the following figure: 

 

 
Figure 5.68 
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2. Keeping the CTRL key pressed; select the text field in the last, the height of which you want to apply 

to the previously selected text fields. For example, in the above figure, the Address field will be 

selected in the last to set the height of other fields according to the Address field. 

3. Select Format → Make Same Size → Height to set the height of all the fields same as the height of 

the last selected field. For example, the height of Employee ID, Name, and Age is set according to the 

height of Address, as shown in the following figure: 

 

 
Figure 5.69 
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5.5.8 Specifying same width 
To set a specific width of all the text fields: 

1. Select the required text fields, the width of which is to be set, by holding the CTRL key and clicking 

each of them, as shown in the following figure: 

 

 
Figure 5.70 
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2. Keeping the CTRL key pressed; select the text field in the last, the width of which you want to apply 

to the previously selected text fields. For example, in the above figure, the Employee ID field will be 

selected in the last to set the width of other fields according to the Employee ID field. 

3. Select Format → Make Same Size → Width to set the width of all the fields same as the width of the 

last selected field. For example, the width of, Name, Age, and Address is set according to the width 

of Employee ID, as shown in the following figure: 

 

 
Figure 5.71 
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5.5.9 Specifying same height and width 
To set both the height and width of the text fields: 

1. Select the required text fields, the height and width of which is to be set, by holding the CTRL key 

and clicking each of them. 

 

 
Figure 5.72 
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2. Keeping the CTRL key pressed; select the text field in the last, the height and width of which you 

want to apply to the previously selected text fields.  

3. Select Format → Make Same Size → both to set the height and width of all the fields same as the 

height and width of the last selected field. 

 

 
Figure 5.73 

 

NOTE: 

Fields get aligned or size selection is applicable based on the position of last selected field or textbox. 
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5.5.10 Specifying equal vertical space 
To make equal vertical spacing among the text fields: 

1. Select the required text fields. 

 

 
Figure 5.74 
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2. Select Format → Equal Spacing → Vertical. 

 

 
Figure 5.75 
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5.5.11 Specifying equal horizontal space 
To make equal horizontal spacing among the text fields: 

1. Select the required text fields. 

 

 

Figure 5.76 

 
 

2. Select Format → Equal Spacing → Horizontal. 

 

 
Figure 5.77 
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5.5.12 Support for Arabic and other foreign languages 
CDG supports Arabic and other foreign languages as input language. There is no rendering issue involved 

with it. To use input language of choice, the user must add this language to the list of languages in 

Keyboards and Languages of his or her PC. 

 

 
Figure 5.78 
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5.6 Function menu 
The operations in Function menu are as shown below:  

• Rule Function 

• Arithmetic Function 

• Annexure Configuration 

• Metadata library 
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5.6.1 Rule function 
The Rule menu allows you to create rules on the fields of the documents. These rules are applied to the 

fields to define conditions based on which particular information is displayed on the documents. For 

example, while generating an employee’s salary details report, you want a particular object (added to a 

report) to turn green if the salary of employees is more than Rs. 25,000. Then, you can define a rule with 

the condition, “If (Salary>25000)” and associate this rule with the required object using the Rule menu. 

Similarly, if you want a text field (added to a report) to display a particular message in red color in bold 

letters for those employees whose salary status is pending. Then, you can define a rule, “If (SalStatus=P)” 

and associate this rule with the text field so that its message turns into red color with bold text when the 

condition is satisfied on the generation of reports. 

 
You can define rules at the: 

• Page level: If you want to display a birthday message on a statement page of a customer during his 

birthday month, you can specify a page level rule, which will apply to only that page. 

• Global level: If you want to display a common message on all the pages, say, Christmas and New Year 

messages, you can specify a rule at the global level. 

• Container level: For a customer ID, if you want to highlight the transaction field if the transaction 

amount is more than $1000, you can specify a container-level rule. 

Associating the objects with the rules involves setting colors, captions, font types, or font size in which 

these objects will be highlighted when the corresponding rule condition is satisfied. You can associate 

rules with the various objects added to the reports such as text, rectangle, circle, line, database field, or 

an image.  

At run time, when reports are generated, these objects if associated with the rules are highlighted 

accordingly when the field in the associated rule satisfies the rule condition. 

 
NOTE: 

The Salary and SalStatus variables in the above examples are random and represent the relation fields linked with the 

documents in Composition Designer. 
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You can associate a single object with multiple rules and multiple objects with a single rule. 

The Rule Function menu is shown in the following figure: 

 

 
Figure 5.79 

 

Following are the options of the Rules menu: 

• Create Rule: Allows you to create a rule on fields.  

• Rule Association: Allows you to associate the rules with different objects, such as images, captions, 

and database field values. 

• Rule Library: Allows you to manage all rules defined by the user on fields. 

 

5.6.1.1 Creating rule 
To create a rule: 

1. Select Function →Rules → Create Rule to open the Create Rule dialog box, as shown in the following 

figure: 

 

 
Figure 5.80 
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2. Specify a name for the rule in the Name textbox. 

3. By default, the Active checkbox is selected. It means that the rule will be active at the time of output 

generation i.e. if the rule condition is satisfied, the corresponding action will take place.  

• Uncheck the Active checkbox to make the rule inactive. This is useful in case you do not wish to 

apply the rule on fields currently. In such a case, you can define the rule and make it inactive so 

that you can use it at some later point of time. 

4. In the Create Conditions section, click on the dropdown list to view a list of all the fields associated 

with the current document, as shown in the following figure: 

 

 
Figure 5.81 

 

NOTE: 

The list of fields appears only if the user has associated objects on the documents with some database fields. 

 

5. Click on the dropdown option to view a list of operators. 

6. Select the required operator. 
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Figure 5.82 

 

7. Select Static or Dynamic option as per the requirement. 

 

NOTE: 

While creating a Rule, in the second operand of the condition, the user can enter a constant value or select from a dynamic 

dropdown. 

 

i. The user can select whether it is needed a comparative operand to be a static value or dynamic 

value using the radio button. By selecting Static, the user will enter the value to compare with 

the operand and operator selected. 
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Figure 5.83 

 

ii. By selecting the Dynamic option, the user gets a comparative operand to choose from the 

dropdown list with all possible fields with the same data-type selected in operand 1. 
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Figure 5.84 

8. To enhance the Rule, select the AND/OR option from the available dropdown list. 

 

 
Figure 5.85 
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NOTE: 

Click on Clear to clear the selected conditions. 

 

9. Click on Add to add the defined rule. 

10. The Defined Rule appears in the Rule Section. 

11. Click OK to complete the rule creation. 

Or click Cancel to close the Create Rule dialog box without saving the changes. 

 

 
Figure 5.86 
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5.6.1.2 Rule association 
To associate rules with objects placed on the documents: 

1. Select the object that you want to associate with the rule. 

2. Select Rules → Rule Association to display the Rule Association screen. 

3. Click on Associate Rule given in the bottom-left corner of the screen. 

 

 
Figure 5.87 

 

4. Select Rule dropdown list gets activated. A list of all the defined rules appears in this dropdown list. 

Select the rule that you want to apply on the selected object. 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 148 

 
Figure 5.88 

 

5. Click on Add to associate the rule with the object. The added rule appears in the left pane under 

Associated Rules. 

6. Select the Show Object checkbox to display the object on the document highlighted with the 

specified colors. Select Hide Object checkbox to hide the object. 

7. The object that you selected to associate with the rule is displayed on RHS. 

8. Select the background and foreground color of the object using  and  icons. In case, the 

object is a textbox, then these icons do not appear. Instead, buttons for selecting the fore color, back 

color, and font properties appear. 

9. Select the width of the object using the  icon. This icon is enabled only for the line object. 

10. Click OK to save the settings. 

11. Click Cancel to close the dialog box without saving the changes. 
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NOTE: 

You can associate a single object with multiple rules. The precedence is given to the first rule defined and if it is satisfied, the 

output generation engine does not go to the second rule. If the first rule condition is not satisfied, the second rule defined in 

the queue is processed and so on. 

 

12. Click Delete to delete the selected rule from the Associated Rules list. 

13. Click Rule Details link to open Rule Library screen, which is used to manage rules. 

14. Click Create New Rule to invoke the Create Rule screen, which is used to define rules. 

 

 
Figure 5.89 
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5.6.1.3 Rule library 
To view and manage defined rules: 

1. Select Rules → Rule Library to open the Rule Library screen, as shown: 

 

 
Figure 5.90 

 

2. The Rules list on LHS displays the rules defined in the current document. You can select a rule to view 

its properties in the respective fields, as shown: 
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Figure 5.91 

 

3. The Name and Expression fields display the name and condition of the selected rule. 

4. The objects associated with the selected rule are displayed in the Objects Associated section. 

8. The Page combo box allows you to select the page of the document on which objects associated 

with the rule are placed. The options available are: All and the individual number of the page in 

the document. 

9. The Type combo box allows you to select the object associated with the rule. The available 

options are: All, Database Field, Line, Caption, Rectangle, Image, and Circle. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 152 

5. You can type the name or the initial letters of the rule in the Rules textbox at the top and click Go to 

search for that particular rule. 

6. Click Refresh to refresh the Rules list. 

7. Click Add Rule to define a new rule. Create Rule dialog box appears to define a new rule. However, 

you cannot associate the object with the new rule in the Rule Library screen. You need to open the 

Rule Association screen for performing this task.  

8. Specify the name and condition for the rule in the Name and Expression textboxes. 

9. Click Apply to add the newly created rule in the Rules list. 

 

 
Figure 5.92 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 153 

10. Click on Import Rule to import a rule to the Rule Library. Click Import Rule for more details. 

11. Click Modify Rule to modify the existing properties of the selected rule. 

12. Click Delete Rule to delete the selected rule. 

13. Click OK to save the settings and close the dialog box. 

Or, click Cancel to close the dialog box without saving the changes. 

 

Import Rule 

The Import Rule feature allows the users to select rules of any report for importing to the Rule Library. 

Users can choose Category, Communication Group, Report (which is associated with the same dataset), 

and its rules for importing. Follow the below steps to import rules: 

1. Select Category, Communication Group and Report from the respective dropdown boxes. Select 

Category in the Report selection group, then its communication group will get populated. Then select 

Communication Group, its Reports will get populated. According to the report, the Rules will get 

populated. 

2. Once the Report is selected, all the rules created for this report appear in the Rules List. On selecting 

a Rule, its name and expression are displayed in the Rule Details section. 
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Figure 5.93 

 

  



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 155 

3. Now, select the required rules from the list of Rules. 

• Click on Check all to select all the rules. 

• Click on Uncheck all to unselect all the selected rules. 

4. Search Rules search box is provided for filtering the rules from the Rules list box. 

5. Click on Import. 

 

 
Figure 5.94 

 

6. After importing, the rules are imported and added to the Rule Library. 
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Figure 5.95 
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5.6.2 Arithmetic function 
To create and apply Arithmetic expression: 

1. Click on Database tab, database table and field list appear. 

 

 
Figure 5.96 

 

2. From this list, select and drop the required fields (only integer data type is allowed), using which 

Arithmetic Expression has to be created, on the canvas. 

 

 
Figure 5.97 
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3. Select Function → Arithmetic Function to open the Create Arithmetic Expression screen. 

 

 
Figure 5.98 

 

4. To create Arithmetic Expression, click on the Add Expression tab and carry out the following steps: 

i. In Add Expression tab, click on the Add (default) radio button. 

ii. In Expression Name textbox, enter a name for the new expression. 
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Figure 5.99 

 

iii. From the Data Field dropdown, select the required Data Field. 

iv. In the Constant textbox, enter the required constant value. 

v. Using Decimal Precision option, select the decimal value limit. 

vi. From the Expression List dropdown option, select any of the earlier created expression. 

 

NOTE: 

The Data Field elements are those which have been dragged and dropped from the database into the Canvas. 
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Figure 5.100 

 

vii. Select the required table from Tables dropdown list. 

viii. Select the required Aggregate Data associated with the selected table. 

 

 
Figure 5.101 
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ix. Using the Data Field, Constant and Arithmetic Operators, create an Arithmetic Expression. 

x. Click on Add to save the Arithmetic Expression. 

 

 
Figure 5.102 

 

5. The added Arithmetic Expression appears in the Library section. To apply added Arithmetic 

Expression, carry out the following steps:- 

i. To use any of the added expression, select the required one from the Library. 
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Figure 5.103 

 

ii. Click on Error Message dropdown option. 

iii. From the dropdown list, select the required error message option which will appear when any of 

the expression fails to find the data. 

iv. Click on Apply to use the required Arithmetic Expression. 

v. Click Delete to delete the selected Arithmetic Expression. 

vi. Click Cancel to close the dialog box without applying any available Arithmetic Expression. 
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Figure 5.104 
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5.6.3 Annexure configuration 
To manage additional annexure with documents: 

1. Select Function→ Annexure Configuration to open the Conditional Annexure screen, as shown: 

 

 
Figure 5.105 

 

2. Select a Rule from the Select Rule dropdown list. The rule definition is displayed in the box just below 

the Select Rule option. 

3. Select a PDF Annexure from the dropdown list. This PDF Annexure dropdown list contains all the 

PDFs added in Dynamic Content Library in OmniOMS Web Admin. 

4. Click ‘+’ for annexure association. 

5. Click the checkbox of the added annexure if it is to be appended in the beginning. 
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Figure 5.106 

 

Click Apply to save the settings. 

Click OK to save the settings and close the dialog box. 

Click Cancel to close the dialog box without saving the changes. 

 

5.6.4 Metadata library 
A metadata library is a repository of metadata tags that are associated with various reports. This library 

serves as a central location for creating and managing these tags. 

Metadata tags are components that store descriptive or structural information regarding reports.  
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5.6.4.1 Creating a metadata tag 
To create a metadata tag, follow the below steps: 

 

1. Go to the Function tab and select Metadata Library. The Metadata Library dialog appears, displaying 

a list of available metadata tags. 

2. In the Name box, specify the metadata tag name. 

3. From the Datatype dropdown, select the required data type for the metadata tag. The available 

options are String, Integer, and Date.  

The system accepts the data inputs of the selected datatype only in the metadata field. For example, 

if Date is selected as a datatype for a tag, only date-type values are accepted in that metadata tag. 

4. Click Add. The tag gets added to the Metadata tags list. 

5. Click OK to close the Metadata Library dialog. A dialog informing that the metadata library details 

have been saved appears. Click OK to close this dialog. 

 

5.6.4.2 Modifying a metadata tag 
To modify a metadata tag, follow the below steps: 

 

1. Go to the Function tab and select Metadata Library. The Metadata Library dialog appears, displaying 

a list of available metadata tags. 

2. From the available Metadata tags list, select the required tag. You can use the search box to search 

for the required metadata tag by name. The details of the selected metadata tag appear in the Create 

Metadata Tag section. 

3. Make the necessary modifications. 

 

NOTE: 

The datatype details are non-modifiable. 

 

4. Click Modify. A dialog confirming the modification of the selected metadata tag appears. 

5. Click Yes to confirm. A dialog acknowledging the modification of the metadata tag details appears. 
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6. Click OK to close this dialog.  

7. Click OK to close the Metadata Library dialog. A dialog informing that the metadata library details 

have been saved appears. Click OK to close this dialog. 

 

5.6.4.3 Deleting a metadata tag 
To delete a metadata tag, follow the below steps: 

 

1. Go to the Function tab and select Metadata Library. The Metadata Library dialog appears, displaying 

a list of available metadata tags. 

2. From the available Metadata tags list, select the required tag. You can use the search box to search 

for the required metadata tag by name.  

3. Click Delete. A dialog confirming the deletion of the selected metadata tag appears. 

4. Click Yes to confirm. 

5. Click OK to close the Metadata Library dialog. A dialog informing that the metadata library details 

have been saved appears. Click OK to close this dialog. 

 

5.6.4.4 Associating metadata tag values 
To associate metadata tag values for a report, follow the below steps: 

 

1. In the Object Gallery→Object tab, navigate to the required report. 

2. Right-click the report name and click Properties. The Report Properties dialog appears. 

3. Go to the Metadata tab. It displays a list of available metadata tags. 

You can also create a new metadata tag using the Add metadata tag option. For procedural details 

on how to create a metadata tag, refer to the Creating a metadata tag section. 

4. Specify the metadata tag values, as required. 

5. Click OK to save. 
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5.6.4.5 Searching templates 
The Search feature enables you to perform search operations on reports, layout components, and 

master layout templates. These searches can be conducted at various levels, each yielding distinct 

results: 

 

• Output Management System node — The search operation gets executed among all categories, 

communication groups, reports, layout components, and master layouts. 

• Category level — The search operation gets restricted to the selected category along with its 

associated communication groups, reports, layout components, and master layouts. 

• Communication Group level — The search operation gets restricted to the selected communication 

group along with its reports, layout components, and master layouts. 

• Report level — The search operation gets executed across all reports present within the selected 

report node. 

• Layout Components level — The search operation gets executed across all layout components 

present within the selected layout component node. 

• Master Layouts level — The search operation gets executed across all master layouts present within 

the selected master layout node. 

 

To search for a report, layout component, or master layout template, follow the below steps: 

 

1. In the Object Gallery pane, select the required node to perform the search. 

2. Click the filter icon . The Search dialog appears. 

3. Select one of the following options: 

• Search by Name – To search the template by its name. 

In the Enter Name box, specify the required template name. 

• Search by Metadata – To search the template using a metadata tag value. This option is 

applicable to report templates only. 

From the Select Metadata dropdown, select the required metadata tag.  

In the Enter Value box, specify the required value against the selected metadata tag.  
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• Search by Content – To search the template using content references used within it. 

In the Enter Content box, specify the piece of content to use as a reference for the search. 

4. Click Search. The search results appear.  

For example, to search the report templates created by a user named John Mark: 

 

1. Select the Output Management System node. 

2. Click the filter icon . The Search dialog appears. 

3. Select the Search by Metadata option. 

4. From the Select Metadata dropdown, select the Author Name tag. 

5. In the Enter Value box, specify, John Mark. 

6. Click Search. All the reports created by John Mark appear in the search results. 

 

Before starting a new search, it is essential to clear the search results from the prior search and refresh 

the entire Output Management System node. To clear the existing search results, click the Reset Filter 

option. 
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5.7 Tools menu 
The Tools menu gets enabled at Reports level. The operations in Tools menu are as shown below:  

 

 
Figure 5.107 

 

• Configuration Manager • PDF Security Parameters 

• Auto Relativity • Edit Master Query 

• Auto Alignment • Watermark Configuration 

• Password Designer • Decision Table Library 

• Sample PDF Stamp • Export Schema XML 

 

5.7.1 Configuration manager 
This option is used to setup OmniOMS before you start using it. You can set the database details, 

configure locations and specify the application server connection. 

 

NOTE: 

Refer to Installation Guide for more details. 
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5.7.2 Auto relativity and alignment 
These options allow you to enable or disable Auto-Alignment and Auto-Relativity features. If enabled, 

while adding or deleting a control within a set of controls, you don’t have to manually adjust and align 

all the controls. 

 

When Auto-Alignment is Enabled: 

When a new control is added between the set of controls on the canvas, on dropping the control, it is 

auto aligned with the left location of the control just above it. 

 

When Auto-Relativity is Enabled: 

When a new control is added in canvas anywhere in the design area, it should adjust properly by 

maintaining relativity with all other controls. All controls below the inserted object will move downwards 

in order to give appropriate space for the new object. When any control is deleted then all the controls 

below it will move upwards without losing relativity. On resizing control, all controls will move 

accordingly. 

 
5.7.3 Password designer 
This option allows you to design a password for the PDF report: 

To compose a password: 

1. From the Tools menu, select the Password Designer option. The following screen appears. 
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Figure 5.108 
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2. Type the Password Policy description. 

3. Select the Password Logic: Section Type from the dropdown menu. 

 
Figure 5.109 

 

4. When you select the Section Type as Static Text, then the Field textbox changes to Text, allowing 

you to enter free text. 
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Figure 5.110 

 

5. When you select the Section Type as Report Field, the Field, Function, Padding, Start, No. of Char 

and Filter sections get enabled. 

6. Select Padding, specify Start and No. of Char in the respective boxes. 
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Figure 5.111 

 

7. Choose the appropriate options and click Append. The Password Policy gets updated in the Sections 

Detail as shown below. 
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Figure 5.112 

 

8. Click Save to save the password policy. Password Saved Successfully message appears. 
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5.7.4 Sample PDF stamp 
This option in Tools is for PDF Stamping to add some text to distinguish between report generated from 

Composition Designer and normal generation cycle. e.g. "Sample PDF" Stamp in PDF generated directly 

from Composition Designer 

Position: The position can be set by specifying the Left and Top positions. 

Rotation: The Sample Text rotation angle can be selected as -45, 0, 45 degrees or can be set as Custom. 

Appearance: The Appearance section is to change the appearance-related setting like font, height, width 

and color. 

Preview: This option is to preview the designed stamp. 

 

 
Figure 5.113 
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5.7.5 PDF security parameters 
PDF Security Parameters allow you to set PDF security features, master password, password strength 

and permissions. 

Certain PDF security parameters like allow degraded printing, allow copy, allow printing etc. can be set 

from Tools in Composition Designer. 

To Set PDF Security Configuration: 

1. From the Tools menu, select PDF Security Parameters. The following screen appears. 

 

 
Figure 5.114 

 

2. In the Master Password Settings section: 

a. Select Password Type as Static Text or Report Field. 
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Figure 5.115 

 

b. If Password Type is selected as Static Text, then enter the Password Text. 

• Selecting Show Characters checkbox allows you to view the entered password text. 

c. If Password Type is selected as Report Field, Password Field dropdown list appears and the 

following fields get enabled. 

• Padding 

• Start 

• Number of char 

 
Figure 5.116 

d. Select Password Field from the dropdown list. 
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e. Select Password Strength from the dropdown list. 

f. If Password Type is Report Field, then select Padding from the dropdown list, specify Start and 

Number of char. 

3. After specifying all the options, click on Append. 

4. The appended security feature gets added in Sections’ Detail as shown below. 

 

 
Figure 5.117 

5. The Appended Password Field can be modified and removed. Select the required password field 

listed in Sections’ Detail and click on Modify to modify and Remove to remove. 

 
Figure 5.118 
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6. Click on the Permissions tab to enable/disable the following permissions: 

• Allow Degraded Printing 

• Allow Printing 

• Allow Modify Contents 

• Allow Copy 

• Allow Modify Annotations 

• Apply Compression 

• Apply Encryption 

 

 
Figure 5.119 

 

7. Click on OK to save PDF Security Configuration. Password saved successfully message appears. 
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5.7.6 Edit master query 
This Option is used to make changes to the master query as per user requirement to fetch and display 

data fields. 

 

 
Figure 5.120 

 

5.7.7 Watermark configuration 
This option allows you to set a Watermark in the templates. Configuring a watermark is done at the 

template level and applicable to all the pages of the template. You can apply rules to the watermarks 

and show text and images alternatively in the watermark. There are two types of watermarks, Non-tiled 

and Tiled and each type includes two primary tabs Image and Text. 

Non-tiled: In Non-tiled watermarks, you can place watermarks anywhere in the file, and you can use 

both types of watermarks at the same time. 

Tiled: To insert a repeating pattern in watermarks tiled watermark is used. In tiled watermarks, you 

cannot place watermarks anywhere, and only one type of watermark is allowed to be used. 

Setting the image as a watermark 

The Image tab helps to set the image as a watermark. To configure the image as a watermark, perform 

the following steps: 

1. Open the watermark configuration from the Tools menu. 

2. Select the watermark type Non-tiled or Tiled. 

3. Click on the Image tab. By default, the image tab is selected. 

4. Select the Apply Image Watermark checkbox, to enable the configuration setting in the watermark. 
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Figure 5.121 

 
5. To configure the image watermark, enter the following details: 

 

Fields Description 

Source 

Type Choose the source type for the watermark from 

Choose file or Image URL 

Image If choose file is selected 

Click on and choose the image from the device and 

click Open.  

If the Image URL is selected 

Click on  and choose the image from the given 

dataset. 

Apply Rule Click on this link to apply the selected rule. Refer 

section Rule Association for more details. 

Position (only visible when watermark type is selected as non-tiled) 

Left Offset Specify the left offset of the image in pixels. 

Top Offset Specify the right offset of the image in pixels. 
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Tiling (only visible when watermark type is selected as tiled) 

Horizontal Specify the horizontal position in pixels. 

Vertical Specify the vertical position in pixels. 

Appearance 

Fill Opacity Specify the fill opacity of the image. 

Stroke Opacity Specify the stroke opacity of the image. 

Orientation Click on the dropdown to select the required 

orientation between 0 to 7. 

Width Specify the width of the image in pixels. By default, the 

width is set to 180. 

Height Specify the height of the image in pixels. By default, the 

width is set to 60. 

 

6. (Optional) Click Add, to add a watermark in multiple positions. 

7. (Optional) Click Delete to remove the boxes. The last remaining box cannot be deleted. 

Note 

Access to the Add and Delete buttons is blocked for the tiled watermark.  

8. Click OK to save the changes and save the watermark configuration. The image watermark is applied 

successfully. 

9. Click Preview to check the output. 

Note 

The watermark is configured at the template level and applies to all pages within the template. 

 

Setting text as a watermark 

The Text tab helps to set the text as a watermark. To configure text as a watermark, perform the 

following steps: 

1. Open the watermark configuration from the Tools menu. 

2. Select the watermark type Non-tiled or Tiled. 

3. Click on the Text tab. By default, the image tab is selected. 

4. Select the Apply Text Watermark checkbox, to enable the configuration setting in the watermark. 
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Figure 5.122 

 

5. To configure the table watermark, enter the following details: 

Fields Description 

Source 

Text Specify the text that you want to use as a watermark. 

ForeColor Specify the color that you use as a foreground of the 

watermark. 

BackColor Specify the color that you use as a background of the 

watermark. 

Font Properties Click on the link to set font type, style, and size. 

Apply Rule Click on this link to apply the selected rule. Refer 

section Rule Association for more details. 

Position (only visible when watermark type is non-tiled) 

Left Offset Specify the left offset of the image in pixels. 

Top Offset Specify the right offset of the image in pixels. 

Tiling (only visible when watermark type is tiled) 

Horizontal Specify the horizontal position in pixels. 

Vertical Specify the vertical position in pixels. 
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Appearance 

Fill Opacity Specify the fill opacity of the image. 

Stroke Opacity Specify the stroke opacity of the image. 

Orientation Click on the dropdown to select the required 

orientation between 0 to 7. 

Width Specify the width of the image in pixels. By default, the 

width is set to 180. 

Height Specify the height of the image in pixels. By default, the 

width is set to 60. 

 

6. (Optional) Click Add, to add a watermark in multiple positions. 

7. (Optional) Click Delete to remove the boxes. The last remaining box cannot be deleted. 

Note 

Add and Delete buttons are blocked for the tiled watermark.  

8. Click OK to save the changes and save the watermark configuration. The text watermark is applied 

successfully. 

9. Click Preview to check the output. 

Note 

The watermark is configured at the template level and applies to all pages within the template. 

 
 

5.7.8 Exporting XML schema 
This option is used to export the XML design structure of a report from Composition Designer. This is 

typically used for an on-demand generation scenario where data input typically consists of XML files. 

To export an XML: 

1. From the left pane, right-click the report linked to an XSD dataset. 

2. Then, select Export Schema from the context menu.  

 

NOTE: 

The Export Schema option is only available for Design on Canvas report. 

 

The Browse For Folder dialog appears. 
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3. Specify the path to save XML structure on your system. 

4. Click Save to save XML file. 

 
 

5.7.9 Decision table library 
Decision table library window is displayed in Tools. The decision table library shows the entire defined 

decision table for the selected report. These decision tables are executed one by one in the visible order. 

 

To change the order of execution; User can click to select any decision table name and move up/down 

using Arrow keys. Selection is highlighted in blue. 

 

 
Figure 5.123 
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To create a new decision table: 

1. Click New, the following window pops up: 

 

 
Figure 5.124 

 

2. Specify the Name of the Decision Table. By default, a blank condition and action are available for the 

new decision table. 
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To define a new condition: 

1. Click on Condition Header to define the Condition. On double click, Condition definition form is 

visible as shown below or click on Insert Condition to add a New Condition. 

 

 
Figure 5.125 

 

2. Specify Condition Name. 

3. Select Variable (database field) applicable for the condition. 

4. Select Type as Value or Range. Range type is applicable for integer values only. For Range type, the 

user will be able to specify Minimum and Maximum value for a variable. For Value type, the user can 

only specify a particular value for a variable. 
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5. Select Operator for Value Type variable. 

6. Click Save to save the condition. 

7. To define a new action: 

8. Click on Action header to define Action. On double click, Action definition form is visible as shown 

below or click on Insert Action to add a New Action. 

 

 
Figure 5.126 

 

9. Specify Action Name. 

10. Select Action Type as Set Variable, Set Text, or Set Image. 
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Figure 5.127 

 

For Set Variable: 

1. Select action type as Set Variable from the Action Type dropdown. 

2. Select the required database field from the Variable dropdown.  

3. Click Save to confirm the changes. 

 

For Set Text 

1. Select action type as Set Text from the Action Type combo box. 

2. Select the required dynamic content from the Dynamic Text dropdown. This dropdown lists all the 

dynamic content created for the Text and RichText Box controls in the report.  
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3. Click Save to confirm the changes. 

 

For Set Image 

1. Select action type as Set Image from the Action Type combo box. 

2. Select the required dynamic content from the Dynamic Text dropdown. This dropdown lists all the 

dynamic content created for the Image controls in the report.   

3. Click Save to confirm the changes. 

The final decision table is populated with defined conditions and actions as shown below: 

 

 
Figure 5.128 
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5.7.10 Spell check 
The Spell Check feature automatically checks and highlights any spelling errors in a piece of rich text. 

This feature helps you ensure that reports are free from spelling mistakes and typos. Also, it helps in 

improving the overall accuracy of the written content.  

 

To enable or disable spell check, follow the below steps: 

1. Click the Tools menu and select Spell Check. A checkmark icon appearing next to the spell check 

option indicates that it is enabled. 

2. Similarly, to disable the spell check, navigate to the Tools menu and select Spell Check. The 

checkmark icon disappears indicating that the spell check option is disabled. 

When spell check is enabled, the erroneous text appears wavy underlined. Right-click the text to view 

the following options: 

• Suggestion – Click to view a list of alternate word suggestions to replace a potentially misspelled 

word. You can select the correct spelling from the list of suggestions and make the correction. 

• Ignore All – Click to allow the software to ignore all instances of a potentially misspelled word 

throughout the report. 

• Add To Dictionary – Click to add a word to the internal dictionary of the CDG. Once added, it no 

longer gets flagged as a misspelling. 

 

NOTE: 

The spell check functionality supports English language only and works exclusively for rich text. 

 

5.8 Help menu 
The Help menu has one option, About Composition Designer. This screen displays the currently installed 

version and the copyright-related information of Composition Designer. 
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5.9 Data masking 
To apply masking on a field, right-click on Field, click on Properties then select Data Masking tab. 

Following window will appear for field length data masking. 

 

 

 
Figure 5.129 

 
Example, this masking pattern is for data having length =5; Where first character, third and fourth 

character will be masked. 

 

 
Figure 5.130 
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Variable Length Data Masking would be done as shown in the figure below: 

 

 
Figure 5.131 

 

Input Type Permissible Values Comment 

Apply Masking CheckBox Checked, Unchecked If the field is to be masked then 

check on Apply Masking, otherwise 

uncheck it. 

Masking Character TextBox One character other than a 

placeholder 

Character to show in output  on the 

masked character of the input 

PlaceHolder TextBox One character other than 

masking character 

While applying a masking pattern, 

the value corresponding to the 

position of Place Holder will not be 

changed. 

Masking pattern TextBox Can use only masking character 

and placeholder 

It is used to define a masking 

condition. 

Variable Length Data CheckBox Checked, Unchecked Check on it, if the field can have 

variable length data 

Apply Pattern ComboBox Two choices: 

Start From Left 

End to Right 

It specifies from where to start 

applying the pattern on input data. 
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Replace Remaining 

Data 

ComboBox Two Choice : 

Keep Same 

With Masking Character 

It decides how to show data where 

the pattern is not applied. There 

are two options either mask all 

those character positions which 

are not under pattern or do not 

change them. 

Sample input TextBox String Specify data to be masked 

 TextBox String Output when preview Button is 

clicked. 

 

6 Toolbars 
The Output Management System supports the following toolbars to design documents: 

• Standard Toolbar 

• Formatting Toolbar 

• Objects 

• Statement Navigator 

• Page Navigator 

 

6.1 Standard toolbar 
The Standard Toolbar of OmniOMS allows users to perform most common and basic tasks on documents, 

such as creating new documents, saving documents, and specifying page settings of documents etc. The 

Standard Toolbar is shown in the following figure: 

 
Figure 6.1 

 

The following table shows the various options available in the Standard Toolbar: 

Name Description 

 Provides a blank canvas to design a new document. 

 
Saves the current document. 
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Generate PDF 

 Generate HTML 

 
Cut, Copy and Paste Object 

 Allows the user to create a PDF with a password or PDF with Master Key. 

 Allows users to view the preview of the report. Clicking on the triangular 

button opens a dropdown list of the following options: 

• Preview without Pre-print Layer 

• Preview with Pre-print Layer 

• Preview with Password 

• Preview with Grey Scale 

• Preview with Rules 

• Preview with Branding 

 
It is used to switch to design mode when you are in the preview mode. 

 
Opens the Properties of the selected field. 

 
Allows you to zoom in and zoom out the display of the output. 

 
Brings the selected drawing object to the front position among various 

drawing objects overlapping each other. 

 Sends the selected drawing object to the last position among various drawing 

objects overlapping each other. 

Table 1 

 

Preview with Rules 

Preview with Rules feature allows the user to preview a report with associated rules and their respective 

master keys. The user can select any rule associated with the report and a master key to generate a 

preview. It applies to those reports that are created using a DB Dataset. 

To generate a preview with rules, follow the given steps: 

1. Select the desired report node. 

2. Click on Preview Report  on the Standard Toolbar and select Preview with Rules option from 

the dropdown list. 
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Figure 6.2 

 

3. Preview on Rules dialog box appears. 

 

 
Figure 6.3 

4. It contains CDG and Decision Table rules. The CDG rules are shown in the Layout tab and Decision 

Table layout is shown in the Decision Table tab. 
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Figure 6.4 

5. If the user selects any rules in the Layout tab or Rows in Decision Table tab, then rules expression is 

shown in Rules Expression textbox. 

 
Figure 6.5 

6. For Decision Table rules, along with the Rules Expression, a list of actions is also shown. 
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Figure 6.6 

7. Master keys and Preview choice are shown in the Master key dropdown and Preview choice 

dropdown, respectively. 

8. After selecting a combination of Master key and Preview choice, click on the Preview button. 

 

 
Figure 6.7 
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9. The preview of the report is generated in PDF format. 

 
Figure 6.8 

10. The Search option is given to search for any rule or decision table. 

 

 
Figure 6.9 
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6.2 Objects 
The Objects toolbar is used to draw pictures, containers, charts, and various shapes in the documents. 

The Objects toolbar is shown in the following figure. 

 

 
Figure 6.10 

 
The following table shows the various options available in the Objects Toolbar: 

 

Name Description 

 
Draws a line in the document. 

 Draws a rectangle in the document. 

 Draws a round rectangle in the document. 

 Draws a circle in the document. 

 
Inserts text in the document. 

 Inserts rich text in the document. Also, you can map rich text box to RTF labels 

cc Inserts a picture in the document.  

 Inserts a table in the document. 

 Inserts a container in the document. A container is an object that contains a header, 

footer, and the body section to display data in an organized and formatted manner.  

 Allows adding a digital signature in the document. 

 Allows you to add charts in the document. 

 Allows you to add Table of Contents in document. 

 Allows you to add Arithmetic Expression in the document. 

 Allows you to add page numbers in the document. 

 Allows you to add a barcode in the document. 

 Allows you to add an Intelligent Mail (IM) barcode in the document. 

Table 2 
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6.2.1 Dynamic rich text 
To insert the dynamic rich textbox, follow the steps below: 

1. Drag and drop Rich Text on the canvas. 

Note 

This feature is not applicable for HTML and Message report types. 

2. Right-click the rich text box and select Define Sections. The Define Sections dialog appears. 

 

Figure 6.11 

 

NOTE: 

• To apply rules to the complete rich text box, insert the rich textbox, and enter the required text. Right-click and select 

“Rules”. 

• To apply indentation in the text added in the rich text box, insert the rich text box, and enter the required text. Right-

click the rich text box and select “Apply Indentation”. 
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Before 

 

After 
 

Associating Rule 

Associating rules allows you to apply rules to selected sections of text added in the rich text box. 

3. Click Add to add a new section. 

4. Enter the Section Name. 

5. Click Rules to open the related tab. 

6. Select the portion of the text with which you want to associate with the rule in the Text Selection 

Area. 

7. Click Associate Rule. The list of rules is retrieved in the Select Rule dropdown. 

8. Select the rule that you have created using the Select Rule dropdown. 

9. Select: 

• Show Object - checkbox to display the object in the document. 

• Hide Object - checkbox to hide the object. 

10. Click Save to complete the rule association. 
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Figure 6.12 

NOTE: 

• Use “Rule Details” option to view the rule details in the library. 

• Use “Create new Rule” option to create a new rule and associate it to the rich text box. 

11. Go to the Formatting tab to make any formatting-related changes to the selected text. 

12. Go to the Data Masking tab to mask the selected text. 

 
Enabling and Adding Abbreviations 

This option appears only when you create an accessible PDF. It allows you to provide an expansion or 

definition of an abbreviation for the first occurrence of the abbreviation. 

13. Click Add to add a new section. 

14. Enter the Section Name. 

15. Click Accessibility to open to related tab. 

16. Select the text for which you want to provide the full form in the Text Selection Area. 

17. Select the Abbreviation checkbox. The selected text appears as an Acronym. 

18. Enter the Full Form of the acronym. 

19. Click Save to save the changes made. 
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Figure 6.13 

NOTE: 

To know how to enable creation of accessible PDFs, refer to Enable creation of PDF-UA compliant PDFs 

 

20. Click OK to close the dialog. 

 

NOTE:  

The Dynamic Rich Textbox is applicable for WhatsApp templates and not applicable for HTML and message reports type. 

 
6.2.2 Mapping rich text box to RTF labels 
OmniOMS Composition Designer allows you to map the rich text box to external RTF content using RTF 

Labels. You must select the RTF labels containing content. When previewing a report, you can view the 

content retrieved from the RTF label. But real-time fetching of the content occurs during batch 

generation. 

For more information, refer to the Mapping RTF content to rich text box section. 
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6.3 Statement navigator 
Statement Navigator is used to navigate between various statements of the output. Statement Navigator 

is shown in the following figure. It appears enabled when the user views the output in preview mode. 

 

 
Figure 6.14 

 

6.4 Page navigator 
Page Navigator is used to navigate between various pages of a statement in the output. Page Navigator 

is shown in the following figure. It appears enabled when the user views the output in preview mode. 

 

 
Figure 6.15 

6.5 Formatting toolbar 
The Formatting toolbar includes the options to enhance the output appearance. 

 

 
Figure 6.16 

 

Following table lists the options available in the formatting toolbar: 

Name Description 

 
Use this option to change the font type of the text. 

 
Use this option to change the font size for the text. 

 
Use this option to change the text font to bold. 

 
Use this option to change the text font to italics. 
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Name Description 

 
Use this option to underlines the text 

 

Use this option to specify the portion of text added in the rich text box as 

superscript.  

 

Use this option to specify the portion of text added in the rich text box as 

subscript. 

 Use this option to strikethrough the text 

 
Use this option to align the text left. 

 Use this option to center align the text. 

 
Use this option to align the text right. 

 
Use this option to distribute your text evenly between margins. 

 
Use this option to top align the selected textbox. 

 
Use this option to middle align the selected textbox. 

 
Use this option to bottom align the selected textbox. 

 
Use this option to add space between paragraphs. 

 

Use this option to select a foreground color for the text field. 

NOTE: 

For PDF and HTML type reports, use the color picker  option to select 

the colors of visual elements like text or shapes present on the canvas and 

apply it as foreground color. 

 

Use this option to select a background color for the text field. 

NOTE: 

For PDF and HTML type reports, use the color picker  option to select 

the colors of visual elements like text or shapes present on the canvas and 

apply it as background color. 

 

Use this option to set the width of the border of the drawing objects, such 

as Line, Rectangle, and Circle. 
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Name Description 

 

Use this option to change the width of the line border. In the case of 

rectangles, you can change the style of the border. The available style 

options are Solid and Dash. 

 

Use this option to select a color to fill the border (line) of the selected 

object with that color. 

NOTE: 

For PDF and HTML type reports, use the color picker  option to select 

the colors of visual elements like text or shapes present on the canvas and 

apply it as line (border) color. 

 
Use this option to left-align the selected objects. 

 
Use this option to center-align the selected objects. 

 
Use this option to right-align the selected objects. 

 
Use this option to top align the selected objects. 

 
Use this option to middle align the selected objects. 

 
Use this option to bottom align the selected objects. 

 Use this option to merge the textbox vertically. 

 Use this option to merge multiple rich text boxes and convert into table. 

 

Use this option to create a component by capturing a segment containing 

different controls  of an existing report from the design canvas. For more 

information, refer to the Saving report segment as a component section. 

 Use this option assign same height to the selected objects. 

 Use this option assign same width to the selected objects. 

 Use this option assign same size to the selected objects. 

 
Use this option to add equal horizontal spacing for caption and database 

fields. 

 
Use this option to add equal vertical spacing for caption and database 

fields. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 210 

Name Description 

 
Use this option to copy the formatting of a selected object and apply it on 

another object. 

 

Use this option to select a format available in the formats gallery and 

apply it to any other objects. To add a format in the formats gallery, refer 

to the Adding Formats section. 

 
The DataField Properties dialog displays all the options available in the formatting toolbar. 

To view and configure data field properties, follow the below steps: 

1. Right-click the selected filed, then select Properties. The DataField Properties dialog appears. 

 

 
Figure 6.17 

 

2. The General tab displays the following fields: 

• Column Name – It displays the caption of the object. Enter a caption of your choice (if required). 

• Header Margin - Specify the marginal space to be left between the heading and the data. 

• Data Margin - Specify the marginal space to be left between the data. 

• Text alignment – Select: 

➢ Left Aling – to align data to the left. 

➢ Center Align – to align data in the center. 

➢ Right Align – to align data to the right. 

• Character Casing –You can specify character casing for string type data field only. Otherwise, the 

section appears disabled, with Normal character casing set as default. 
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Case Database Content PDF Content 

Normal rePort data rePort data 

Lower rePort data report data 

Upper rePort data REPORT DATA 

Title rePort data Report Data 

 

 
Figure 6.18 

 
3. Click Page Numbering to open the related tab.  

4. In the Format section, select the page number to apply it to the output. 
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Figure 6.19 

 

5. Click Format to open the related tab. This tab allows you to format fields containing numbers, text, 

or date. 

6. Select the required Category to display its various corresponding formats in the Format section. For 

example, the Text category allows you to select from various text formats. 

 
7. Select Category as: 

• Number – Select the required number format. In the Options section, 

➢ Select the Use 1000 separator (,) checkbox to add a comma leaving three digits from left, that 

is, at the thousandth place. 

➢ Select the Use () for Negative values checkbox to specify a negative value. 

➢ Specify the number to add a decimal after the specified number places from left in the 

Decimal Places field. 

• Text – Select the required text format. In the Options section, 

➢ Prefix - Specify the prefix for the text, that is, character(s) with which the text starts. 

➢ Suffix - Specify the suffix for the text, that is, character(s) with which the text ends. 

• Date – Select the required date format. The Options section appears disabled in the case of date. 
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Figure 6.20 

 

8. Select Borders to open the related tab. This tab allows you to set the borders around the selected object.  

9. In the Presets section, select None in case no border required. Else, select Box. 

10. In the Lines section, select the thickness of the border. 

11. Select the color of the border using the Color option. 

 

 
Figure 6.21 
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12. Click OK to save the changes made to the properties. 
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7 Design reports 
OmniOMS Composition Designer allows you to design a report by dragging and dropping components 

from the gallery or by directly using controls. You can use the components having the same dataset as 

that of communication group to design a report. 

The Reports section includes the following: 

• Report Design 

• Cover Page 

• Trailer Page 

• Annexure 

 

The Report Design section provisions a statement and report. You design multiple statements within this 

section.  

 

7.1 Create PDF or HTML or Message report 
To create a new report/ HTML Report/ Message Report: 

To create a new report/ HTML Report/ Message Report, the user can directly design the required report 

or associate a template with the report. Typically, a template consists of the organization logo, address 

disclaimers, and more. The user has the option to either import the template or link it as a master 

template. Import template option is used to import template annotations to the selected report and link 

as a master option is used to link the template with the report so that at generation time latest available 

template version will be applied to the report. 

 

NOTE: 

The master templates are not applicable to Message reports. 

 

1. Right-click the Report Design node to display a shortcut menu. 

2. Select New → Report/ HTMLReport/ Message Report from the shortcut menu. This adds a node 

under Report Design for a New Report. 

i. The Report has four options: 
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• Design on Canvas: Select this option to design a report from scratch using the CDG canvas. 

On selecting this option, a blank canvas appears. 

• Design on PDF: Select this option to design a report using an existing PDF report. This feature 

allows users to import a PDF file in CDG and can add data on the PDF document (rendered as 

part of the canvas). By this, the user gets the output PDF containing the added canvas 

elements on top of the input PDF. 

 
Figure 7.1 

 

If Design on PDF is selected, a dialog box appears for importing a PDF file in the report. 

a. Select the required PDF file and click on OK. 

 

 
Figure 7.2 

 

b. The PDF page will be rendered as an image and add it on the canvas. So, the user can 

draw the data fields, image, rich textbox, textbox and arithmetic expression on top of 

it. 
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c. After the image is imported in the page, the PDF page will be drawn on the canvas. 

The user can place the elements according to the placement of PDF controls available. 

 
Figure 7.3 

 

• Upload Word: Select this option to design a report using an existing report made in a Word 

file. Upload Word enables the users to upload word file containing text, dynamic elements, 

designs, shapes, etc. Users can edit, upload, and download the word report. 

➢ If Upload Word is selected, a new node gets added under the Report node. As you press 

enter on your keyboard after renaming this node, a dialog box appears for importing a 

Word file in the report. 

a. Select the required Word file and click on OK. 

 
Figure 7.4 

 

b. A message “Word file uploaded successfully” appears. Click on OK to close the 

message box. 

c. Once the upload is complete, the canvas appears showing the details of the uploaded 

word file. 
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Figure 7.5 

 
d. To edit this word file, go to the Default Layer. 

e. The Edit, Upload and Save buttons now appear enabled. 

f. Click on: 

• Edit to edit the uploaded word file. The file opens in its native application. 

• Upload to upload the modified file. 

• Save to save a copy of this word file in your local machine. 

 

 
Figure 7.6 

• Upload Excel: Select this option to design a report using an existing report made in an Excel file. 

The upload Excel feature enables users to upload Excel files containing text, dynamic elements, 

designs, and shapes. You can edit, upload, and download the Excel report. 
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➢ If upload Excel is selected, a new node gets added under the Report node. As you press 

enter on your keyboard after renaming this node, a dialog box appears for importing an 

Excel file in the report. 

a. Select the required Excel file and click on OK. 

Note 

Three formats of Excel csv,xlsx, xls are supported in the CDG and output format of 

file depends on input file. 

 

 

Figure 7.7 

b. A message “Excel file uploaded successfully” appears. Click on OK to close the 

message box. The canvas displays the Excel file properties which are file name, file 

size, creation time, and last modified time.  

 

 

Figure 7.8 

➢ After uploading, three operations that you can perform are edit, upload, and save. 

• Edit: It allows you to edit the uploaded Excel file. Click Edit, the file opens in its 

native application. 
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• Upload: It allows you to upload the modified file. Click Upload, to upload another 

file that replaces the existing file. 

• Save: It allows you to save a copy of the Excel file on your local computer. Click 

Save to save the file. 

ii. HTML Report and Message Report options are shown in the below figure: 

 

 
Figure 7.7 

 
Enabling creation of PDF – UA compliant reports: 

Composition Designer allows you to create accessible PDF Reports, Letters, Contracts, and Fillable PDFs. 

This helps organizations to design accessible PDFs to maintain compliance with WCAG 2.1 accessible 

guidelines and help persons with or without disabilities to have an enriched experience with accessible 

PDFs. 

To enable creation of Accessible PDFs, follow the below steps: 

1. Right-click the required report in the Objects section and select Properties. The Report Properties 

dialog appears. 

2. Select the Accessible PDF checkbox to enable creation of accessible PDFs. 
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Figure 7.8 

3. Click OK to save the changes made. 

 

NOTE: 

Refer to Annexure for a list of constraints associated with creating accessible PDFs 

 

7.2 Design PDF or HTML or Message report 
Using the controls available in the toolbars design a PDF or HTML or Message report. 

To know the usage of different controls and options present in the toolbars, refer to the Toolbars section. 

 

 
Figure 7.9 

 

NOTE: 
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To select multiple controls added to the canvas at once, click the mouse pointer, hold, and drag it over the required area 

containing the controls you want to select, then release the mouse pointer. The controls appear selected. 

 

7.3 Save PDF or HTML or Message report 
Save a Report in another Communication Group 

1. Go to Object → Output Management System → Category → Communication Group → Reports → 

Report Designs → Report  

2. Right-click on the required Report and select Save To. 

 

 
Figure 7.10 

 

3. Save Report dialog box appears. In this dialog box, select the Communication Group where the 

Report is to be saved. 

4. Now, click OK. 
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Figure 7.11 

 

5. A dialog box appears which provides information that Report is Saved Successfully. To continue on 

the saved report, click on Yes button. 

 

7.4 Create WhatsApp report 
Users can create a WhatsApp message report and it looks like a normal message report. However, in 

WhatsApp report, the users can use the different font styles for content as well. 

 

To Create a WhatsApp Report: 

1. Right-click the Reports node to display a shortcut menu. 

2. Select New → WhatsApp → WhatsApp Message from the shortcut menu to design a WhatsApp 

Report. 
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Figure 7.12 

 

3. On selecting WhatsApp Message: 

a. A new node gets added in the left pane under the selected report node. Rename it as per 

your requirement and press enter. 

b. A blank canvas appears. Now you can design it like a normal message report. Here, you have 

the added advantage of using the rich-text. You can also add file/image URL in the WhatsApp 

report. 
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Figure 7.13 

 

4. To add file/image URL in WhatsApp report: 

i. Right-click in + Add Attachment box and select Add Attachment. 

 

 
Figure 7.14 

 

ii. Add Attachment - WhatsApp Report dialog box appears. 

iii. Select the Attachment Type as Image or File. 

➢ For Image: 

➢ Enter the Image URL and click on Add to add the image. 

➢ You can also add a macro for the Image URL by clicking on Add Macro button. If Macro 

Fields are defined, the values are automatically retrieved from the database during run-

time. 
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Figure 7.15 

 

➢ For File: 

➢ Enter the File URL and File Name in the respective textboxes. 

➢ Click on Add to add the file. 

➢ You can also add macros for the File URL and File Name by clicking on Add Macro 

button. If Macro Fields are defined, the values are automatically retrieved from the 

database during run-time. 

 

 
Figure 7.16 

iv. The selected image or file appears on the canvas as shown in the below figure: 
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Figure 7.17 

 

5. Update Attachment: 

i. Right-click on the attached image/file and select Update Attachment. 

ii. Update Attachment dialog box appears. 

iii. Modify the values as required and click on Update. 

 

 
Figure 7.18 

 

6. Delete Attachment: 

i. Right-click on the attached image/file and select Delete Attachment. 

ii. The attached image/file gets deleted from the canvas. 
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Figure 7.19 
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7.5 Fillable PDF 
You can create a fillable PDF report. It appears similar to a normal PDF report. 

 

NOTE: 

The option to enable and add Labels appears only when you create an accessible PDF. To know how to enable accessible PDF 

creation, refer to the Enable creation of PDF-UA compliant PDFs 

 

To create a fillable PDF report, follow the below steps: 

1. Right-click the required reports in the Object section. 

2. Select New → Fillable PDF. 

3. Select: 

• Design on Canvas 

• Design on PDF 

 

 
Figure 7.20 
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7.5.1 Design on canvas 
On selecting Design on Canvas: 

1. A new node gets added in the left pane under the selected report node. Rename it as per your 

requirement. 

A blank canvas appears. The following interactive controls appear in the tool bar: 

a. Textbox 

b. Checkbox 

c. Radio button 

d. Radio button group 

e. List box 

f. Date picker 

 

 
Figure 7.21 

 

2. Drag and drop the control on canvas to add the interaction on the PDF. When you drag and drop the 

control on canvas, the control properties dialog appears. It is mandatory to configure up the 

properties of control. 

• Textbox: Textbox allows you  to input any text. Drag and drop the textbox button control on the 

canvas, the Interactive Text Box Properties dialog appears. 
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Figure 7.22 

 

Specify the following details: 

➢ Name: Enter the name of the text field. 

➢ Type: Select the Numeric checkbox if you want to create a numbered control. 

➢ Character Limit: Select the Enable Character Limit checkbox if you want to specify the 

character limit for the control. Then, specify the Character Limit in the text box. 

➢ Label: Select the Label checkbox. Then, specify the control label. 

Click OK to save the changes made. 

• Checkbox: Checkboxes allows you to add a list of options to select from, in the PDF. Drag and 

drop the checkbox control on the canvas, the Check Box Properties dialog appears. 

 

 
Figure 7.23 
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Specify the following details: 

➢ Name: Enter the name of the checkbox field. 

➢ Checked by Default: Select the Checked by Default checkbox to the set the default state of 

the checkbox field. 

➢ Label: Select the Label checkbox. Then, specify the control label. 

Click OK to save the changes made. 

• Radio button: Radio button allows you to select a single option from the given options. Use this 

option to create a list of two or more options that are mutually exclusive, and the end user must 

select exactly one choice. Drag and drop the radio button control on the canvas, the Radio Button 

Properties dialog appears. 

 

 
Figure 7.24 

 

Specify the following details: 

➢ Name: Enter the name of the radio button field. 

➢ Button value: Specify the value of the radio button. 

➢ Add Macro: It redirects to the database field browser window to add required macros. 

➢ Checked by default: Select the Checked by Default checkbox to the set the default value of 

the field. 

➢ Label: Select the Label checkbox. Then, specify the control label. 

Click OK to save the changes made. 
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• Radio button group: Add the radio buttons to a group such that any modification or placement 

of the radio buttons becomes easier, rather than opting for scattered radio buttons. Collections 

of radio buttons describe a set of related options. 

To make radio buttons a group, select the radio buttons and then click Radio Button Group icon. 

If the values of multiple radio buttons are same in a group, then all the radio buttons with same 

value get enabled or disabled accordingly. 

• List box: List box allows you to select one or more items from a list contained within a static, 

multiple line text box. Drag and drop the list box button control on the canvas, the List Box 

Properties dialog appears. 

 

 
Figure 7.25 

 

Specify the following details: 

➢ Name: Enter the name of the list box field. 

➢ Default item: Select the default value for the list box. 

➢ Label: Select the Label checkbox. Then, specify the control label. 

Click OK to save the changes made. 

• Date picker: Date picker allows you to select a date from a calendar or enter it into an input field. 

Drag and drop the date picker button control on the canvas, the Date Picker properties dialog 

appears. 
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Figure 7.26 

 

Specify the following details: 

➢ Name: Enter the name of the date picker field. 

➢ Date format: Add the day format (For example: 01). 

➢ Date position: Specify the position of the day (For example: 1st position, 2nd position, or 3rd 

position). 

➢ Month format: Add the month format (For example: MM, Mon, Month). 

➢ Month position: Specify the position of the month (For example: 1st position, 2nd position, or 

3rd position). 

➢ Year format: Add the year format (For example: YY, YYYY) 

➢ Year position: Specify the position of the month (For example: 1st position, 2nd position, or 

3rd position) 

➢ Separator: Select the separator that you want to use in defining the date format. The 

available options are hyphen (-), oblique (/), comma (,), or space separator ( ). 

➢ Label: Select the Label checkbox. Then, specify the control label. 

 

NOTE:  

• You can format or design buttons using the formatting toolbar.  

• The names of the interactive controls must be unique in its report. 
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7.5.2 Design on PDF 

On selecting Design on PDF: 

1. A new node gets added in the left pane under the selected report node. Rename it as per your 

requirement and press enter. 

2. The following window appears: 

 

 
Figure 7.27 

 

3. Click Browse button to browse the PDF file on which you want to make modifications.  

4. If you want to merge separated contents of your document into one, then check the Flatten PDF 

checkbox. Flattening a PDF makes it so that: Interactive elements in PDF forms such as checkboxes, 

text boxes, radio buttons, drop-down lists are no longer fillable. 

5. Modify the PDF by adding various interactions checkboxes, text boxes, radio buttons, and more. 
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7.6 Insert new page 
This feature allows the user to insert a new page before or after an existing page in the report. 

 

To Insert a New Page: 

1. Go to Reports → Report Designs → Report. By default, a new report is named as New Report. 

2. Right-click on Report and select New→ Page. 

 

 
Figure 7.28 

 

3. Insert Page Configuration dialog box appears. 

4. Specify the following details: 

i. Orientation: Select the Orientation as Portrait or Landscape. It allows you to use mixed Portrait 

and Landscape Orientations in a Single Document, i.e., you can set different orientations for 

different pages. 

ii. Select Page: Select the page before or after which the new page is to be inserted. 

iii. Insert New Page: 
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• Select After Selected Page to insert the new page after the selected page. 

• Select Before Selected Page to insert the new page before the selected page. 

5. Click on OK to insert a new page. 

 

 
Figure 7.29 

 

Copy-Paste of a Report Page 

This feature allows users to copy and paste of the report page globally, across the CDG. 

To perform copy and paste of a page, follow the given steps: 

1. Select the required page and right-click on it. 

2. Click on Copy option from the pop-up menu. 
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Figure 7.30 

 
3. After copying the page, select another report from the same or another communication group. 

4. Right-click on it and select Paste option from the pop-up menu. 

 

 
Figure 7.31 

 

5. After clicking the paste option, a Page Configuration dialog box appears. 

6. From Select Page dropdown list, select a page before or after which the copied page is to be pasted. 
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7. Select the option: 

• After Selected Page to paste the page after the selected page. 

• Before Selected Page to paste the page before the selected page. 

8. Click on OK to paste the coped page. 

 

 
Figure 7.32 
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7.7 Continuation page 
User can define a continuation page in case the second page design of the report is different from the 

first page. In this case, spillover data from the first page will be printed on the continuation page. Last 

defined continuation page will be applicable for subsequent print pages 

 

To define Continuation Page: 

1. Go to Object → Output Management System → Category → Communication Group → Reports → 

Report Designs → Report → Page. 

2. Right-click on Page and select New→Continuation Page. 

 

 
Figure 7.33 

 

Continuation page has a pre-defined printable area on which the spillover data from the first page will 

be printed. Size of printable can be increased or reduced. User can add Text, Annotations and drag-drop 

database fields on non-printable area visible in white. 
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Figure 7.34 

 

7.8 Viewing associated components 
To view the list of components associated with a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report node and select Show Associated Components. The Associated 

Components dialog appears. 

It displays the complete list of components associated with the report.  

The list includes the following information: 

• Component Name – Name of the component associated with the report. 

• Used Version – Version number of the component currently in use. 

• Component Type – The component, type as either Local or Enterprise. 

• Page number – Page number of the report on which the component is located. 

• Available Version – Latest version of the component available. 

This dialog allows you to navigate to the required component. It also allows you to generate a preview 

of the report with the upgraded component and enforce component upgrades to the report. 
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Figure 7.35 

 

7.8.1 Navigating to a component 
To navigate to a component associated with a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Show Associated Components. The Associated 

Components dialog appears. 
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Figure 7.36 

 

5. Select the required component. 

6. Click Go to Component. The selected component opens on the canvas. 
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7.8.2 Previewing a sample report with an upgraded component 
The preview feature enables you to generate a preview of the report with the upgraded component 

and verify how it affects the report appearance, without actually associating it with the report. 

 

To generate a preview, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Show Associated Components. The Associated 

Components dialog appears. 

 

 
Figure 7.37 

 

5. Select the required component and click Preview. A preview of the report with upgraded 

component appears. 
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7.8.3 Enforcing upgrades in a report 
To enforce upgrade the component in a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Show Associated Components. The Associated 

Components dialog appears. 

 

 
Figure 7.38 

 

5. Select the required component. 

6. Click Enforce Upgrade. A dialog asking to confirm enforcing upgrade in the report appears. 

7. Click Yes to confirm. The component in the selected report gets upgraded. 

If a component is used on multiple pages of a report, then updates made to the component gets 

applied to all those pages using it. 

 

NOTE: 

• To enforce an upgrade of multiple components at a time, select the required components and click Enforce Upgrade. 

• Different versions of a component cannot be used in a single report. 
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7.9 Viewing associated master layouts 
To view the list of master layouts associated with a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report node and select Show Associated Master Layouts. The Associated 

Master Layouts dialog appears. 

It displays the complete list of master layouts associated with the report.  

The list includes the following information: 

• Master Layout Name – Name of the master layout associated with the report. 

• Used Version – Version number of the master layout currently in use. 

• Master Layout Type – The component type as either Local or Enterprise. 

• Page number – Page number of the report on which the master layout is applied. When you 

apply master layout at report level, the Page number appears as “All Pages”. 

• Available Version – Latest version of the master layout available. 

This dialog allows you to navigate to the required master layout. It also allows you to enforce master 

layout upgrades to the report. 

 

7.9.1 Navigating to a master layout 
To navigate to a master layout associated with a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Associated Master Layouts. The Associated Master 

Layout dialog appears. 

5. Select the required master layout. 

6. Click Go to Master Layout. The selected master layout opens on the canvas. 
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7.9.2 Enforcing upgrades in a report 
To enforce upgrade the master layout in a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Associated Master Layouts. The Associated Master 

Layouts dialog appears. 

5. Select the required master layout. 

6. Click Enforce Upgrade. A dialog asking to confirm enforcing upgrade in the report appears. 

7. Click Yes to confirm. The master layout in the selected report gets upgraded. 

If the master layout is used on multiple pages of a report, then updates made to the master layout 

gets applied to all those pages using it. 

 

7.9.3 Removing associated master layout 
To remove the master layout associated with a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Reports node.  

4. Right-click the required report and select Remove Master Layout. A dialog appears, informing that 

master layout will be removed from all the pages. 

5. Click Yes to confirm. A dialog appears, indicating successful removal of master layout. 

6. Click OK to close the dialog. 
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7.10 Pre-printed stationery 
Users can define pre-printed stationery as a layer in the designer. This pre-printed Stationery layer design 

would be suppressed when generating output for Print files while the same would be embedded in PDF 

output generated for e-mail communications. 

To define Pre-printed Stationery: 

1. Go to Object → Output Management System → Category → Communication Group → Reports → 

Report Designs → Report → Page → Pre-print Layer. 

2. Right-click on Page and select New →Pre-print Layer. 

 

 
Figure 7.39 

 

The pre-print layer can be designed for normal page as well as can be designed for Continuation Page. 

 

7.11 Design cover page 
Statements for each job will be generated in a sorted manner as per specified sorting parameters and 

bundled according to convenience break and specified bundle criteria. Each bundle can have a cover 

page and a trailer page for easy bundle identification. The cover page can be designed in composition 

designer as below. 

To design a new Cover page: 
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1. Go to Object → Output Management System → Category. 

2. Right-click on Communication Group and select Cover Page. 

 

 
Figure 7.40 

 

To add a new cover page, right-click on Cover Page and select New→Cover Page. 

 

a. A blank cover page gets inserted and appears on the canvas. 

b. Specify the Cover page name as shown below: 

 

 
Figure 7.41 

 

c. To design a cover page, specify the name of the cover page. 

d. You can design a Cover page the same as a report. You can also add Bundle Criteria to Cover Page 

as shown below:  
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Figure 7.42 

 

e. Right-click within the textbox to add Bundle Fields as shown below: 

 

 
Figure 7.43 
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f. Specify the Bundling Fields Criteria as shown below: 

 

 
Figure 7.44 
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7.12 Design trailer page 
Trailer page can be designed in composition designer as below. 

To design a new Trailer page: 

1. Go to Object → Output Management System → Category. 

2. Right-click on Communication Group and select Trailer Page. 

 

 
Figure 7.45 

 

a. Select the default trailer page created and rename it as per the requirement. 
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Figure 7.46 

 

b. To design a Trailer page, specify the name of the Trailer Page. 

c. You can design a Trailer page the same as a report. You can also add Bundle Criteria to the Trailer 

Page as shown below: 

 

 
Figure 7.47 
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7.13 Email notification 
 

 
Figure 7.48 

 

1. To add E-mail notification user has to go to Report Properties and click on the Notification tab. 

2. User needs to put the detail To and CC details. 

3. This will enable the product to send an e-mail notification to selected list to notify the completion of 

generation, e-mail or printing services etc. 
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7.14 Container groups 
By using Container Groups, single data can be displayed in multiple output containers. To create 

container groups, carry out the following steps:- 

1. Create Container.  

2. Insert variables in the container. 

3. Right-click on the Report and select Container/Table Groups from the list. 

 

 
Figure 7.49 

 

4. Container/Table Groups dialog box appears. 

5. Select Add checkbox. 

6. Enter a Group Name. 
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7. Select Table from the Table Name dropdown list. 

8. Select Column from the Column Name dropdown list. 

 

 
Figure 7.50 

 

9. Click on Apply button to save the input. 

10. Group Name appears in the Group List. 

11. Click OK to save the changes made. Else, click Cancel to close the dialog box without saving any 

changes. 
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Figure 7.51 

 

12. In the Default Layer, Right-click on the Container. 

13. Click on Properties. 
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Figure 7.52 

 

14. Container Properties dialog box appears. 

15. Select Group, from the Group Name dropdown list. 

16. Click Apply to save the changes made. 

17. Click OK to close the dialog box, once the changes have been made. 

18. Click Cancel to close the dialog box without saving any made changes. 
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Figure 7.53 

 

To modify container/table groups, carry out the following steps:- 

1. Right-click on the Report and select Container/Table Groups from the list. 

2. Container/Table Groups dialog box appears. 

3. Select Modify checkbox. 

4. Select the required Group from the Group List. 

5. Click on Apply button to save the input. 
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NOTE: 

Except for the Margin of any Container Group, none of the other fields can be modified. 

 

 
Figure 7.54 

 

Group Modified Successfully message appears. 
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7.15 Nested container 
By using Nested Container Groups, data can be made available inside other data. To create a Nested 

Container, carry the following steps:- 

1. Create Container.  

2. Insert variables in the container. 

3. Create Nested Container inside the Container. The created Nested Container will appear like the 

following image. 

4. Click on Preview Report button to view the preview of this Nested Container. 

 

 
Figure 7.55 

5. The following Nested Container report appears. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 262 

 
Figure 7.56 
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7.16 Applying URL shortening  
CDG offers the capability to incorporate shortened URLs into your reports. You can implement URL 

shortening for the links inserted through data fields. This functionality is also available with the Rich 

Text Box and Table controls.  

For information on enabling the URL shortening feature, refer to the NewgenONE OmniOMS 11.3 SP1 

Admin Workspace User Guide. 

 

To implement URL shortening to data fields used in reports, follow the below steps: 

1. Open the required report. 

2. Right-click the data field on the design canvas and select Shorten URL. A checkmark appears next 

to the option, indicating that the URL shortening is applicable to the data field. 

3. Click the save icon . A dialog asking to save the changes made to the report appears. Click Yes to 

confirm. 

 

For information on applying URL shortening to rich text and tables, refer to the following sections: 

• Adding hyperlinks to rich text 

• Adding macro fields to rich text 

• Apply URL shortening in a table 

 

NOTE: 

• URL shortening applies to PDF, HTML, Letter, Contract, and WhatsApp reports.  

• URL shortening using the hyperlink option does not apply to Message and WhatsApp reports. 
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8 Sending report templates for approval 
 

NOTE: 

To enable iBPS approval workflow in Composition Designer, set “EnableiBPSApprovalWorkflow” in CDG.ini as “Y”. Else, the 

option does not appear. 

 

Composition Designer (CDG) provides the option to send the report templates for approval before 

baselining them for production run. Approval workflow is essential to ensure that communications are 

thoroughly reviewed, before sharing with the customers.  

Designated reviewers approve or reject the report design templates. The approval flow can either be 

sequential or parallel.  

 

NOTE: 

To enable Template Approval in OmniOMS CDG, the Approval Workflow must be created in iBPS Process Modeler. 

 

This chapter explains the following: 

• Mapping Approval Workflow with Communication Group 

• Creating new report 

• Saving report templates 

• Check-in reports 

• Viewing approval summary 

• Sending report template for approval 

• Viewing associated components 

• Baselining report 
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8.1 Mapping approval workflow with communication group 
To map approval workflow, follow the below steps: 

1. In the Object Gallery section, click Object → Output Management System → select the required 

category → right-click the required communication group. 

2. Select Map Approval Workflow. The Map Approval Workflow dialog appears. 

 

 
Figure 8.1 

 

3. Select the Process Name designed in iBPS Process Designer to run approval workflow. 

4. Select the Activity ID of the process. 

5. Select the Status Variable that holds the final status (decision) of the approval workflow. 

6. Select the Comment Variable that holds the reviewer comments for approval or rejection. 

 

 
Figure 8.2 
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7. Click OK. A dialog indicating successful mapping of the communication group appears. 

8. Click OK to close the dialog. 

 
NOTE: 

After successful mapping of the approval workflow with the selected communication group, all the reports listed under it 

undergoes the approval process before being baselined. 

 

8.2 Creating a new report 
You can create a new report or send an existing report listed under the communication group mapped 

with the approval workflow. 

To know how to create a new report, refer to the Design reports section. 

 

8.3 Saving report templates 
To save a report template, follow the below steps: 

1. Open the report that you want to send for approval. 

2. Click the Preview icon  to preview the report template. The Save icon gets enabled. 

3. Click the Save icon . The Template Sample dialog appears. 

It displays the list of previously saved samples of the selected report (if any). 

4. Enter the Sample Name. 

 

NOTE: 

You can override an existing sample or create a new one.  
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Figure 8.3 

5. Click OK. A dialog indicating successful saving of sample template appears. 

6. Click OK to close the dialog. 

 

NOTE: 

You can save multiple samples of a single report template. Every time you save a new sample, preview it first, and then save.  
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8.4 Check-in reports 
To check-in reports, follow the below steps: 

1. Right-click the report and select Check-in. The Check-in Information dialog appears. 

The Check-in Version appears by default. 

 

 
Figure 8.4 

 

2. Enter the Check-in Comments. 

 

 
Figure 8.5 

  



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 269 

3. Click OK. A dialog indicating successful check-in of report appears. 

4. Click OK to close the dialog. 

 

8.5 Sending report template for approval 
To send report templates for approval, follow the below steps: 

1. Right-click the report and select Show Version History. The Version Explorer appears at the bottom 

of the screen. 

It displays the Check In Date, Check In By, and Check In Comments. 

 

 
Figure 8.6 

 

 
Figure 8.7 

 

2. Click Send for Approval. The Send For Approval dialog appears. 

It displays the Process Name (process designed for approval workflow) and Template Name (report 

template you are sending for approval). 

3. Enter the Approval Comments. 

The list of available samples of the report template appear. Clickable links allow you to view the PDF 

of the attached samples. 

 

NOTE: 

You can send up to five samples of a report for approval at a time. 
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Figure 8.8 

 

4. Click Send for Approval. A dialog indicating successful sending of templates for approval appears. 

5. Click OK to close the dialog. 

 

NOTE: 

• When you open a report that is under approval workflow, a dialog indicates that it is pending approval. The preview 

appears after you click OK to close the dialog. It is not possible to modify the report template until it exits the approval 

workflow. 

• In the report list, a dot appears on the report indicating that it is under approval workflow currently. 
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8.6 Viewing approval summary 
Composition Designer allows you to preview the approval summary until the report is under approval.  

 

To view the approval summary of a report, follow the below steps: 

1. Right-click the report and select Show Approval Summary. The Approval Summary appears at the 

bottom of the screen. 

It displays the Workitem ID (created in iBPS Process Designer), Category Name (category to which 

the communication group belong), Communication Group (to which the report belongs), Report 

Name (report sent for approval), Version of the report, Status (current status of the report), 

Pending With (currently under which review). 

 

 
Figure 8.9 

 

 

2. Click Refresh to get the latest summary. 

 

NOTE: 

Once the report template exits the approval workflow cycle, the “View Workflow” option gets enabled. It allows you to 

view the who has reviewed the report template and check comments provided by the reviewer. 
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3. Right-click the report and select Show Version History. The Version Explorer appears at the bottom 

of the screen. 

If the template gets approved, the Send for Approval option appears disabled. While, if it gets 

rejected, the Send for Approval option appears enabled. Make the required changes to the report 

template and send it for approval again. 

 

 
Figure 8.10 
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8.7 Baselining report 
It is mandatory to preview the report before baselining it. 

 

To baseline the report, follow the below steps: 

1. In the Version Explorer, click Baseline. The Baseline Information dialog appears. 

It displays the Baseline Version, Effective Date From, and Effective Date To. 

 

 
Figure 8.11 

 

NOTE: 

You can modify the Effective Date From as per your requirement. 

 

2. Specify comments for baselining report in the Baseline Comment field. 

 

 
Figure 8.12 

 

3. Click OK. A dialog indicating the successful baselining of the template version appears. 

4. Click OK to close the dialog. 
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9 Add jobs 
A job is a part of the Communication Group, and the jobs folder gets created when a New 

Communication Group is created. You can create multiple jobs as per the requirement. Jobs will be 

scheduled through Cycle Management for the Production run. These jobs will be rule-driven and will 

decide the type of output that will be generated, that is, print, email, or text. 

Jobs can be of the following type: Print Job, Email Job, and Message Job. 

 

9.1 Create print job 
To create a print job: 

1. Right-click on Jobs →New →Print Job. The Print Job dialog box appears. 

 

 
Figure 8.1 

 

2. Enter the details in the General tab like Name, Description, Select Report from the dropdown menu 

that we want to send to customers as an attachment and select Output Format-is the format in 
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which we want to generate the output statements, specify the Filename Prefix – specifies the prefix 

that we need to add to the filename that would be generated. 

3. Select the Output File Path, the location for saving the generated output. The output file can be 

saved in a local machine as well as in a shared machine. 

a) Local: Select the Local radio button to save the generated output in the local machine. To specify 

the local path, click on the Output File Path button. 

b) Shared: Select the Shared radio button to save the generated output in a shared machine. 

i. Click on the Edit button to specify, edit, or view the shared location details. 

 

 
Figure 8.2 

 

ii. Shared Location Details screen appears. 
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Figure 8.3 

 

iii. In the User Name textbox, enter the user name of the shared location/machine. 

iv. In the Password textbox, enter the password of the user name. 

v. Check the Show Password checkbox to view the password while you type. 

vi. In the Domain textbox, enter the domain name of the shared machine. 

vii. In the Path textbox, enter the folder path in which the generated output is to be saved. 

viii. Click Ok to save and close the Shared Location Details. 

4. Select the checkbox for Apply Pre-printed stationery- if we want to generate output with pre-printed 

design and Duplex- in case duplex printing is required. 

5. Select Embed Font to embed the font with an attached PDF. 

6. Modify Query to specify filter condition to Master Query. 

7. Check the Password Protected checkbox in case we want to specify a password for merging PDF. 

8. Choose Sorting and Bundling tab to specify the settings as shown below: 
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Figure 8.4 

 

Bundling Criteria: Users can specify up to 3 bundling criteria for a specific bundle. The Bundle criteria 

can be chosen by clicking on the ellipsis button and select from the displayed list of database fields. 

Cover Page: The Cover page of the selected communication group to which the bundle belongs is 

displayed. 

Trailer Page: The Trailer page of the selected communication group to which the bundle belongs is 

displayed. 

No of Customers: Defines the total number of customers in a bundle. 

Bundle Name: The bundle name can be a combination of text as well as a database field. 

Bundle Path: To define the path at which the bundle is saved. 

Sorting Criteria: The sorting criterion is selected from the database fields. 

9. Click the ellipsis button to select the Data Fields, specify the Table and Column from the dropdown 

menu. 
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Figure 8.5 

 

10. Click on Page Range checkbox to enable Define Page Range. 

11. Click on the Define Page Range button. 

12. In the Define Page Range screen, specify the Start Index, End Index and Bundle Name as shown 

below: 

 

 
Figure 8.6 
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13. Select the Archival tab and make the appropriate settings as shown below: 

 

 
Figure 8.7 

 

NOTE:  

When the Call type: Service is selected, check or uncheck whether the service is secured or not. HTTP is for non-secured 

service while HTTPS is for the secured service. 

 

14. Select DMS from the dropdown menu between OmniDocs and Other DMS. 

15. If under the DMS drop-down Other DMS is selected, then refer OmniDocs REST Service for 

Message/Archival Job. 

16. Specify Server IP, Server Port and select Server Type. 

17. Click on Get Cabinet, this will populate a list of the available cabinets. 

18. Specify the Login ID and Password of the Cabinet, select Cabinet from the list, and click on Connect. 

If the OmniDocs cabinet is registered, then proceed to step 19. If not, then a pop-up appears that 

asks you to register using an immune user. To register the cabinet with an immune user, refer to the 

section Registering Immune User. 
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19. Once the cabinet is connected, the screen further shows some details: 

a. The Volume, Folder, and DataClass fields are displayed. 

b. Click on Add to add the selected folder. 

c. Click on Get Fields. The fields associated with the selected folder appear in the Map Fields 

section. 

 
Figure 8.8 

 

20. Select the fields for mapping. 

21. Click OK. Composition Designer pop up opens asking whether to save the changes or not. 

Click Yes to save the changes else click No. 

 
Figure 8.9 

22. Print Job created successfully message appears.  
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23. The created Print Job gets displayed as shown on the LHS of the object gallery.

Figure 8.10 

9.1.1 Registering OmniDocs cabinet with CCM cabinet 

using immune user 
Immune users are secondary users who help in connecting the OmniDocs cabinet with the CCM 

cabinet. Using these credentials, you can register the OmniDocs cabinet with the CCM cabinet. The 

immune user helps generate an application ID in the backend, so you do not have to register the 

application again for the cabinet. It is only applicable in case OAuth is enabled.  

To register the immune user, perform the following steps (if you want to register the OmniDocs 

application with CCM cabinet): 
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1. On the archival screen, click on Register. A pop-up window appears. 

 

 
2. Enter the Login ID and Password. A pop-up window with registration successful appears. 

NOTE  

Immune credentials also help you to directly connect the cabinet without registering the application to CCM. 

 

9.2 Create email job 
To create an email job: 

1. Right-click on Jobs → New → Email Job. 

 

 
Figure 8.11 
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2. Specify the general settings like Name, Description, Select Report, select Output Format, 

Enable/Disable Attachment, specify Output File Name, Sender Name, Sender E-mail Id and External 

Doc Path. 

3. Mail Body: The Email Body Definition is either Using Report or User Defined. 

• Select Add as Attachment to add mail body as attachment while configuring mail details. Once 

enabled, you can also add attachment name in textbox in front of the option Add as Attachment 

and also can add a macro in attachment name. 

 

For Using Report: 

a. Select the Email-Body from the dropdown menu. 

b. Select the Email Subject by clicking on the associated ellipsis button, the following Data Fields 

window pops up. 

 

 
Figure 8.12 

 

c. Select a field from the Field dropdown list and click on Add. The selected Field gets added in the 

E-mail Subject. 

d. Specify an attachment name and click on the ellipsis to add database field as an attachment 

name. 

 

 

For User Defined: 

a. Click on Design Mail Body to design the content of the email. 
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Figure 8.13 

 

b. Enter Subject, Attachment Name and specify Reply to the e-mail id. 

4. Filtration Condition can be Associate Rule or Modify Query. 

5. Associate the Rule from the Select Filtration Rule and click Add. 

6. Select Embed Font to embed the font with the attached PDF. 

7. Select the Attachment checkbox, if you want to archive only the Report. 

8. Select the Communication checkbox, if you want to archive the whole email and the Report. 

9. Select the checkbox for Apply Digital Signature if you want to associate a digital signature.  

10. Select the checkbox for Apply Password if you want to generate password-protected PDF files.  

24. Specify settings for the Archival (as explained for the Print Job) like DMS, Server, and Cabinet details. 

If OmniDocs cabinet is registered, then proceed to step 19. If not, then a pop-up appears that asks 

you to register using an immune user. Registering the cabinet with an immune user refers to 

the section Registering Immune User. 
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Figure 8.14 

11. Specify properties for the Settings tab. This tab allows you to define settings for archiving 

conversations on the cloud and the expiry time for a job.  

 
To enable cloud storage:  

OmniOMS integration with Amazon S3 and MS Azure sites facilitates temporary storage of the 

generated communications in the respective sites. Storing the generated communications in a cloud 

environment helps OmniOMS with high availability.  

 
To enable cloud storage, follow the below steps: 

a. Select the Enable Cloud Storage checkbox to specify the configuration settings for cloud 

storage. 

b. Select a suitable Storage Type from the dropdown list. You can either use Amazon S3 Sites or 

MS Azure Sites. 

c. Select a suitable Site Name from the dropdown list.  
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If you choose the Amazon S3 Site as the storage type, click the Get Buckets button, and select a 

suitable cabinet from the dropdown list. If you choose MS Azure Site as the storage type, click 

the Get Container button, and select a suitable cabinet from the dropdown list.  

d. Specify the suitable Output File Path to store the generated output. 

e. Click OK to save. 

To set mail communication expiry 

 

The E-Mail Communication Expiry feature enables you to set the expiration time of a mail job. This 

implies that records within the job will not be delivered or archived once the specified expiration 

time is reached. 

For instance, when sending a one-time password (OTP) email with a 10-minute expiry time, the mail 

will not be sent or archived 10 minutes from the request time. 

 

To set email communication expiry, follow the below steps: 

a. Select the E-mail Communication Expiry checkbox. 

b. Specify the expiration time in the Timeout field in hours and minutes. 

c. Click OK to save. 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 287 

9.3 Create message job 
To create a Message job: 

1. Right-click on Jobs→New→Message Job. 

2. Message Job dialog box appears. 

 

 
Figure 8.15 

3. Specify Job Information details: 

• Job Name 

• Job Description 

• Select a Report from the dropdown list 

4. Make the following entries in Message tab: 

i. Select Message Required checkbox. 

ii. Specify the following details in the Query section: 

a. System Query 

b. Condition 

c. Modified Query 

iii. Specify the following details in the File Information section: 
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a. Filename Prefix: Specify the prefix that we need to add to the filename that would be 

generated. 

• Click on the ellipsis button to select and specify the filename prefix. The Macro Fields 

dialog box appears. 

• Select either Report Fields or System Fields. 

➢ If Report Fields are selected, then select Table and Column from the respective text 

boxes. 

➢ If the System Field is selected, then select the desired System Field from the 

dropdown. 

• Click on Add to add the defined filename prefix. 

 

 
Figure 8.16 

b. Path: Select either, 

• Local radio button to save the generated output in a local machine. To specify the local 

path. 

o Click on Browse to select the local folder. 

o Click on Add Macro to add path through defined macro fields. 

 
Figure 8.17 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 289 

Or 

• Shared radio button to save the generated output in a shared machine. 

Click on Edit button to specify, edit or view the shared location details. 

 
Figure 8.18 

 

iv. Specify the following details in the WSDL Configuration section: 

a. Enter the WSDL Path and click on Go. 

b. Select the Service Name from the dropdown list. 

c. Select the Method Name from the dropdown list. 

d. Click on the Register button. 

e. Depending on the selected Service and Method names, fields to perform Forward Mapping 

appear. 

5. Make the following entries in the Archival tab: 

i. Select the Archival Required Checkbox. 

ii. Select DMS from the dropdown and specify the following details: 

• Server IP, Server Port, Server Type, and DMS Port. 

iii. Click on Get Cabinet, this will populate a list of the available cabinets. 

iv. Specify the following Cabinet Details: 

• Login ID and Password of the Cabinet. 

• Select the Cabinet from the list. 

• Click on Connect. If the OmniDocs cabinet is registered, then proceed to step 19. If not, then 

a pop-up appears that asks you to register using an immune user. Registering the cabinet with 

an immune user refers to the section Registering Immune User. 

v. Specify the Volume, Folder, and Dataclass fields. 

vi. Click on Add to add the selected folder. 
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vii. Click on Get Fields. The fields associated with the selected folder appear in the Map Fields 

section. 

viii. Select the fields for mapping. Map Fields will be used to specify the database table details where 

we want to store the Text of Message Report content. 

ix. A message box appears. Click Yes to save the changes. 

 

 
Figure 8.19 

 

6. Click OK to save the defined Message Job. 

7. Navigate to the Settings tab to define settings for archiving conversations on the cloud and the expiry 

time for a job. For procedural details, see Step 12 of the Create Mail Job section. 

 
9.4 Create WhatsApp job 
After creating WhatsApp related reports, users can configure the WhatsApp job. The WhatsApp job 

menu item will be enabled only for DB Dataset and users can configure it with archival as well. 
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To create a WhatsApp job: 

1. Right-click on Jobs→New→WhatsApp Job. 

2. WhatsApp Job dialog box appears. 

 
Figure 8.20 

 

3. Specify the following details in the General Tab: 

i. Job Name 

ii. Job Description 

iii. Select a Report from the dropdown list. 

iv. Select Recipient No. from the dropdown list. 

v. Provide the External Doc Path. 

vi. Enter the Filter Condition query, if any. 

vii. Output Path: Select either, 

• Local radio button to save the generated output in a local machine. To specify the local path. 

o Click on Browse to select the local folder. 

o Click on Add Macro to add path through defined macro fields. 
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OR 

• Shared radio button to save the generated output in a shared machine. 

o Click on the Edit button to specify, edit, or view the shared location details. 

 
Figure 8.21 

4. Make the following entries in the Archival tab: 

i. Select the Archival checkbox. 

ii. In the DMS section, specify the following details: 

• Select the desired DMS from the dropdown list. The options are OmniDocs and Other DMS. 

• Select the Attachment checkbox, if you want to achieve only the Report. It is not available for 

Other DMSs. 

• Select the Communication checkbox, if you want to archive the whole email and the Report. It 

is not available for Other DMSs. 

iii. If under the DMS drop-down Other DMS is selected, then refer OmniDocs REST Service for 

Message/Archival Job. 

iv. If DMS is selected as OmniDocs, then specify the following fields in the Server Details section: 

a. On selecting OmniDocs in the DMS section, the following fields appear. 

b. Enter the OmniDocs Server IP. 

c. Enter the OmniDocs Server Port. 

d. Select the required Server type from the dropdown list. 

e. Click on the Get Cabinet button. A Cabinet list appears in the Cabinet Details section. 

 

 
Figure 8.22 
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f. In the Cabinet Details section, specify the following details: 

• Enter the Login Id and the Password of the selected cabinet. 

• Select the Cabinet and click on Connect. If the OmniDocs cabinet is registered, then 

proceed to step 19. If not, then a pop-up appears that asks you to register using 

an immune user. To register the cabinet with an immune user, refer to the section 

Registering Immune User. 

• A confirmation message for a successful connection appears. Click OK to close the 

message box. 

• Extended OmniDocs fields appear. 

 

 
Figure 8.23 

• Select the Volume and Folder from the respective dropdown list. 

• Click on the Add button to add the selected Folder. 

• Select the Data Class from the dropdown list. 

• Click on the Get Fields button. 

• Map Fields appear. 

• Map the available fields by selecting the required option from the dropdown list. 

v. If DMS is selected as Other DMS, then specify the following fields in WSDL Configuration section: 

a. Enter the WSDL path and click on the Go button. 

b. Select Service Name from the dropdown list. 

c. Select Method Name from the dropdown list. 

d. Click the Register button. 

e. Select Table Name from the dropdown list. 
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f. Carry out the Forward Mapping. 

g. Carry out the Reverse Mapping. 

 

 
Figure 8.24 

 
5. Click OK to save the defined WhatsApp Job properties. 

 

 
Figure 8.25 
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6. Specify Job Information. 

7. In the Job Tab, specify the information related to the WhatsApp server. 

8. Select the REST Service configuration radio button to perform REST services-related configuration. 

9. Enter the REST service URL and Media type (XML or JSON) that must go on the back end. 

10. Click Test to establish a successful connection with the server. 

11. Once the connection has been established, the forward mapping column will be enabled itself. Add 

the mapping fields manually. The mapping fields can be added or deleted. 

 
Figure 8.26 

 

12. Navigate to the Settings tab to define settings for archiving conversations on the cloud and the expiry 

time for a job. For procedural details, see Step 12 of the Create Mail Job section. 

13. Click OK to save the changes.  

 

A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 

Print Job created successfully. The created Print Job gets displayed as shown on the LHS of the object 

gallery. 
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Figure 8.27 

 

9.5 Create on demand job 
The On Demand Job is comprised of: 

• Mail/Archival: Jobs → New → On Demand Job 

• Message/WhatsApp: Jobs → New → On Demand Job 

 

9.5.1 Mail or archival 
To create a mail or archival type On Demand Job: 

1. Right-click on Jobs → New → On Demand Job→Mail/Archival. 

 

 
Figure 8.28 
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2. On Demand Job dialog box appears. 

3. Enter the Job Name. 

4. Enter the Job Description. 

5. Select the Report type from the dropdown list. 

6. Associate Reports: It is used to associate multiple reports to a single On-Demand job. 

i. Click on Associate Reports. 

 

 
Figure 8.29 

ii. Reports Association dialog box appears. 

iii. Select the required reports from the list of Reports. 

• Click on Check all to select all the reports. 

• Click on Uncheck all to unselect all the selected reports. 

iv. Search Reports search box is provided for filtering the reports from the Reports list box. 

v. Click on OK to save the association of reports. 
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Figure 8.30 

 

7. Now specify the various details by visiting the following tabs: 

• Mail • Mail Archival • Print Archival • Settings 

 

8. Once all the tabs are specified properly, click on Validate given at the bottom-left corner of the 

screen.  

It is used to validate the configured job properties. 

In case there is no error, the message appears – The configured job properties are validated 

successfully. 

In case of an error, another pop up appears having a hyperlink to view error details. Click on the 

hyperlink to view the error details. 

9. After validating the configured job properties, click OK to save the defined On Demand Job 

properties. 

 

 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 299 

9.5.1.1 Mail Tab 
1. In the Mail tab, specify the following details: 

2. Select the Mail Required checkbox. The fields below it are now enabled. 

3. Select Sender from the dropdown list. 

4. Select Sender E-mail Id from the dropdown list. 

5. Select Mail To from the dropdown list. 

6. Select MailCC from the dropdown list. 

7. Select MailBCC from the dropdown list. 

8. For the Attachment select the Yes radio button, otherwise select No radio button. 

9. To specify E-mail Subject: 

i. Click on the E-mail Subject ellipsis button. The Macro Fields dialog box appears. 

ii. Select the required field from the available dropdown list. 

 

 
Figure 8.31 

 

10. To select Attachment Name: 

i. Click on the Attachment Name ellipsis button. The Macro Fields dialog box appears. 

ii. Select the required field from the available dropdown list. 

 

 
Figure 8.32 

 
11. In the Mail Body section, specify the following settings: 
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i. For User Defined: 

a. Click on the Design Mail Body button. E-Mail Designer dialog box appears. 

b. It allows you to design the content of the email. 

c. Write the content as per your requirement and save it. 

d. Close the screen. 

 

 
Figure 8.33 

 

ii. For HTML Report: 

a. Select HTML Report radio button. 

b. Select an HTML report from the dropdown. 

c. Select the Enable Editing checkbox to enable editing of the mail body while configuring mail 

details. 

iii. Select Add as Attachment to add the mail body as an attachment while configuring mail details. 

Once enabled, you can also add an attachment name in the given textbox and can also add a 

macro in the attachment name. 
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9.5.1.2 Mail Archival Tab 
1. Select the Archival Required checkbox to enable the mail archival and specify its settings. 

 

 
Figure 8.34 

 

2. In DMS section, specify the following details: 

i. Select the desired DMS from the dropdown list. The options are OmniDocs and Other DMS. 

ii. Select Attachment checkbox, if you want to archive only the Report. It is not available for Other 

DMSs. 

iii. Select the Communication checkbox, if you want to archive the whole email and the Report. It is 

not available for Other DMS. 

3. If under DMS drop down Other DMS is selected, then refer  

4. DMS is selected as OmniDocs, then specify the following fields in the Server Details section: 

a. On selecting OmniDocs in DMS section, the following fields appear. 

b. Enter the OmniDocs Server IP. 
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c. Enter the OmniDocs Server Port. 

d. Select the required Server type from the dropdown list. 

e.Click on Get Cabinet button. A Cabinet list appears in the Cabinet Details section. 

 

 
Figure 8.35 

 

f. In the Cabinet Details section, specify the following details: 

• Enter the Login ID and the Password of the selected cabinet. 

• Select the Cabinet and click on Connect. 

• If the OmniDocs cabinet is registered, then proceed to step 19. If not, then a pop-up 

appears that asks you to register using an immune user. To register the cabinet with 

an immune user, refer to the section Registering Immune User. 

• A confirmation message for successful connections appears. Click OK to close the 

message box. 

• Extended OmniDocs fields appear. 

 

 
Figure 8.36 
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• Select the Volume and Folder from the respective dropdown list. 

• Click on Add button to add the selected Folder. 

• Select the Data Class from the dropdown list. 

• Click on Get Fields button. 

• Map Fields appears. 

• Map the available fields by selecting the required option from the dropdown list. 

5. If DMS is selected as Other DMS, then specify the following fields in WSDL Configuration section: 

h. Enter WSDL path and click on the Go button. 

i. Select Service Name from the dropdown list. 

j. Select Method Name from the dropdown list. 

k. Click on Register button. 

l. Select Table Name from the dropdown list. 

m. Carry out the Forward Mapping. 

n. Carry out the Reverse Mapping. 

 

 
Figure 8.37 
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9.5.1.3 Print Archival Tab 
1. Select Print Archival Required checkbox to enable the print archival and specify its settings. 

 

 
Figure 8.38 

 
2. In DMS section, specify the following details: 

i. Select the desired DMS from the dropdown list. The options are OmniDocs and Other DMS. 

ii. If under DMS drop down Other DMS is selected, then refer OmniDocs REST Service for 

Message/Archival Job. 

3. If DMS is selected as OmniDocs, then specify the following fields in the Server Details section: 

i. On selecting OmniDocs in the DMS section, the following fields appear: 

ii. Enter the OmniDocs Server IP. 

iii. Enter the OmniDocs Server Port. 

iv. Select the required Server type from the dropdown list. 

v. Click the Get Cabinet button. A Cabinet list appears in the Cabinet Details section. 
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Figure 8.39 

 

vi. In Cabinet Details section, specify the following details: 

a. Enter the Login Id and the Password of the selected cabinet. 

b. Select the Cabinet and click on Connect. 

c. A confirmation message for successful connection appears. Click OK to close the message box. 

d. Extended OmniDocs fields appear. 

 

 
Figure 8.40 

 

e. Select the Volume and Folder from the respective dropdown list. 

f. Click on the Add button to add the selected Folder. 

g. Select the Data Class from the dropdown list. 

h. Click on the Get Fields button. 
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i. Map Fields appear. 

j. Map the available fields by selecting the required option from the dropdown list. 

 

4. If DMS is selected as Other DMS, then specify the following fields in the WSDL Configuration section: 

i. Enter the WSDL path and click on the Go button. 

ii. Select Service Name from the dropdown list. 

iii. Select Method Name from the dropdown list. 

iv. Click on the Register button. 

v. Select Table Name from the dropdown list. 

vi. Carry out the Forward Mapping. 

vii. Carry out the Reverse Mapping. 

 

 
Figure 8.41 

 
9.5.1.4 Settings Tab 
The Settings tab allows you to enable or disable mail and print settings. It also allows you to define 

settings for archiving conversations on the cloud and set the expiry time for a job. 

These settings include the following: 

 

• Mail Settings • Print Settings 
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o Font Embed 

o Apply Digital Signature 

o Apply Password 

o Apply Pre-Printed Stationery 

o Font Embed 

o Apply Digital Signature 

o Apply Password 

o Apply Pre-Printed Stationery 

 

 
Figure 8.42 

To enable cloud storage  

OmniOMS integration with Amazon S3 and MS Azure sites facilitates temporary storage of the generated 

communications in the respective sites. Storing the generated communications in a cloud environment 

helps OmniOMS with high availability.  

 

To enable cloud storage for On-Demand Job, follow the below steps: 

1. Select the Enable Cloud Storage checkbox to specify the configuration settings for cloud storage. 

2. Select a suitable Storage Type from the dropdown list. You can either use Amazon S3 Sites or MS 

Azure Sites. 

3. Select a suitable Site Name from the dropdown list. If you chose the Amazon S3 Site as the storage 

type, click the Get Buckets button, and select a suitable cabinet from the dropdown list. If you 
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chose MS Azure Site as the storage type, click the Get Container button, and select a suitable 

cabinet from the dropdown list.  

4. Click OK to save. 

 

To set the on-demand job expiration time 

The Communication Expiry feature enables you to set the expiration time for an On Demand Job 

(Mail/Archival). This implies that records within the job will not be delivered or archived once the 

specified expiration time is reached. 

For instance, when sending a one-time password (OTP) mail with a 10-minute expiry time, it will not be 

sent or archived 10 minutes after the request time. 

To set the Communication Expiry for an Email/Archival job, follow the below steps. 

1. Select the Communication Expiry checkbox. 

2. Specify the expiration time in the Timeout field in hours and minutes.  

3. Click OK to save. 

 

9.5.2 Message or WhatsApp 
To create a Message/WhatsApp-type On Demand Job: 

1. Right-click on Jobs→New→On Demand Job→Message/WhatsApp. 

 

.  
Figure 8.43 

2. On Demand Job dialog box appears. 
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Figure 8.44 

 

3. Configure On Demand Job section: 

i. Enter a Job Name. 

ii. Enter the Job Description. 

iii. Select a Report from the dropdown list. 

iv. Associate Reports: It is used to associate multiple reports to a single On-Demand job. 

a. Click on Associate Reports. 

b. Reports Association dialog box appears. 

c. Select the required reports from the list of Reports. 

• Click on Check all to select all the reports. 

• Click on Uncheck all to unselect all the selected reports. 

d. Search Reports search box is provided for filtering the reports from the Reports list box. 

e. Click on OK to save the association of reports. 
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Figure 8.45 

 

4. Make the following entries in the Message tab: 

i. Select Message Required checkbox. 

ii. Specify the following details in the WSDL Configuration section: 

a. Enter the WSDL Path and click on Go. 

b. Select the Service Name from the dropdown list. 

c. Select the Method Name from the dropdown list. 

d. Select Recipient No from the dropdown list.  

e. Click on Register button. 

f. Depending on the selected Service and Method names, fields to perform Forward Mapping 

appear. 

5. Make the following entries in the Archival tab: 

i. Select Archival Required checkbox. 

ii. Select DMS from the dropdown: 
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a. If the DMS is selected as OmniDocs, specify the following Server Details: 

• Server IP, Server Port, Server Type and DMS Port. 

• Click on Get Cabinet, this will populate the list of the available cabinet. 

• Specify the following Cabinet Details: 

o Login ID and Password of the Cabinet. 

o Select the Cabinet from the list. 

o Click on Connect. 

• Specify the Volume, Folder and Dataclass fields. 

• Click on Add to add the selected folder. 

• Click on Get Fields. The fields associated with the selected folder appear in the Map Fields 

section. 

• Select the fields for mapping. Map Fields will be used to specify the database table details 

where we want to store the Text of Message Report content. 

• A message box appears. Click Yes to save the changes. 

b. If the DMS is selected as Other DMS, specify the following WSDL Configuration: 

• Enter the WSDL Path and click on Go. 

• Select the Service Name from the dropdown list. 

• Select the Method Name from the dropdown list. 

• Click on Register button. 

• Depending on the selected Service and Method names, fields to perform Forward 

Mapping and Reverse Mapping appear. 
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Figure 8.46 

 

6. Make the following entries in the WhatsApp tab: 

i. Select WhatsApp Required checkbox to enable and specify WhatsApp properties. 

ii. Select Recipient No from the dropdown list. 

 

 
Figure 8.47 
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7. Once all the tabs are specified properly, click on Validate given at the bottom-left corner of the 

screen. It is used to validate the configured job properties. 

8. In case there is no error, the message appears – The configured job properties are validated 

successfully. 

9. In case of an error, another pop up appears having a hyperlink to view error details. Click on the 

hyperlink to view the error details. 

10. After validating the configured job properties, click on OK to save the defined-On Demand Job 

properties. 

11. Navigate to the Settings tab to enable or disable the message and WhatsApp settings for the job. 

Apart from this, you can also define settings for archiving conversations on the cloud and set the 

expiry time for a job. For procedural details, see Settings tab. 
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9.6 Copy-paste job 
A job can also be created by copying an existing job and pasting it to the desired location within the same 

category. 

To create a job using the Copy-Paste option, follow the given steps: 

1. Right-click on the required job and select Copy. 

 

 
Figure 8.48 

 

2. Go to the Jobs node of the same communication group and right-click on it. 

3. Select Paste. 

 
Figure 8.49 
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4. Paste Job dialog box appears. Specify the following details: 

• Name 

• Report 

• Output Format 

5. Click on OK to save and create the job. 

 

 
Figure 8.50 

 

 

10 Importing templates through MS Excel 
The Import Excel feature allows you to create Message, HTML, and Letter (Upload Word) reports 

containing jobs. An excel file containing pre-defined fields can be used to accomplish this task. 

 

Following table lists the Excel file column names with validation specifications: 

 

Column name Mandatory (Yes/No) Description 

ReportType Yes Report type must be mentioned as “H” for an 

HTML Report, “T” for a Message Report and “W” 

for Word Report. 

ReportName Yes • Report Name must be mentioned for the 

Report. 

• If the Report Name in that particular category 

and communication group is not found, then 
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the report with the given name gets added as 

a new one. 

• If the Report Name exists and the type 

mentioned in excel is also same as the report 

type in communication group, then the 

report gets checked-in as a new version. 

• Report Name cannot contain special 

characters like “\/: *?""<>|". 

NewVersion Yes • Input required as “Y” or “N” to check the 

report with the same name exists with the 

same type of report and update the report 

with the New Version. 

• If no report is found in the communication 

group, then the new report gets added with 

check-in version 1. Also, the report gets fully 

baselined. 

ReportContent Mandatory if ReportType ='H' or 

'T' 

Input required for HTML report as HTML Body, 

and Message Report, simple Text with macros 

added. 

ReportPrimaryKey Mandatory if DB dataset is 

associated 

• Input required as a single field for DB dataset 

associated communication group. For XSD 

Dataset, this field is not utilized. 

• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

ReportFields Yes • The report fields must be in the form of 

Tablename.Columnname. In case of multiple 

report fields, the input  for DB and XSD 

Dataset must be in split format, that is, (,) 

comma-separated. 

• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 
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exists, then proceeds to create the report, 

else an error message gets logged. 

EnableOnDemandRequest Yes Input required as “Y” or “N”. If Product Name for 

the report is required, then this must be “Y”. 

EnableTracking Yes Input required as “Y” or “N”. 

ProductName Yes A unique Product Name is required. 

MailTo Mandatory if ReportType = ‘H’ • Input required as a single field for DB dataset 

and XSD Dataset associated communication 

group. For XSD Dataset, this field is not 

utilized. 

• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

MailCC No • Input required as a single field for DB dataset 

and XSD Dataset associated communication 

group. For XSD Dataset, this field is not 

utilized. 

• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

MailBcc No • Input required as a single field for DB dataset 

and XSD Dataset associated communication 

group. For XSD Dataset, this field is not 

utilized. 

• The given Tablename.Columnname will be 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

SenderName No • Input required as a single field for DB dataset 

and XSD Dataset associated communication 

group. For XSD Dataset, this field is not 

utilized. 
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• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

SenderEmailId No • Input required as a single field for DB dataset 

and XSD Dataset associated communication 

group. For XSD Dataset, this field is not 

utilized. 

• The given Tablename.Columnname gets 

checked with the associated dataset tables. If 

exists, then proceeds to create the report, 

else an error message gets logged. 

Subject No • Input required as multiple fields for DB and 

XSD Dataset with the split format of && 

separated. 

• Added manual text is also allowed when 

&&Field&& is mentioned along with the text. 

• The given &&Tablename.Columnname&& 

gets checked with the associated dataset 

tables. If exists, then proceeds to create the 

report, else an error message gets logged. 

JobName Yes • JobName is not given then report name with 

Job type is considered as JobName. 

• If JobName already exists, then an error gets 

logged. 

• Job Name can't contain special character like 

“\/: *?""<>|. 

JobDescription No Simple text is allowed to add it as the description. 

ExternalDocPath No Any folder path to the local system is the input. 

AddAsAttachment Yes Input required as “Y” or “N”. 

AttachmentName Mandatory if 

"AddAsAttachment"='Y' 

If Input AddAsAttachment is “Y”, then the 

attachment name is mandatory. 

OnDemandJob Yes Input required as “Y” or “N”. By this input, the job 

gets created as OnDemand or Normal job. 
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QueryCondition No Input can be any modified query condition if 

needed. 

ModifiedQuery No Input can be any modified query if needed. 

FilenamePrefix No Input can be any user text along with 

“%MasterKey%” or the system current date as 

format “<#SYSTEM.CURRENT_DATE|dd MMM 

yy#>” is allowed if needed. 

PathType Yes Input required as “Local” or “Shared”. 

LocalPath Mandatory if "PathType"= 'Local' If PathType is “Local”, then the local folder path 

must be given. 

SharedPath Mandatory if "PathType"= 'Shared' If PathType is “Shared”, then the shared folder 

path must be given. 

DomainUser No If PathType is “Shared”, then the shared folder 

domain user name must be given. 

DomainPassword No If PathType is “Shared”, then the shared folder 

domain user password must be given. 

DomainName No If PathType is “Shared”, then the shared folder 

domain name must be given. 

WSDLPath Mandatory if ReportType = ‘T’ • Input is required as WSDL Path for Message 

service registration. 

• If service is not connected, then an error 

message gets logged. 

ServiceName Mandatory if ReportType = ‘T’ • Input is required as Service Name for 

Message service registration. 

• If Service Name is not found in the WSDL 

path, then an error message gets logged. 

MethodName Mandatory if ReportType = ‘T’ • Input is required as Method Name for 

Message service registration. 

• If Method Name is not found in the WSDL 

path, then an error message gets logged. 

ForwardmappingDetails Mandatory if ReportType = ‘T’ Input is required as the Fields = Value. And for 

multiple inputs then fields and value must be 

separated with (;) semicolon. 

DMSType Mandatory if ArchivalRequired ='Y' Input is required as “OmniDocs”. 
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ServerIP Mandatory if ArchivalRequired ='Y' Input is required as Server IP for OmniDocs 

archival. 

ServerPort Mandatory if ArchivalRequired ='Y' Input is required as Server Port for OmniDocs 

archival. 

ServerType Mandatory if ArchivalRequired ='Y' Input is required as ServerType for OmniDocs 

archival. 

CabinetLogin Mandatory if ArchivalRequired ='Y' Input is required as Cabinet Login Username for 

OmniDocs archival. 

CabinetPassword Mandatory if ArchivalRequired ='Y' Input is required as Cabinet Login Password for 

OmniDocs archival. 

CabinetName Mandatory if ArchivalRequired ='Y' Input is required as Cabinet Name for OmniDocs 

archival. 

Volume Mandatory if ArchivalRequired ='Y' Input is required as Volume Name for OmniDocs 

archival. 

Folder Mandatory if ArchivalRequired ='Y' Input is required as Folder Name which can have 

text as <#Fields#> or <#ProductName#> for 

OmniDocs archival. 

Dataclass Mandatory if ArchivalRequired ='Y' Input is required as Dataclass Name for OmniDocs 

archival. 

MappingDetails Mandatory if ArchivalRequired ='Y' Input is required as the Fields = Value. In case of 

multiple inputs, the field and value pairs must be 

separated with semicolon (;). 

WordFilePath Mandatory if ReportType = ‘W’ Local Filepath of the Word File 

JobType Yes Mail, Print, Message 

ArchivalRequired Yes Input is required as Y or N. 

HTMLReport Mandatory if "Attachment"= 'Y' HTML report name that is required to configure 

the Mail Job 

Attachment Yes Input is required as Y or N.  

IsService Yes Input is required as Y or N. 

IsSecured Yes Input is required as Y or N. 

OutputFormat Mandatory if OndemandJob='N' 

and Jobtype = 'Mail' or 'Print' 

Existing Output Format Name 

OutputFileName   It is required for Message Job. 

PrintArchivalRequired Yes Input is required as Y or N. 
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OndemandPrintArchivalDMST

ype 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as OmniDocs. 

OndemandPrintArchivalServer

IP 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Server IP for Print archival. 

OndemandPrintArchivalServer

Port 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Server Port for Print archival. 

OndemandPrintArchivalServer

Type 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as ServerType for Print archival. 

OndemandPrintArchivalCabin

etLogin 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Cabinet Login Username for 

Print archival. 

OndemandPrintArchivalCabin

etPassword 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Cabinet Login Password for 

Print archival. 

OndemandPrintArchivalCabin

etName 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Cabinet Name for Print 

archival. 

OndemandPrintArchivalVolu

me 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Volume Name for Print 

archival. 

OndemandPrintArchivalFolder Mandatory if 

"PrintArchivalRequired" = 'Y' 

Folder Name which can have text as <#Fields#> or 

<#ProductName#> for Omnidocs archival. 

OndemandPrintArchivalDataC

lass 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required as Dataclass Name for Omnidocs 

archiva.l 

OndemandPrintArchivalMappi

ngDetails 

Mandatory if 

"PrintArchivalRequired" = 'Y' 

Input is required in the form of Field = Value. In 

case of multiple inputs, the field and value pairs 

must be separated with semicolon (;). 

OndemandPrintArchivalIsServi

ce 

No Input is required as Y or N. 

OndemandPrintArchivalIsSecu

red 

No Input is required as Y or N. 

 
 
Validation for OmniDocs Archival: 

• With ServerIP, ServerPort and ServerType, the Cabinet name given gets checked. If not found, then 

an error gets logged. 
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• With CabinetName, Cabinet Username and Cabinet Password, the Cabinet gets logged in to get all 

the dataclasses and volumes. If the input is not having the dataclass or volume, then an error gets 

logged. If cabinet connection fails, then also an error gets logged. 

• With the dataclass name, all Mapping Field names are taken and checked with the user inputs. If 

nothing is found, then no mapping is made.  

 

To Import an Excel, follow the below steps: 

1. Create a Communication Group and associate it to a Dataset. 

Or select the Communication Group in which Excel import is required and associate the Dataset (If 

not associated earlier).  

2. Create the necessary output format(s) if the Mail job or Print job is required in the import.  

3. Prepare the Excel sheet with columns. Refer to the Table with Column Names and Validation 

Specifications. 

4. Right-click on the Communication Group and select Import Excel. 

 

 
Figure 9.1 

 
6. The Import Excel dialog appears. Navigate to the input Excel file and select it to open. 

 
NOTE: 

• Make sure the input Excel file is not open already. 

• The necessary error prompts appear if any error occurs while uploading processing the Excel file.  
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The Designer imports reports of HTML, Message, or Word types automatically. A success message 

appears if all inputs are correct, and reports are imported successfully. 

A successful import can be confirmed by expanding the Reports or Jobs node. 

 

 
Figure 9.2 

 
If any error occurs while importing the Excel file, a dialog with an error message appears. Click the 

link present in the dialog to view error logs. 

 

NOTE: 

Refer to the details provided in the Table with Column Names and Validation Specifications to fix issues in the imported 

Excel and try again. 

 

11 Sample templates 
Sample templates library is a repository to store templates to guide new users to aid their designing 

journey. By default, users get a few sample templates to get a flavour of different types of templates 

created through the designer. This can be easily done by following the steps below: 

1. Create a Communication Group and associate it to a Dataset. 

2. Right-click on the Communication Group and select Sample Templates. 
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Figure 10.1 

 

Sample templates window appears. 

 
Figure 10.2 

 

3. Template Category is the library of the pre-defined templates provided to the user. 

4. Select any template from the template category. 

 

Previewing the template 

1. Click Download from the right pane to preview the same template. 
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2. Specify the file name and it gets downloaded in the PDF format. 

 

Using the template 

1. Select the template and click Ok in the right pane. 

2. A new node gets added similar to the report. 

3. Rename the node as required. 

4. Click the node, the template gets displayed in the canvas pane. 

5. You can modify the template as per requirement. 

 
Saving the sample template 

2. Once the modifications have been made in the template, create any report → Check-in the report. 

3. Preview the template to generate thumbnail and enable Download button in the templates library. 

 
Figure 10.3 

 

4. Right click and Select Save to Sample Templates. The Add Sample Template window appears. 
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Figure 10.4 

 

5. In the Add Sample Template screen, specify the following: 

a. Template Name: It is the title of the template that you want to display. 

b. Category type: Specify whether the template is existing or new. 

c. Category Name: Select the category of the template using from drop down where it belongs. 

 
6. Click Ok. The template then gets saved in the templates library.  

Also, this library is available for all the associated communication groups. 

 

Note: 

If the Sample Templates are not available, then enable the tag ImportSystemTemplates = Y in CDG.ini to make it enabled 

and restart CDG. 
 

12 Enforce Dataset 
Enforce Dataset feature allows you to upgrade the dataset version easily for any template if the 

associated dataset is updated or changed. The comparison is conducted between the dataset established 

during the baseline phase of the template and the current dataset associated with the communication 

group. This process aims to enforce consistency and accuracy. With this feature, associating the new 

datasets with templates that are checked in and baselined in a communication group becomes 

convenient. 
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To enforce the dataset with reports, perform the following steps: 

1. Right-click on the communication group and choose Enforce Dataset, a pop-up window appears. 

 
2. Select the reports that you want to associate with the new dataset. 

Note 

It is mandatory to link the new dataset with the communication group, before enforcing. 

 

3. Click Enforce Dataset, to enforce reports with new datasets. 

Note 

For successful enforcement of the dataset, all fields present in the template must be in the dataset otherwise, 

the error log is displayed in the status column. 

 

13 Add and manage layout components 
A component is a subpart of a report and functions as a self-contained template. It provides a reusable 

piece of content that you can use across multiple reports. Whenever you modify a component, you can 

select whether to implement the changes to the selected reports or enforce updates to all checked-in 

reports containing the updated component at once. 

By using components, report designers can create a consistent and streamlined approach to report 

creation. It simplifies the maintenance process and reduces the time and effort required to manage 

multiple reports. 
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CDG consists of Local Layout Components and Enterprise Layout Components. Local Layout 

Components are designed for use within a specific communication group and with reports associated 

with that group. Enterprise Layout Components, on the other hand, used in all the reports available 

across all the categories. These components are not linked to any dataset and thus do not allow the 

usage of dynamic controls for their design. These types of components are best suited for static 

elements, such as the logo of an organization, disclaimer, or terms and conditions. 

CDG allows you to design PDF Components, HTML Components, and Letter Components. Each type of 

component is designed for use with a specific type of report. 

PDF Components allow you to add reusable sections to PDF-type reports, while HTML Components are 

for HTML-type reports. Letter Components, on the other hand, are available to add reusable sections 

to letters and contracts. 

When designing any type of component, you can use all the controls available in the Objects toolbar. 

For more information on using the Objects toolbar, refer to the Objects toolbar section. For Letter 

Components, in addition to the objects toolbar, the paragraph and Communication Editor are also 

available to use. 

 

NOTE: 

You can use each type of component with a specific type of report. For example, you must use a PDF component with a 

PDF-type report only. 

 

13.1 Creating a new component 
To create a new component, follow these steps: 

1. In the Objects pane, expand the required category node. 

2. Right-click the required communication group and select New > Component.  

If Layout Components already exist in the selected communication group, right-click the Layout 

Components node and select New > Component.  

For Enterprise Components, right-click the Enterprise Layout Components node and select New > 

Component. 

3. Select the appropriate type of component based on the report type you are designing: 
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• PDF Component or PDF Enterprise Component 

• HTML Component or HTML Enterprise Component 

• Letter Component or Letter Enterprise Component 

4. Specify a descriptive name for the component. 

5. Select the newly added component node to open the component design canvas. 

6. Design the component using the available controls in the toolbars. For more information on 

designing components, refer to the Toolbars section. 

7. Click the save icon  in the upper-left corner to save the component. 

Before using a new or modified component in any report, it must be checked-in and baselined. This 

ensures that only the properly saved and versioned components gets reused across different reports. 

 

Check-in a component 

To check in the components, follow the below steps: 

1. Right-click the component node and select Check-in. A dialog asking to confirm the check-in 

operation appears. 

2. Click Yes to confirm. The Check-in Information dialog appears displaying the current check-in 

version. For a newly created component, the version is 1. 

3. In the Check-in Comments text box, specify any comments you want to associate with the check-in. 

4. Click OK. A dialog informing the successful check-in of the component appears. 

5. Click OK to close the dialog. 

 

Baselining a component 

To baseline a component, follow the below steps: 

1. Right-click the component node and select Show Version History. The Version Explorer pane 

appears at the bottom of the screen. 

It displays the list of available versions of the component, and the check-in details, that is, the 

check-in date and time, the name of the user who has check-in the component, and the check-in 

comments.  
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2. Select the required version and click Baseline. The Baseline Information dialog appears. 

It displays the current baseline version. For a newly created component, the version is 1. 

3. In the Baseline Comments text box, specify any comments you want to associate with the baseline. 

4. Click OK. A dialog informing the successful baselining of the component appears. 

5. Click OK to close the dialog. 

The baselined components get populated in the Component Gallery and are now available to use in the 

reports. 

 

13.2 Adding components to a report 
To add components to a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Right-click the required communication group and select New > Reports > Design on Canvas.  

If reports already exist in the selected communication group, right-click the Reports node and 

select New > Design on Canvas.  

The report design canvas appears. 

4. Click the Component Gallery option available on the right side of the page. The Component Gallery 

pane appears. It displays the complete list of baselined components, both Local and Enterprise. 

Here, you can use the Search Component text box to search the component by name.  

Also, you can specify the Batch Size, to display the specific number of components at once. Specify 

the batch size and click the run icon . 

5. Drag and drop the required component on the report and position it as required. 

6. Click the save icon  in the upper-left corner to save the component. 

You can preview the report to verify how the component appears on the report.  

 

NOTE: 

The component gallery contains only the baselined components from both the local layout and global enterprise layout 

components.  
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13.3 Saving report segment as a component 
To create a component by capturing a segment of an existing report, follow the below steps: 

1. Open the required report. 

2. Click the create component icon  available in the formatting toolbar.  

3. Select and drag your mouse cursor over the required segment of the report. Once you have made 

selection, release the mouse cursor. The Create Component dialog appears. 

4. Select the appropriate Component Type. The available options are: 

• Local – To save the segment as a local layout component within the communication group 

where the original report is available. 

• Enterprise – To save the segment as an enterprise layout component. 

5. Click OK. The local or enterprise component node gets added within the communication group or 

enterprise layout component node. 

6. Rename the component according to your requirements and press Enter on your keyboard. The 

component opens on the design canvas. 

Before check-in and baselining, you can modify the component or use it as-is, based on your specific 

requirements. 

 

13.4 Viewing associated reports 
To view the reports associated with a component, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Layout Components node.  

4. Right-click the required component and select Show Associated Reports. The Associated Reports 

dialog appears. 

It displays the complete list of reports that are using the component.  

The list includes the following information: 

• Category Name – Name of the category to which the selected communication group belongs. 

• Communication Group Name – Name of the communication group to which the selected 

component belongs. 
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• Report Name – Name of the report using the component. 

• Report Status – Status of the report, checked in or checked out. 

• Used Component Version – Version of the component the report is using currently. 

• Component Latest Version – Latest version of the component available. 

This dialog allows you to navigate to the required report containing the selected component. Also, 

enforce upgrades directly to the report. 

 

13.4.1 Navigating to a report 
To navigate to a report containing the selected component, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Layout Components node.  

4. Right-click the required component and select Show Associated Reports. The Associated Reports 

dialog appears. 

5. Select the required report. 

6. Click Go to Report. The selected report opens on the canvas. 

13.4.2 Enforcing upgrades in a report 
To enforce upgrade the component in a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Layout Components node.  

4. Right-click the required component and select Show Associated Reports. The Associated Reports 

dialog appears. 

5. Select the required report. 

 

NOTE: 

Ensure the report on which you are enforcing the layout component upgrade is checked in. 

 

6. Click Enforce Upgrade. A dialog asking to confirm enforcing upgrade in the report appears. 
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7. Click Yes to confirm. The component in the selected report gets upgraded. 

If a component is used on multiple pages of a report, any updates made to the component gets 

applied to all the pages using this feature. 

NOTE: 

Different versions of a component cannot be used in a single report. 

 

13.5 Modifying a component 
To modify or update a component, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Layout Component node. Select the required component. 

You can modify any version of a component, including the latest version. 

4. For a checked-in component, you must first check-out and then modify it. To check-out the latest 

version, right-click the required component and select Check-out.  

For Enterprise Components, expand the Enterprise Layout Component node. Right-click the 

required component and select Check-out.  

To modify a previously created version, right-click the component node and select Show Version 

History. The Version Explorer appears at the bottom of the screen. Select the required component 

version and click Check Out. 

A dialog asking to confirm checkout appears. 

5. Click Yes to confirm. A dialog informing successful checkout of the component appears. 

6. Click OK to close the dialog.  

7. Select the component to open it on the design canvas.  

8. Make the required modifications. For more information on designing components, refer to the 

Toolbars section. 

9. Click the save icon  in the upper-left corner to save the changes made to the component. 

A modified component must be checked-in and baselined before using or updating it in any reports. 

 

NOTE: 
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In case you want to discard the modifications made to a component version, you can either right-click the component node 

and select the Undo Check-out option or open the Version Explorer and select the required version and select the Undo 

Check Out option. 

13.6 Deleting a component 
To delete a component, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Layout Component node. Right-click the required checked out component and select 

Delete.  

For Enterprise Components, expand the Enterprise Layout Component node. Right-click the 

required checked out component and select Delete.  

For a checked-in component, perform the check-out operation first and then try deleting it. 

A dialog asking to confirm deletion appears. 

4. Click Yes to confirm. The component gets deleted.  

 

NOTE: 

An error message appears when you attempt to delete a layout component linked to one or more reports. In this case, first 

unlink the component from the report(s) and then proceed with deletion. 

 

14 Add and manage master layouts 
Master Layouts are templates that allows you to define the overall layout of the reports. It helps you in 

following a consistent design across multiple pages in your reports. 

While creating a master layout, you can define various elements such as the header, footer, and layout 

body. 

Master layouts are reusable. You can link them to multiple reports and pages. By linking a master 

layout to a report or page, any modifications made to the master layout automatically propagates to all 

the linked reports and pages. This centralized approach simplifies the management of report layouts, 

as users can make changes from a single location instead of handling layouts individually for each 

report. 

Master layouts ensure that all pages in the report adhere to a unified style and structure. 
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CDG consists of: Local Master Layouts and Enterprise Master Layouts. Local Master Layouts are 

designed for use within a specific communication group and are available for mapping with reports 

associated with that group. Enterprise Master Layouts, on the other hand, are available for use in all 

the reports available across all the categories. 

CDG allows you to design PDF Master Layout, HTML Master Layout, and Letter Master Layout. Each 

type of layout is designed for use with a specific type of report. PDF Master Layouts allow you to design 

a master layout for PDF-type reports, while HTML Master Layouts are for HTML-type reports. Letter 

Master Layouts, on the other hand, are available to add master layouts to letters and contracts. 

In the cases where the dynamic report content exceeds the available space on a single page, 

continuation pages allow you to continue the report content on additional pages while maintaining the 

overall structure and layout of the report. 

You can design the layout for a continuation page separately as well. A continuation page includes only 

the header and footer design, which can be the same as or different from the one applied to the 

master page. 

You can design and add continuation pages only for PDF-type master layouts. 

For a case, where you want a specific page in a multi-page report to have a different layout, you can 

design a different layout by adding a new page within the master layout node.  

 

14.1 Creating a new master layout 
To create a new master layout, follow these steps: 

1. In the Objects pane, expand the required category node. 

2. Right-click the required communication group and select New > Master Layout.  

If Master Layout already exists in the selected communication group, right-click the Master Layout 

node and select New > Master Layout.  

For Enterprise Master Layouts, right-click the Enterprise Master Layout node and select New. 

3. Select the appropriate type of master layout based on the report type you are designing: 

• PDF Master Layout or PDF Enterprise Master Layout 

• HTML Master Layout or HTML Enterprise Master Layout  

• Letter Master Layout or Letter Enterprise Master Layout 
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4. Specify a descriptive name for the master layout. 

5. Select the newly added master layout node to open the layout design canvas. 

6. Design the master layout using the available controls in the toolbars. For more information on 

designing, refer to the Toolbars section. 

7. Click the save icon  in the upper-left corner to save the master layout. 

Before using a new or modified master layout in any report, it must be checked-in. This ensures that 

only the properly saved master layouts are used across different reports. 

 
Check-in a master layout 

To check in a master layout, follow the below steps: 

1. Right-click the master layout node and select Check-in. A dialog asking to confirm the check-in 

operation appears. 

2. Click Yes to confirm. The Check-in Information dialog appears displaying the current check-in 

version. For a newly created master layout, the version is 1. 

3. In the Check-in Comments text box, specify any comments you want to associate with the check-in. 

4. Click OK. A dialog informing the successful check-in of the master layout appears. 

5. Click OK to close the dialog. 

The checked-in master layout gets populated in the Master Layout Gallery and are now available to 

associate with the reports. 

 

14.2 Adding master layouts to a report 
To add master layouts to a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Right-click the required communication group and select New > Reports > Design on Canvas.  

If reports already exist in the selected communication group, right-click the Reports node and 

select New > Design on Canvas.  

The report design canvas appears. 
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4. Click the Master Layout Gallery option available on the right side of the page. The Master Layout 

Gallery pane appears. It displays the complete list of available master layouts. 

Here, you can use the Search Template text box to search the master layout by name.  

Also, you can specify the Batch Size to display a specific number of master layouts at once. Specify 

the batch size and click the run icon . 

Following options are available to add master layout to a report: 

• Link Master Layout 

• Import Master Layout 

14.2.1 Linking master layout 
The Link Master Layout feature enables the association of a master layout to a report as a non-editable 

field. 

To link a master layout to a report, follow the below steps: 

1. In the Master Layout Gallery, select the required master layout. 

2. Click Link Master Layout. A dialog informing successful association of master layout to the report 

appears. 

3. Click OK to close the dialog. The master layout gets linked to the report.  

 

NOTE: 

• When you link a master layout to a report, the elements of the master layout gets linked as non-editable fields.  

• Linking a master layout to a report that includes a header and footer is not possible. 

• You can link master layout at the page and report levels. 

 

14.2.2 Importing a master layout 
The Import Master Layout feature enables the importing of a master layout in a report as an editable 

field. 

To import a master layout in a report, follow the below steps: 

1. In the Master Layout Gallery, select the required master layout. 

2. Click Import Master Layout. The master layout gets added to the report. 

3. (Optional) Make the required modifications. 

4. Click the save icon  in the upper-left corner to save the changes made. 
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14.3 Viewing associated reports 
To view the reports associated with a master layout, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Master Layout node.  

4. Right-click the required master layout and select Show Associated Reports. The Associated Reports 

dialog appears. 

It displays the complete list of reports that are using the master layout.  

The list includes the following information: 

• Category Name – Name of the category to which the selected communication group belongs. 

• Communication Group Name – Name of the communication group to which the selected 

master layout belongs. 

• Report Name – Name of the report using the master layout. 

• Report Status – Status of the report, checked in or checked out. 

• Master Template Version – Version of the master layout the report is using currently. 

• Master Layout Latest Version – Latest version of the master layout available. 

This dialog allows you to navigate to the required report having the selected master layout. Also, 

enforce upgrades directly to the report. 

 

14.3.1 Navigating to a report 
To navigate to a report having the selected master layout, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Master Layout node.  

4. Right-click the required master layout and select Show Associated Reports. The Associated Reports 

dialog appears. 

5. Select the required report. 

6. Click Go to Report. The selected report opens on the canvas. 
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14.3.2 Enforcing upgrades in a report 
Using the enforce upgrade functionality, you can upgrade all master layouts on a report or page to the 

most recent version. 

 

To enforce upgrade the master layout in a report, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Master Layout node.  

4. Right-click the required master layout and select Show Associated Reports. The Associated Reports 

dialog appears. 

5. Select the required report. 

 

NOTE: 

Ensure the report on which you are enforcing the master layout upgrade is checked in. 

 

6. Click Enforce Upgrade. A dialog asking to confirm enforcing upgrade in the report appears. 

7. Click Yes to confirm. The master layout in the selected report gets upgraded.  

If a master layout is used on multiple pages of a report, then updates made to the master layout 

gets applied to all those pages using it. 

 

14.4 Modifying a master layout 
To modify or update a master layout, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

Expand the Master Layout node. Select the required master layout. 

You can modify any version of a master layout including the latest version. 

3. For a checked-in master layout, you must first check-out and then modify it. To check out the latest 

version, right-click the required master layout and select Check-out.  

For Enterprise Master Layouts, expand the Enterprise Master Layout node. Right-click the required 
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master layout and select Check-out. 

To modify a previously created version, right-click the master layout node and select Show Version 

History. The Version Explorer appears at the bottom of the screen. Select the required master 

layout version and click Check Out. 

A dialog asking to confirm checkout appears. 

4. Click Yes to confirm. A dialog informing successful checkout of the master layout appears. 

5. Click OK to close the dialog.  

6. Select the master layout to open it on the design canvas.  

7. Make the required modifications. For more information on designing master layouts, refer to the 

Toolbars section. 

8. Click the save icon  in the upper-left corner to save the changes made to the master layout. 

A modified component must be checked-in before using or updating it in any reports. 

 

NOTE: 

In case you want to discard the modifications made to a master layout version, you can either right-click the master layout 

node and select the Undo Check-out option or open the Version Explorer and select the required version and select the 

Undo Check Out option. 

 

14.5 Deleting a master layout 
To delete a master layout, follow the below steps: 

1. In the Objects pane, expand the required category node. 

2. Expand the required communication group node.  

3. Expand the Master Layout node. Right-click the required checked out master layout and select 

Delete.  

For Enterprise Master Layouts, expand the Enterprise Master Layout node. Right-click the required 

checked out master layout and select Delete.  

For a checked-in master layout, perform the check-out operation first and then try deleting it. 

A dialog asking to confirm deletion appears. 

4. Click Yes to confirm. The master layout gets deleted.  
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NOTE: 

An error message appears when you attempt to delete a master layout linked to one or more reports. In this case, first 

unlink the master layout from the report(s) and then proceed with deletion. 

 

15 Contract designer 
Contract Designer allows you to define customized terms and conditions for different types of 

engagements. 

Contract option is enabled if the Communication Group is associated with a dataset of XML-type that 

will be used for fetching variable values at run time. 

To Define Contract: 

1. Right-click the Report Designs (Communication Group → Reports → Report Designs) node to 

display a shortcut menu. 

2. Select New → Contract from the shortcut menu. 

 

 
Figure 12.1 

 

New Contract node is added under Report Designs. You can rename it to any name (for example 

Contract to Hire) as per requirements. 
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Figure 12.2 

 

3. As you click on Enter after renaming the contract, the following dialog box appears: 

 

 
Figure 12.3 

 

4. Select Using Design to design the contract from scratch on the canvas. Select Using Word File to 

design the contract using an existing Word file. Refer the section Import Word File. 
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5. Click on + sign to expand and view sub-node of the New Contract. By default, New Page is added as 

sub-node of the New Contract. 

• To rename, Right-click and select Rename.  

• To add a new page, Right-click on New Contract and select New → Page. 

• When New Page is expanded, Default Layer appears as a sub node. 

• To add a new layer, Right-click on New Page and select New → Layer. 

6. Click on Default Layer to open the Canvas. 

 

 
Figure 12.4 

 

7. After designing the contract, save it by clicking on File → Save (Ctrl+S). 

 

To define contract clauses: 

a. Right-click on the canvas to add a paragraph. 

b. Select Add Paragraph. 
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Figure 12.5 

 

c. Double-click in the paragraph textbox that appears. 

d. Now you can enter text or graphic as required. 

e. To add another paragraph, right-click on the canvas and select Add Paragraph. 

 

NOTE: 

The paragraph textboxes are floating, so you can drag and drop them anywhere within the canvas area. 
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Figure 12.6 

Macro Fields: 

If Macro Fields are defined, the values are automatically retrieved from the database during run-time. 

 

To define Macro Fields: 

a. While in text-entry mode, right-click in the paragraph box and select Macro Fields. 
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Figure 12.7 

 

b. Database Field Browser dialog box appears. 

 

 
Figure 12.8 
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c. Click on  (plus icon) to expand the node and select the desired field. 

 

 
Figure 12.9 
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d. Check the Use in Mail Body Linking checkbox if you want to use the selected field in Mail Body 

linking. 

e. Select the desired Character Casing from the dropdown list. 

The provided character casings are NORMAL, UPPER, LOWER and TITLE. 

f. Click on Select. The selected Macro Field gets inserted. 

 

 
Figure 12.10 

 

To Set Paragraph Properties: 

a. Select the Paragraph box and right-click on it. 

b. Click on Properties. 
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Figure 12.11 

 

c. Paragraph Properties dialog box appears. 

 

 
Figure 12.12 

 

d. Specify the Name in the Name textbox which would act as a bookmark for the PDF. 

e. Select the Level number from the Level dropdown list. 
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f. Select the following checkboxes if required: 

• Editable: If you want the paragraph to be editable during run-time.  

NOTE: 

By default, the macro fields in an editable paragraph are non-editable and cannot be changed by the user. 

 

• Removable: If you want the paragraph to be removable during run-time. 

• Skip Numbering: If you want to skip paragraph numbering during run-time. 

g. Click OK to save the specified Paragraph Properties, else click Cancel to cancel Paragraph 

Properties. 

 

To define sections in a paragraph 

Composition Designer allows you to mark sections within a paragraph control. Sections refer to the 

segments of the paragraph content. You can divide the content in a paragraph into multiple sections. By 

default, the macro fields in a paragraph are automatically defined as non-editable sections.  

Defining sections helps you to associate rules with a part of the text as well as allows you to apply the 

data formatting and masking on them. For more information, see Dynamic rich text.  

 

NOTE: 

You can apply data formatting and masking only on the macro fields in the non-editable sections.  

 

Additionally, you can also use sections to control the paragraph editing. For more information, see 

Control paragraph editing.  

 

To control paragraph editing 

Control editing allows you to mark sections within a paragraph as editable or non-editable. When you 

view the paragraph in the Interactive Editor, the paragraph section marked as editable appears enabled 

(prominent black color) and the section marked as non-editable appears disabled (grey color). By default, 

the macro fields in a paragraph are automatically defined as sections. 

 

NOTE: 
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The Control Editing tab is available only if the paragraph is marked as editable.  

 

To mark a section as non-editable in a paragraph, follow the below steps:  

1. In the Add New Sections dialog, navigate to the Control Editing tab. 

2. Click Add to insert a new section. 

3. Enter the name of the section in the Section Name field. 

4. Enter the starting and ending characters of the section in the Start and End fields. Alternatively, 

you can select the part of the paragraph content in the text selection area to make it non-

editable.  

5. Select the Mark as Non-Editable checkbox to make the section non-modifiable in the Interactive 

Editor.  

 

NOTE: 

The macro fields in an editable paragraph cannot be modified in the Interactive Editor. So, the Mark as Non-Editable 

checkbox appears disabled in this case.   

 

6. Click Save to confirm the changes.  

To delete an added section, select the required section from the Sections list, and then click 

Remove. 

 

To define dynamic content 

With Composition Designer, you can display dynamic content in the Paragraph control through direct 

mapping or using a decision table. For more information, see Defining dynamic content in RichText Box 

control. The dynamic content functionality for the Paragraph control works in the same way as that of 

the RichText Box control. 

 

Save a Contract in another Communication Group 

a. Go to Object → Output Management System → Category → Communication Group →Contract 

b. Right-click on the required Contract and select Save To. 
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Figure 12.13 

 

c. Save Contract dialog box appears. 

d. In this dialog box, select the Communication Group where the Report is to be saved. 

e. Click OK. 

 

 
Figure 12.14 
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f. A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 

 

15.1 Contract properties 
Contract Properties allows you to view and edit properties of the contract. 

To View and Edit Contract Properties: 

1. Right-click on Contract and select Properties. 

 

 
Figure 12.15 

2. Contract Properties dialog box appears. 
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Figure 12.16 

3. Contract Properties has the following five tabs: 

• General 

• Details 

• Paper Setup 

• Notification 

• Skip Rules 

4. After specifying the contract properties, click OK to apply the settings else click Cancel. 

 

General Tab: 

General Tab displays the basic information of Contract. The user can select for Right To Left Text 

Direction checkbox for writing text from right to left direction. 
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Details Tab: 

 

 
Figure 12.17 

 

In this Tab, the user can select to Enable for Demand Request to enable Contract for On-demand 

generation. 

Specify Product Name, Product Description and select Output Format. 

 

NOTE: 

The Product Name is mandatory as, without it, the user won’t be able to perform check-in operation. 
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Paper Setup Tab: 

 

 
Figure 12.18 

 

a. Select the required Paper Size option from the combo box. The available options are: Letter, Legal, 

Tabloid, A3, A4, A5, B5, and Custom. 

b. Select the Dimensions (in inches) of the page. Use the up and down button to change the dimensions. 

The Dimensions field gets activated only when Custom is selected from Paper Size. 

c. Select the required Orientation of the page from the displayed options. 

d. Set the Margin (in inches) of the Header and Footer of the document by using the up and down 

buttons. 

e. If you want the header or footer to appear from second page onwards, select the Show 

Header/Footer from 2nd page checkbox. 

f. Click OK to apply the settings, else click Cancel. 
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Notification Tab: 

 

 
Figure 12.19 

 

a. Check Email Notification Required checkbox. 

b. Specify the To and CC details as required. 

c. This will enable the product to send an e-mail notification to the specified email ids. 

d. Click OK to apply the settings, else click Cancel. 
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Skip Rules: 

This tab allows you to define approval and editing rules. 

 

 
Figure 12.20 

 

Approval: On checking Skip Approval checkbox, the report will not follow the approval process on the 

web portal. 

Editing: On checking Skip Editing checkbox, the report will not be allowed to edit on the web portal. 

Enforce: Enforce Rule checkbox is enabled after selecting one or both of the above two rules (Skip 

Approval, Skip Editing). If Enforce Rule checkbox is selected then the above-checked rules are enforced 

permanently and cannot be overridden from the web portal. 

 

15.1.1 Defining mandatory fields 
For information on defining mandatory fields for the contract, refer to the Defining mandatory fields 

section.  
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15.2 Apply numbering 
Numbering allows you to apply paragraph numbering on the output pages. 

To Apply Numbering: 

1. Right-click on Contract and select Apply Numbering. 

 

 
Figure 12.21 

 

2. Numbering Sequence Library dialog box appears. 
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Figure 12.22 

 

3. Click on a paragraph numbering style from the List Library. 

4. Numbering sequence applied successfully message appears. 

 

To Define New Multilevel List: 

1. Click on Define new multilevel list, appearing at the bottom of the Numbering Sequence Library. 

2. Define new multilevellist dialog box appears. 
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Figure 12.23 

 

3. Click level to modify. 

4. Select a style from the Select style dropdown list. 

5. Specify Indentation in inches. 

6. Click OK to apply, else click Cancel. 

7. Close Numbering Sequence Library dialog box. 

 

Check-in / Check-out Contract 

To Check-in a Contract: 

1. Right-click on the Contract and select Check-in. 
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Figure 12.24 

2. A dialog box appears whether you want to save the changes or not. Click Yes to confirm. Check-in 

Information dialog box appears. 

 

 
Figure 12.25 
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NOTE: 

The Check-in Version number is 1 if the Report/Contract is being checked-in for the first time. 

 

3. Specify your comments in Check-in Comments textbox. Click OK to complete the check-in process. 

Contract checked-in successfully message appears. 
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To Check-out a Contract: 

Right-click on the Contract and select Check-out. 

 

NOTE: 

The Check-out option is enabled if the selected contract is already Checked-in. 

 

 
Figure 12.26 

 

Contract checked out successfully message appears. 
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To Undo Check-out a Contract: 

Right-click on the Contract and select Undo Check-out. 

 

NOTE: 

The Undo Check-out option is enabled if the selected contract is Checked-out.  

 

 
Figure 12.27 

 

Requested operation has been performed successfully message appears. 
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15.3 Show version history 
Show Version History displays the different versions of the Contract created by a user. A new version is 

created every time you perform the check-in operation. 

To Show Version History: 

1. Right-click on the Contract and select Show Version History. 

 

 
Figure 12.28 

 

2. Version Explorer appears at the bottom of the Composition Designer screen. 
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Figure 12.29 

 

15.4 Import word file 
Apart from designing a Contract in Contract Designer, the user can import a contract designed in MS 

Word File. 

 

Refer to Import Word File to learn how to import a word file  
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16 Letter designer 
Letter Designer allows you to design customized letters for different types of engagements. 

Letter option is enabled if the Communication Group is associated with a dataset of XML-type as well as 

DB-type that will be used for fetching variable values at run time. 

• Designing Letter with a dataset of XML-type 

• Designing Letter with a dataset of DB-type 

 

To Design Letter with a Dataset of XML-Type: 

1. Right-click the Report Designs (Communication Group → Reports → Report Designs) node to 

display a shortcut menu. 

2. Select New → Letter from the shortcut menu. 

 

 
Figure 13.1 
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New Letter node is added under Report Designs. You can rename it to any name (for example Business 

Letter) as per requirements. 

 

 
Figure 13.2 

 

3. Click on + sign to expand and view sub-node of the New Letter. By default, New Page is added as a 

sub-node of the New Letter. 

• To rename, Right-click and select Rename. 

• To add a new page, Right-click on New Letter and select New → Page. 

• When New Page is expanded, Default Layer appears as a sub node. 

• To add a new layer, Right-click on New Page and select New → Layer. 

4. Click on Default Layer to open the Canvas, the area which is used to write or design the letter. 
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Figure 13.3 

 

5. After defining the letter, save it by clicking on File → Save (Ctrl+S). 

 

To Add Paragraph: 

a. Right-click on the canvas to add a paragraph. 

b. Select Add Paragraph. 
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Figure 13.4 

 

c. Double-click in the paragraph textbox that appears. 

d. Now you can enter text or graphic as required. 

e. To add another paragraph, right-click on the canvas and select Add Paragraph. 

 

NOTE: 

The paragraph textboxes are floating, so you can drag and drop them anywhere within the canvas area. 

 

 
Figure 13.5 
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Macro Fields: 

If Macro Fields are defined, the values are automatically retrieved from the database during run-time. 

 

To define Macro Fields: 

a. While in text-entry mode, right-click in the paragraph box and select Macro Fields. 

 

 
Figure 13.6 

 

b. Database Field Browser dialog box appears. 
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Figure 13.7 

 

c. Click the  (plus icon) to expand the node and select the desired field. 

 

 
Figure 13.8 
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d. Check the Use in Mail Body Linking checkbox if you want to use the selected field in Mail Body linking. 

e. Select the desired Character Casing from the dropdown list. The provided character casings are 

NORMAL, UPPER, LOWER and TITLE. 

f. Click Select. The selected Macro Field gets inserted. 

 

 
Figure 13.9 

 

To define dynamic content 

With Composition Designer, you can display dynamic content in the Paragraph control through direct 

mapping or using a decision table. For more information, see Defining dynamic content in RichText Box 

control. The dynamic content functionality for the Paragraph control works in the same way as that of 

the RichText Box control. 
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To Design Letter with a Dataset of DB-Type: 

1. Right-click on Category to create a new Communication Group as shown below: 

2. Creating a new Communication Group opens the available Dataset Gallery on the RHS of the 

composition designer. 

3. Associate a DB-type dataset from the available datasets with a Communication Group. Reports and 

Components created within a particular Communication Group will be using the associated dataset 

only. 

4. Select the dataset to be linked and click on Link Dataset with Communication Group. 

5. A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 

6. Dataset successfully associated with communication group message appears. 

7. Click OK to close the message box. 

The created Communication Group is now ready for: 

• Reports Designing: Refer to Reports. 

• Jobs Creation: Refer to Jobs. 

• Component Creation: Refer to Components. 

8. Right-click the Report Designs (Communication Group → Reports → Report Designs) node to 

display a shortcut menu. 

9. Select New → Letter from the shortcut menu. New Letter node is added under Report Designs. You 

can rename it to any name as per requirements. 

10. Go to Default Layer (expand Letter->New Page->Default Layer) to open the Canvas. 

11. To add paragraphs: 

a. Right-click on the canvas and select Add Paragraph. 

b. Paragraph textbox appears. Double-click in the textbox to enter any text or graphic as required. 

c. To add another paragraph, right-click on the canvas and select Add Paragraph. 

12. To automatically retrieve data from the database at run time: 

a. Click on Default Layer. 
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Figure 13.10 

 

b. Click on the Database tab of Object Gallery and expand the Dataset. 

 

 
Figure 13.11 

 

c. Drag a unique field and drop it on the canvas. 

d. Right-click on the dropped unique field and select Set As → Primary Key. 
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Figure 13.12 

 

e. While in text-entry mode, right-click in the paragraph box and select Macro Fields. 

 

 
Figure 13.13 

 

f. Database Field Browser dialog box appears. 
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Figure 13.14 

 

g. Click on  (plus icon) to expand the node and select the desired field. 

 
Figure 13.15 

 

h. Check the Use in Mail Body Linking checkbox if you want to use the selected field in Mail Body 

linking. 

i. Select the desired Character Casing from the dropdown list. The provided character casings are 

NORMAL, UPPER, LOWER and TITLE. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 380 

j. Click on Select. The selected Macro Field gets inserted. 

 

 
Figure 13.16 

 

13. Now, the user can preview the designed letter. To do so: 

a. Choose the designed letter to be previewed, this will open the letter as shown below: 

 

 
Figure 13.17 
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From the Standard Toolbar, click on the Preview Report. 

 

 
Figure 13.18 

 

b. Preview of the designed letter appears in PDF format, as shown in the following figure: 

 

 
Figure 13.19 

 

c. From the Standard Toolbar, click on Next Statement / Previous Statement to view the next 

statement/previous statement. 

d. From the Standard Toolbar, click on Design Mode to return to Design Mode. 

 

 
Figure 13.20 
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To Set Paragraph Properties: 

a. Select the Paragraph box and right-click on it. 

b. Click on Properties. 

 

 
Figure 13.21 

 

c. Paragraph Properties dialog box appears. 

 
Figure 13.22 

 

d. Specify the Name in the Name textbox which would act as a bookmark for the PDF. By default, Clause 

number is populated. 

e. Select the Level number from the Level dropdown list. 
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f. Select the following checkboxes if required: 

• Editable: If you want the paragraph to be editable during run-time. 

NOTE: 

By default, the macro fields in an editable paragraph are non-editable and they cannot be changed by the users. 

 

• Removable: If you want the paragraph to be removable during run-time. 

• Skip Numbering: If you want to skip paragraph numbering during run-time. 

g. Click OK to save the specified Paragraph Properties, else click Cancel to cancel Paragraph Properties. 

 

To define sections in a paragraph 

With Communication Designer, you can mark sections within a Paragraph control. For more information, 

see Defining sections. 

 

Save a Letter in another Communication Group 

a. Go to Object → Output Management System → Category → Communication Group → Letter  

b. Right-click on the required Letter and select Save To. 

 
Figure 13.23 

 

c. Save Letter dialog box appears. 
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d. In this dialog box, select the Category and then the Communication Group where the Letter is to be 

saved. 

e. Now, click on the OK button. 

 

 
Figure 13.24 

A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 

 

16.1 Letter properties 
The Letter Properties option allows you to view and modify the properties of a letter.  

 

To view and modify the properties of a letter, follow the below steps: 

1. In the Objects pane, right-click the required letter node and select Properties. The Letter Properties 

dialog appears. It consists of the following tabs: 

• General 

• Details 

• Paper Setup 

• Notification 

• Rules 

2. Configure the required properties and click OK. The changes made to the letter properties get 

saved. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 385 

 

General Tab 

The General Tab displays the basic information of the letter. It displays the following details of the 

selected letter: 

• Name of the Category 

• Type of Report 

• Name of the author who has designed the template 

• Date and time on which it was created 

• Date and time on which template was last modified 

• Name of the user who modified the template 

• Date and time on which template was last accessed 

• Approval status  
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You can modify the following properties of the letter: 

• Report Title 

• Report Author 

• Report Subject 

• Report Keyword 

• Report Language (in case of accessible PDFs, this field decides the language used for read out loud 

feature) 

 

Select the Right to Left Text Direction checkbox to change the direction of text from Right to Left. By 

default, it is Left to Right. 

Select the Accessible PDF checkbox to create an accessible PDF. 

 

Details Tab 

The Details tab allows you to enable the on-demand generation and tracking of the letter type reports. 

It provides you the option to specify the report fields. When you open these fields in the OmniOMS 

Communication Editor, these data fields appear. Also, it allows you to mark the Communication Editor 

data fields as mandatory in the letter. 

 

Select the Enable Demand Request checkbox to enable the on-demand generation of letter-type 

reports. After enabling, specify the Product Name, Product Description, and select the Output Format 

of the letter.  

 

NOTE: 

It is mandatory to specify the Product Name before performing the check-in operation. 

 

Select the Enable Tracking checkbox to enable the mail tracking (read, unread and bounce) and SMS 

tracking (delivered and undelivered) of the letter. 
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Paper Setup Tab 

The Paper Setup tab allows you configure the settings related to the layout, formatting, and 

appearance of a printed letter report. 

 

The following table describes the options present in the Paper Setup tab: 

Option Description 

Paper Size From the dropdown, select the appropriate size of the letter. The available 

options are Letter, Legal, Tabloid, A3, A4, A5, B5, and Custom. 

Dimensions Specify the dimension (length and width) of the paper in inches. This field 

enables only when you select the Custom paper size option. 

Margin Specify the margin of the header and footer from the top and bottom of 

the page respectively in inches.  

Show Header/Footer only on 1st Page Select the checkbox to display the header and footer on the first page of 

the letter report only. 

Show Header/Footer from 2nd Page Select the checkbox to display the header and footer from second page 

onwards of the letter report. 

Orientation Select the required orientation of the paper for the letter report. The 

available options are Portrait (vertical) and Landscape (horizontal). 
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Notification Tab 

The Notification tab allows you enable the notification of approval or rejection for the letter. This 

means that system sends emails to email addresses configured here. 

 

To configure notification for the letter, follow the below steps: 

1. In the Objects pane, right-click the required letter node and select Properties. The Letter Properties 

dialog appears. 

2. Open the Notification tab. 

3. Select the Email Notification Required checkbox to enable the system to send emails regarding the 

actions performed or actions required on the letter. 

4. In the To section, select the: 

5. Approval Requester checkbox – to send an email to the user who sent the letter report for 

approval. 

6. Approver checkbox – to send an email to the user who verify and approves the approver checkbox. 

7. In the Other Email Ids field, specify the additional remail IDs to whom you want to send mails. 

8. Similarly, configure the CC section.  

9. Click OK to apply the settings. 

 

 

  



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 389 

Skip Rules: 

This tab allows you to define approval, and editing rules. 

 

 
Figure 13.25 

 

Approval: On checking Skip Approval checkbox, the report will not follow the approval process on the 

web portal. 

Editing: On checking Skip Editing checkbox, the report will not be allowed to edit on the web portal. 

Enforce: Enforce Rule checkbox is enabled after selecting one or both of the above two rules (Skip 

Approval, Skip Editing). If Enforce Rule checkbox is selected then the above-checked rules are enforced 

permanently and cannot be overridden from the web portal. 
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16.1.1 Defining mandatory fields 
In CDG you can define data fields in letters as mandatory. This ensures that users cannot leave these 

fields empty and restricts them from saving or sending the letter for approval when editing in the 

Communication Editor. 

 

To define mandatory fields, follow the below steps: 

1. In the Object pane, navigate to the required letter. 

2. Right-click and select Properties. The Letter Properties dialog appears. 

3. Go the Details tab and click Communication Editor Fields. The Set Mandatory Data Fields dialog 

appears. 

4. From the Fields section, select the required data fields. 

5. Click Add to Mandatory. The selected data field appears in the Mandatory Fields section. 

6. Click OK. The mandatory fields get defined. 

7. Click OK to close the Letter Properties dialog. 

 

NOTE: 

• For a checked-in report, perform the check-out operation before defining mandatory fields.  

• Ensure specifying the Product Name in the Details tab before saving the mandatory fields. 

• To delete an added data field, select the required field in the Mandatory Fields section and click Delete. 
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16.2 Apply numbering 
Numbering allows you to apply paragraph numbers on the output pages. 

To Apply Numbering: 

1. Right-click on Letter and select Apply Numbering. 

 

 
Figure 13.26 

 

2. Numbering Sequence Library dialog box appears. 
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Figure 13.27 

 

3. Click on a paragraph numbering style from the List Library. 

4. Numbering sequence applied successfully message appears. 
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To Define New Multilevel List: 

1. Click on Define new multilevel list, appearing at the bottom of the Numbering Sequence Library. 

2. Define new multilevellist dialog box appears. 

 

 
Figure 13.28 

 

3. Click level to modify. 

4. Select a style from the Select style dropdown list. 

5. Specify Indentation in inches. 

6. Click OK to apply, else click Cancel. 

7. Close Numbering Sequence Library dialog box. 
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16.3 Check-in and check-out letters 
To Check-in a Letter: 

1. Right-click on the Letter and select Check-in. 

 

 
Figure 13.29 

 

NOTE: 

Product name is mandatory for letter check-in. You can set the product name in Details tab of Letter properties screen. 

 

A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 
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Figure 13.30 

 

NOTE: 

The Check-in Version number is 1 if the letter is being checked-in for the first time. 

 

2. Specify your comments in Check-in Comments textbox. 

3. Click OK to complete the check-in process. 

4. A dialog box appears whether you want to save the changes or not. Click Yes to confirm. 
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To Check-out a Letter: 

1. Right-click on the Letter and select Check-out. 

 

NOTE: 

The Check-out option is enabled if the selected Letter is already Checked-in. 

 

 
Figure 13.31 

 

2. Letter checked out successfully message appears. 
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To Undo Check-out a Letter: 

1. Right-click on the Letter and select Undo Check-out. 

 

NOTE: 

The Undo Check-out option is enabled if the selected letter is Checked-out.  

 

 
Figure 13.32 

 

2. Requested operation has been performed successfully message appears. 
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16.4 Show Version History 
Show Version History displays the different versions of the Letter created by a user. A new version is 

created every time you perform the check-in operation. 

To Show Version History: 

1. Right-click on the Letter and select Show Version History. 

 
Figure 13.33 

 

2. Version Explorer appears at the bottom of the Composition Designer screen. 
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Figure 13.34 

 

16.5 Import Word File 
Apart from designing a letter in Letter Designer, the user can import a letter designed in MS Word File. 

 

The process of importing a word file to create a letter is similar to that of importing a word file to create 

a contract. Refer to Import Word File to learn how to import a word file. 
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17 Rights management 
The Rights Management feature allows you to manage and control the access to categories, reports, 

layout components, and master layouts. A supervisor user can assign specific rights to users and user 

groups to ensure secured access. A user group is a collection of users.  

The rights can be assigned to the root level, category, communication group, required reports, layout 

components, and master layouts. The rights can also be assigned on the Enterprise Layout Components 

root node, and required enterprise layout components, Enterprise Master Layouts node, and required 

enterprise master layouts.  

Before assigning rights at any other level, rights at the root node must be assigned first. This ensures 

that there is a baseline level of access control and permissions established within the system. Once 

rights are assigned at the root node, they can be further granted or restricted at other levels as per the 

requirements. 

 

NOTE: 

• To enable the rights management functionality, set the value of EnableRightManagement parameter to Y in the 

CDG.ini. For more information, refer to the NewgenONE OmniOMS Administration Guide. 

• Only users in the Supervisors group or the supervisor user itself can grant rights to other users. 

• Rights management does not apply to jobs and output formats. 
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17.1 Assigning rights on root level 
To assign rights on the root level node (Output Management System), follow the below steps: 

1. In the Objects pane, right-click the Output Management System node.  

2. Select Assign Right. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 

6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the root level: 

• Create — To allow the selected user or user group to create new categories.  

• View — To allow the selected user or user group to view the categories. 

7. Click OK to confirm the changes.  

 

17.2 Assigning rights on a category 
To assign rights on a category, follow the below steps: 

1. In the Objects pane, expand the Output Management System node.  

2. Right-click the required category and select Assign Rights. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 
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6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the category level: 

• View — To allow the user or user group to view the category. 

• Edit — To allow the user or user group to rename the category. 

• Checker — To assign the user or user group with the checker rights. The basic principle of checker 

means that for each action, there must be at least two users necessary for its completion. While 

a user performs an action, the other user must be involved in authorization of the same.  

7. Click OK to confirm the changes. 

 

17.3 Assigning rights on a communication group 
To assign rights on a communication group, follow the below steps: 

1. In the Objects pane, expand the Output Management System node.  

2. Expand the required category node and right-click the required communication group. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 

6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the communication group level: 

• View — To allow the user or user group to view the reports, jobs, local layout components, and 

master layouts within the communication group. 

• Edit — To allow the user or user group to check-in, check out, modify, rename, and delete 

operation on the reports, layout components, and master layouts within the communication 

group. 
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• Checker — To assign the user or user group with the checker rights. The basic principle of checker 

means that for each action, there must be at least two different users for its completion. While 

a user performs an action, the other user must be involved in authorization of the same.  

7. Click OK to confirm the changes. 

 

17.4 Assigning rights on a report 
To assign rights on a report, follow the below steps: 

1. In the Objects pane, expand the Output Management System node.  

2. Expand the required category node > required communication group node > Reports node. 

3. Right-click the required report and select Assign Rights. The Assign Rights dialog appears. 

4. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

5. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

6. Click Add. The selected user or user group gets added to the list. 

7. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the report level: 

• View — To allow the user or user group to view the reports. 

• Edit — To allow the user or user group to perform the check-in, check out, modify, rename, and 

delete operation on the report. It also allows to remove the associated master layout from the 

report.  

8. Click OK to confirm the changes. 
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17.5 Assigning rights on layout components 
This section explains assigning of rights on the following layout components: 

• Local Layout Components 

• Enterprise Layout Components 

 

Assigning rights on Local Layout Components 

To assign rights on local layout components, follow the below steps: 

1. In the Objects pane, expand the Output Management System node.  

2. Expand the required category node > required communication group node > Layout Components 

node. 

3. Right-click the required layout component and select Assign Rights. The Assign Rights dialog 

appears. 

4. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

5. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

6. Click Add. The selected user or user group gets added to the list. 

7. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the local layout component level: 

• View — To allow the user or user group to view the layout components. 

• Edit — To allow the user or user group to perform the check-in, check out, modify, rename, and 

delete operation on the layout components.  

9. Click OK to confirm the changes. 

 

Assigning rights on Enterprise Layout Components 

To assign rights on Enterprise Layout Components root node, follow the below steps: 

1. In the Objects pane, right-click the Enterprise Layout Components root node.  
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2. Select Assign Right. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 

6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the Enterprise Layout Components root level: 

• Create — To allow the user or user group to create new enterprise layout components.  

• View — To allow the user or user group to view the enterprise layout components. 

7. Click OK to confirm the changes. 

 

To assign rights on an Enterprise Layout Component, follow the below steps: 

1. In the Objects pane, expand the Enterprise Layout Components root node.  

2. Right-click the required component node and select Assign Right. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 

6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the enterprise layout component level: 

• View — To allow the user or user group to view the enterprise layout components. 

• Edit — To allows the users to perform the check-in, check out, modify, rename, and delete 

operation on the enterprise layout component. 
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• Checker — To assign the user or user group with the checker rights. The basic principle of 

checker means that for each action, there must be at least two different users for its 

completion. While a user performs an action, the other user must be involved in authorization 

of the same. 

7. Click OK to confirm the changes. 

 

17.6 Assigning rights on master layouts 
This section explains assigning of rights on the following master layouts: 

• Local Master Layouts  

• Enterprise Master Layouts 

 

Assigning rights on Local Master Layouts 

To assign rights on local master layouts, follow the below steps: 

1. In the Objects pane, expand the Output Management System node.  

2. Expand the required category node > required communication group node > Master Layouts node. 

3. Right-click the required master layout and select Assign Rights. The Assign Rights dialog appears. 

4. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

5. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

6. Click Add. The selected user or user group gets added to the list. 

7. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the local master layout level: 

• View — To allow the user or user group to view the local master layouts. 

• Edit — To allows the user or user group to perform the check-in, check out, modify, rename, 

and delete operation on the local master layouts.  

8. Click OK to confirm the changes. 
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Assigning rights on Enterprise Master Layouts 

To assign rights on Enterprise Master Layouts root node, follow the below steps: 

1. In the Objects pane, right-click the Enterprise Master Layout root node.  

2. Select Assign Right. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 

6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the Enterprise Master Layouts root level: 

• Create —To allow the user or user group to create new enterprise master layouts. Also, they can 

view master layouts for which they have the view rights. 

• View — To allow the user or user group to view the master layouts.  

7. Click OK to confirm the changes. 

 

To assign rights on an Enterprise Master Layout, follow the below steps: 

1. In the Objects pane, expand the Enterprise Master Layouts root node.  

2. Right-click the required component node and select Assign Right. The Assign Rights dialog appears. 

3. Set the Assign To field to either User or Group.  

• Select User to assign access rights to a user. 

• Select Group to assign access rights to a user group.  

4. From the User Name dropdown, select the required user or user group from the list. The User 

Name dropdown contains a list of users or user groups depending on the value chosen for the 

Assign To field.  

5. Click Add. The selected user or user group gets added to the list. 
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6. Select the required checkbox to provide rights to the chosen user or user group. These are the 

different types of permissions you can assign at the enterprise master layout level: 

• View — To allow the user or user group to view the enterprise master layout. 

• Edit — To allows the user or user group to perform the check-in, check out, modify, rename, 

and delete operation on the master layout.  

• Checker — To assign the user or user group with the checker rights. The basic principle of 

checker means that for each action, there must be at least two different users for its 

completion. While a user performs an action, the other user must be involved in authorization 

of the same. 

7. Click OK to confirm the changes. 
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18 Maker checker 
The maker-checker process applies to certain user actions on objects. The basic principle of maker-

checker requires at least two users to be involved in completing each action. While one user performs 

the action, another user must verify and approve it. In all cases, the maker cannot act as the checker 

for actions they have performed. 

 

The maker-checker applies to the following actions: 

• Report baseline 

• Report deletion 

• Layout component baseline 

 

NOTE: 

• To enable the maker checker functionality, set the value of parameter EnableMakerChecker to Y in the CDG.ini file. For 

more information, refer to the NewgenONE OmniOMS 12.0 Administration Guide. 

• A supervisor user gets the rights of a checker to approve requests for baselining and deleting reports and layout 

components. 

• For any pending action, the system sends an email notification to all the users having checker rights on the particular 

report.  

• Once a checker approves a report or component, the approval request is automatically removed from all other users. 
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18.1 Sending report or component for approval 
To send a report or component for approval while baselining, follow the below steps: 

1. In the Objects pane, right-click the required report or component node. 

2. Select Show Version History. The Version Explorer appears. 

3. Select the required report or component version and click Baseline. The Baseline Information dialog 

appears. 

It displays the Baseline Version, Effective Date From, and Effective Date To. 

 

NOTE: 

You can modify the Effective Date From as per your requirement. 

 

4. In the Baseline Comment field, specify comments for the baselining report or component. 

5. Click OK. A dialog indicating the initiation of baseline operation appears.  

6. Click OK to close the dialog. 

On approval, the report or component gets baselined. 
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18.2 Reviewing pending requests 
Supervisor users are the checkers of approval requests. 

 

To review pending requests, follow the below steps: 

1. Click Pending Requests in the lower-right corner of the screen. The Pending Requests pane 

appears. 

It displays the list of approval requests awaiting your action. 

2. Select the required request and click: 

• Preview – to preview the component or report before accept or reject the action performed on 

them. 

• Accept – to accept the baseline or deletion action for report or layout component. 

a. Click Accept. The Remarks dialog appears. 

b. Specify your remarks for accepting the action.  

c. Click OK. The action gets completed at the makers end. 

• Reject – to reject the baseline or deletion action for a report or layout component. 

a. Click Reject. The Remarks dialog appears. 

b. Specify your remarks for rejecting the action.  

c. Click OK. The action gets added to the Rejected Requests queue of the maker. 
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19 Table 
To insert the Table in the Report, carry the following steps:- 

1. Open the default layer. 

2. Click on Table button in the toolbar. 

3. Mouse Hover button changes to +. 

 

 
Figure 16.1 

 

4. Click on the canvas, where the table is to be inserted. 

5. Holding the clicked button, stretch it as per your estimated requirement and then free the clicked 

mouse button. 

6. Table Properties dialog box appears. It has the following three tabs: 

• General 

• Cell 

• Details 
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Figure 16.2 

 

7. The General tab consists of the fields as tabled below: 

 

Fields Description 

Table Information 

Table Name Name of the table.  

Group Select a Group from the dropdown list. Refer Table Grouping to create a group and assign 

this group to different tables 

Transpose Allows you to specify column(s) width for the transposed table. To enable it, select 

Transpose checkbox and click on the Define button. In Transposed Column Details, specify 

the width percentage for each row. You can select the Equalize Width checkbox for equal 

distribution of row width. 

Set as Header Table Allows you to make the first table within a group as a header table, displaying the details 

present in the header table. The header table prints first, whenever a table from the same 

group spills over to the next page. This enhances data readability and requires a minimum 

of two tables within the same group for the feature to function. 

Row/Column 

Width % Width of the respective Column. Select the column and increase and decrease the 

respective column width %. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 414 

Equalize Width Select this checkbox to enable auto-distribution of column width. 

Column Number of Columns. Click on Add button to add more number of columns. Select the 

respective column and click on the Delete button to delete it. 

Row Number of Rows. Click on Add button to add more number of Rows. Select the respective 

Rows and click on the Delete button to delete it. Click on Rule button to open the Rule 

windows. Select or create the rule to associate it with the respective Row. 

Add Click on this button to add the respective Row/Column. 

To Insert a Row 

1. Click on Add in the Row section. 

2. Insert Row Configuration dialog box appears. 

3. Select Row from the dropdown after/before which the row has to be inserted. 

4. Select: 

• After Selected Row radio button to insert after the selected row. 

• Before Selected Row radio button to insert before the selected row. 

5. Click on OK to save the specified configuration. 

 

To Insert a Column 

1. Click on Add in the Column section. 

2. Insert Column Configuration dialog box appears. 

3. Select Column from the dropdown after/before which the column has to be inserted. 

4. Select: 

• After Selected Column radio button to inserted after the selected row. 

• Before Selected Column radio button to insert before the selected row. 

5. Click on OK to save the specified configuration. 

Remove Click on this button to remove the respective Row/Column. 

Rules Click on this button to open the Rule windows. Select or create the rule in this window, to 

associate it with the respective Row. Refer to Section 14.3 Rule Association for a clearer 

picture. 

Table Position 

Relative to Page Select this checkbox to associate the table with any previously created page on the default 

layer. 

Table Select the required table, which has to be associated with the previously created page, 

from the dropdown list. 
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Container Select the required container, which has to be associated with the previously created page, 

from the dropdown list. 

Relative Space Enter the required Relative Space.  

Add Click on this button to Add the respective selected Table/Container. 

Delete Click on this button to Delete the respective selected Table/Container. 

Set Border 

Set Border Select this checkbox to enable and set border properties. 

Line Width Enter or increase or decrease the already entered Line Width. 

Line Color Click on the dropdown box and select the required Line Color. 

Rounded Corner Select this checkbox to make the table corners rounded. 

Border Color Select this checkbox to enable and change the border color. 

Set Format 

Set Format Select this checkbox to set the text format of the Table. 

Font Select the Font from the available font dropdown list. 

Font Size Select the Font Size from the available font size dropdown list. 

Bold Click on this button to make the font bold.  

Italic Click on this button to italicize the font.  

Underline Click on this button to underline the font.  

Back Color Click on the dropdown button to select the background color. 

Fore Color Click on the dropdown button to select the foreground color. 

Center Alignment Click on the button to centrally align the text. 

Right Alignment Click on the button to right-align the text. 

Top Alignment Click on the button to left-align the text. 

Middle Alignment Click on the button to middle align the text. 

Bottom Alignment Click on the button to bottom align the text. 

Copy Format Click on this link to copy the table format. 

Apply Format Click on this link to apply the copied format of one table to another table. This link gets 

enabled after clicking on Copy Format link.  

Set Padding 

All Enter or increase/decrease the entered common padding value. 

Left Enter or increase/decrease the entered left padding value. 

Top Enter or increase/decrease the entered Top padding value. 

Right Enter or increase/decrease the entered Right padding value. 
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Bottom Enter or increase/decrease the entered Bottom padding value. 

Copy Padding Click on this link to copy the padding properties. 

Apply Padding Click on this link to apply the copied padding properties of one table to another table. This 

link gets enabled after clicking on the Copy Padding link.  

 

8. Cell tab consists of the following four tabs: - 

• Data Field 

• Appearance 

• Padding 

• Cell Format 

 

i. Data Field tab consists of a tree view of the table. The user can select the data field from the tree 

structure itself. The data field can be applied to single or multiple cells. 

 

 
Figure 16.3 

 

a. Select the desired cell or cells in the left pane. 

b. Select the desired data field from the tree structure of the table, shown in the right pane. 
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c. Click on any other cell, in the left pane. 

As you click on the other cell, the selected data field appears in the selected cell(s). 

 

 
Figure 16.4 

 

Redo/Undo Undo: This option is used to reverse your last action. Ctrl+Z keyboard keys can also be used to 

perform this option. 

Redo: This option is used to reverse your last Undo. Ctrl+Y keyboard keys can also be used to 

perform this option. 

Edit Query Click on this link to edit the query. Refer section Edit Query. This link appears after selecting a cell 

containing a data field. 

Apply Masking Click on this link to apply data masking. Refer section Apply Masking. This link appears after 

selecting a cell containing a data field. 

Apply Rules Click on this link to apply the selected rule. Refer section Rule Association for more details. 
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ii. Appearance tab: The Font section appears disabled if Set Format is enabled in the General tab. 

Therefore, to enable Font section here, disable Set Format in the General tab. 

 

 
Figure 16.5 

 

Fields Description 

Font 

Font Style Click on the dropdown button to view and select the Font Style which is to be applied on the 

Cell. 

Font Size Click on the dropdown button to select the required Font Size. 

Bold Click on this button to make the font bold. 

Italic Click on this button to italicize the font. 

Underline Click on this button to underline the font. 

Back Color Click on the dropdown button to select the Background Color. 

Fore Color Click on the dropdown button to select the Foreground Color. 

Left Alignment Click on the button to left-align the text. 

Center Alignment Click on the button to centrally align the text. 

Right Alignment Click on the button to right-align the text. 

Justify Alignment Click on the button to apply justify alignment. 

Top Alignment Click on the button to top align the text. 
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Middle Alignment Click on the button to middle align the text. 

Bottom Alignment Click on the button to bottom align the text. 

Copy Format and Apply 

Format 

Refer to the section Cell Format Copy and Paste. 

Content 

Content Type Select the required Content Type from the dropdown list. 

Static Text Running Direction 

(Right to Left) 

Select this checkbox to start the content from Right to Left. 

Textbox Enter the required Text in this Textbox. 

Define Section Click on the link to define the section, refer to Dynamic Rich Section for 

more details. 

Image Image Type Select the medium to fetch or import image as: 

• Embed Image: Select the Image File Path. 

• Watch Folder: Select the Watch Folder Path. 

• Image URL: Enter the Image URL. 

NOTE: 

When selecting an image in HTML reports, you can only choose from the 

Image URL option. The Embed Image and Watch Folder options appear 

disabled. 

Height Specify the height of the image in pixel. 

Width Specify the width of the image in pixel. 

Data Field Running Direction 

(Right to Left) 

Select on this checkbox to start the content from Right to Left. 

Table Select the required table from the dropdown list. 

Column Select the required column of the above-selected table. 

Date Format Select the required date format. 

Enable HTML Content Select this checkbox, to enable HTML content and view the normal 

contracts in HTML format also.  

Aggregate Data Aggregate Function Select the desired aggregate function from the dropdown list. The 

options are Sum, Average, Minimum, Maximum, Count, First Entry and 

Last Entry 

DB Fields This dropdown list appears when the cell is of an integer data type. 

Decimal Specify the number of places that can appear after the decimal. 
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Use 1000 separator (,) Select this checkbox to use (,) as the separator of 1000 

Indian number format Select this checkbox to use (,) as the separator as per Indian Number 

Format. 

International number 

format 

Select this checkbox to use (,) as the separator of 1000 (International 

Format) 

Convert to Words Select this checkbox to enable conversion of cell data from numbers to 

words. 

Table Define It allows you to define a table in the selected cell. The process of defining 

a table within a cell is called a Nested Table. Refer section Nested Table. 

Barcode Define It allows you to define barcode properties in the selected cell. Click on 

Define to define its properties. Refer the section Barcode. 

External Content RTF or HTML It allows you to map the table to the RTF or HTML content. Refer to the 

Mapping table to RTF or HTML labels section. 

 

iii. Padding Tab: The Padding appears disabled if Set Padding is enabled in the General tab. 

Therefore, to enable Padding here, disable Set Padding in General tab. Padding tab consists of 

the following fields: 

 

 
Figure 16.6 
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Fields Description 

Set Padding 

All Enter or increase/decrease the entered common padding value. 

Left Enter or increase/decrease the entered left padding value. 

Top Enter or increase/decrease the entered Top padding value. 

Right Enter or increase/decrease the entered Right padding value. 

Bottom Enter or increase/decrease the entered Bottom padding value. 

Copy Padding Click on this link to copy the padding properties. 

Apply Padding Click on this link to apply the copied padding properties of one table to another table. This 

link gets enabled after clicking on the copy Padding link.  

 

iv. Cell Format: The Borders section appears disabled if Set Border is enabled in the General tab. 

Therefore, to enable the Borders section here, disable Set Border in the General tab. 

 

 
Figure 16.7 
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Fields Description 

Merge 

Horizontal Enter the number of horizontal cells to be merged. 

Vertical Enter the number of vertical cells to be merged. 

Borders: It is disabled if Set Border is enabled in General properties. 

Line Width Enter or increase/decrease the entered Line Width value. 

Line Color Click on the dropdown button to select the Line Color. 

Right Border Check this box to apply the Line on the right side. 

Left Border Check this box to apply the Line on the left side. 

Top Border Check this box to apply the Line on the top side. 

Bottom Border Check this box to apply the Line on the bottom side. 

Cell Text Rotation 

Angle Select the rotation angle of the cell text. 

 

9. Details tab consists of the following fields: - 

 

Fields Description 

Dynamic Details 

Dynamic Table Select the checkbox to define the dynamic table. 

Detail Row Click on this dropdown button to select the number of rows which are to be declared 

Dynamic. 

Table Name Select the Table Name from the dropdown. 

Numbering Select the numbering style from the dropdown. 

Use multiple colors for 

transactions 

Select the checkbox to add two or more alternate colors on the specified detail row within 

a dynamic table. Applying different colors to alternate table rows in a table makes the data 

easier to understand. 

To do so, select the required color from the color dropdown . You can use 

standard color, theme color, or RBG color code for the table row color. Then, click Add. 

The color gets added to the list. 

Similarly, you can add more table row colors. The color sequence in the list determines the 

color pattern to apply to the table. 

To delete any added color, select the required color from the list and then click Remove. 

Header Details: It is disabled if Column Details is enabled 
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Allow Header Select this checkbox to allow header. 

Header Row Gets activated on selecting the Allow Header checkbox. Enter the required Header Row 

width, by entering the required value opposite the From and To box. 

Create table header on each 

page. 

Select this checkbox to allow create table header on each page. 

Suppress table header for 

blank rows 

Select this checkbox to suppress the table header for blank rows. 

Auto Adjust Property 

Start from New Page Select this checkbox to allow “Row Auto Adjust Property” from the new page. 

 Always adjust 

row height 

automatically 

Select this radio button to always adjust row height automatically. 

If spaces on pages 

is less than 

Select this radio button and enter the required percentage value in the available box, to 

apply the row auto adjust property, only if space on pages is less than the entered value. 

If space left on 

the page 

Select this radio button and enter the required percentage value in the available box, to 

apply the row auto adjust property, only if space left on the pages is equal to the entered 

value. 

Reduce Table Size Select this checkbox, to reduce the table size. 

 If Space occupied 

on last page is 

less than 

Enter the required value in the available box, to reduce the table size only if the space 

occupied on the last page is less than the entered value. 

Reduce font size 

on table  

Enter the required threshold value in the available box to reduce the font size by the 

threshold limit. 

Spill row on page 

split 

Select this checkbox to enable shifting of the table row to a new page. 

Columns: Refer to the section Split Column Details. 

Column Auto Adjust Property 

Auto adjust by content Select this checkbox to automatically adjust column width by content size 

Suppress Columns Enter the number of columns which has to be suppressed. 

Auto adjust by width Select this checkbox to suppress the column width automatically. 

Sort Details 

Sort details Select the checkbox to enable the tab. It can only be applicable when detail row tab is 

enabled. 

Sort by Select the order of displaying table entries in ascending or descending. 
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Table Name Enter the table name that you want to sort. 

Column Name Enter the column name, you want to display. 

Include in Table of Contents 

Include in Table of Contents Select this checkbox to enable the include in the table of contents section. 

Table Name Enter the table name that you want to display in the table of content 

Level Specify the level of heading. 

 

 
Figure 16.8 

 

10. The following buttons appear at the bottom of the Table Properties dialog box: 

• Preview: Click on Preview to have a preview of the table. 

o On click of Preview, the Preview dialog box appears. 

o Specify the Master Key and select the required Preview Choice. 

o Click Preview. 

• Apply: Click Apply to apply the defined table properties. 

• OK: Click OK to save the table properties and close the dialog box. 

• Cancel: Click Cancel to close the dialog box without saving the changes done. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 425 

  



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 426 

19.1 Edit query 
Edit Query feature allows the user to: 

• Add User Defined Query in a table 

• Modify the System Query or Add a New Query 

• Apply Filters using Queries 

• Apply Order By using Queries 

 

To perform the above tasks, carry out the following steps:- 

1. Go to Table Properties → Cell. 

2. Select a cell with a data field or select a blank cell and add a data field. 

3. Edit Query link appears at the bottom of the screen. Click on Edit Query link. 

 

 
Figure 16.9 

 

4. Edit Query dialog box appears. You can add your query from scratch or use the system query as user-

defined query and modify it. You can add the filter condition and use order by to order the data in a 

particular order. 
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Figure 16.10 

 

5. Refer the below figure where a sample of the user-defined query from scratch has been made to the 

selected cell. 

 
Figure 16.11 
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6. Click on Execute Query link, given in the bottom-left corner, to check whether the query is valid or 

not. It shows the result of the query. 

 
Figure 16.12 

 

19.2 Apply masking 
Apply Masking is used to hide the original data of Data Fields in Tables. 

 

To apply data masking in tables, carry out the following steps:- 

1. Go to Table Properties → Cell. 

2. Select a cell with a data field or select a blank cell and add a data field. 

3. Apply Masking link appears at the bottom of the screen. Click on Apply Masking link. 
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Figure 16.13 

 

4. Data Masking Configuration dialog box appears. 

 

 
Figure 16.14 

 

5. Refer the below steps to understand how masking is done.  

i. We have used an example, this masking pattern is for data having length =5; where the first, third 

and fourth characters will be masked. 

ii. Specify Masking Character, PlaceHolder and Masking Pattern. 
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Figure 16.15 

 
iii. Variable Length Data Masking would be done as shown in the figure below.  

a. Select Variable Length Data checkbox to enable it. 

b. Select Apply Pattern as Start From Left or End to Right. 

c. Select Replace Remaining data as Keep Same or With Masking Character. 

 

 

 
Figure 16.16 

 

iv. Preview section allows you to view a preview of the masked data. 

a. Specify Sample Input data to be masked. 

b. Click Preview. 

c. Sample Output textbox shows the masked output of the specified Sample Input. 

 

 
Figure 16.17 

 

6. Click OK to save the settings. 
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19.3 Rule association 
To associate Rule, or create any new Rule and then associate it with the cell, carry out the following 

steps:- 

1. Click on Table Properties → General → Rules button, or click on Table Properties → Cell → Apply 

Rules link, to open the Rules Association page. 

2. Respective Rule Association dialog box appears. 

3. Click on Associate Rule button to enable the Select Rule dropdown box. 

 

 
Figure 16.18 

 

4. Select Rule section is enabled. Click on the dropdown button to make the required selection. 
 

 
Figure 16.19 

5. To create New Rule, click Create New Rule link.  

6. Common “Create Rule” dialog box appears. To learn about creating a new rule, refer to the section 

Create Rule. 
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7. After creating the new rule, go back to Rule Association dialog box. 

8. Select and associate the required Rule.  

9. Click Add. 

 

 
Figure 16.20 

10. The required Rule is added and appears in the Associated Rules section. 

11. Click OK. 

12. The Rule is associated with the required Row/Cell. 

 

19.4 Dynamic table 
To create a Dynamic Table, carry the following steps:- 

1. Go to Contract/Report Table Properties. 

2. In Table Properties → General tab, add the required number of Columns and Rows. 

3. In Table Properties →Cell → Appearance tab, associate each cell with the required value or image. 

 

NOTE: 

When you create an accessible PDF, the Image Type and Alternate Text field appears. Select Image Type as: 

• Artifact – when you do not want to add a description about the image. 

• Non-Artifact – when you want to add a description about the image. 

➢ Enter a description of the image in Alternate Text box. 

 

4. In Table Properties →Details tab, select the Dynamic Table checkbox to enable it. 
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5. Select the Detail Row from its dropdown list and click on OK to save the properties. 

 

 
Figure 16.21 

 

19.5 Split column details 
Split Column allows you to split a table by columns. It is useful when you are required to split a single 

cell into multiple cells. 

 

 
Figure 16.22 

 
To use it, specify the following Column Details in the Columns section: 

1. Select Column Details checkbox to enable split column functionality in the table. 

• The Header Details section is disabled on enabling Split Column. 

2. Select First Column Header and Auto Adjust Column checkboxes, as per the requirement. 

3. Specify the Relative Margin in pixel. 

4. Define the Split Type: 

i. If Split Type is selected as Static Column: 

a. Click on Define Columns Width to specify the column width details in pixel.  
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b. Column Details dialog box appears. 

 

 
Figure 16.23 

 

c. Select the desired column or columns and specify their width in pixel. 

d. Click on OK to save and close the dialog box. 

 

 
Figure 16.24 

ii. If Split Type is selected as Dynamic Column: It should be noted that on selecting Dynamic Column 

radio button, Suppress Columns and Auto adjust by width given in Column Auto Adjust Property 

section and Dynamic Details section are disabled. 

a. Specify Total Width of the table which is mandatory to define the Split table with type 

Dynamic column. 
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Figure 16.25 

 

5. Click on OK to save the table properties. 

 

19.6 Table grouping 
Table Grouping provides facility to create a group and assign this group to different tables so while 

previewing, all the data will be previewed as a group on the basis of a specific master key. 

To Create Table Grouping: 

1. Select any report (in any communication group which is associated with DB dataset). 

2. Right-click and select Container/Table Groups. 

 

 
Figure 16.26 

3. Container/Table Groups dialog box appears. 

4. Click on Add to create a new group or click on Modify to modify a selected group. 

i. Enter Group Name. 

ii. Select a Table from the dropdown list. 

iii. Select a Column from the dropdown list. 
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iv. Click on Apply and then Ok to save the defined table group. 

 

 
Figure 16.27 

 

When the user draws a table in CDG or open the table properties, then the highlighted changes for table 

grouping will display in General tab: 

 

 
Figure 16.28 
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19.7 Table pop-up menu options 
Table Pop-up menu options are the options that appear on Right-click of the selected table. These 

options are: Cut, Copy, Paste, Delete, Hide, Properties, Orientation and Undo Cell Change. 

Also, All the tables can be selected using Ctrl+A on the keyboard. 

 

 
Figure 16.29 

 

To Cut and Paste a Table: 

1. Select the table. 

2. Right-click on it and select Cut. 

3. Right-click at the place in the table design area where you want to paste the Cut table.  

4. Select Paste. 

 

To Copy and Paste a Table: 

1. Select the table. 

2. Right-click on it and select Copy.  

3. Right-click at the place in the table design area where you want to paste the Copied table.  

4. Select Paste. 
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Figure 16.30: Copied Table 

 

 
Figure 16.31: Pasted Table 

 
To Delete a Table: 

1. Select the desired table. 

2. Right-click on it and select Delete.  

3. The selected table gets deleted from its place. 
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To View and Configure Table Properties: 

1. Select the desired table. 

2. Right-click on it and select Properties. Table Properties dialog box appears. 

3. Refer to Table Properties to learn about it. 

 

Undo Cell Changes 

This functionality is provided to revert the changes on the last applied settings on a single cell. 

1. Select the table. 

2. Right-click on it and select Undo Cell Changes. A confirmation message appears. 

3. Click on Yes to confirm. 

 

Orientation 

It is used to set the selected table to some specific angle: 

1. Select the table and right-click on it 

2. Select Orientation . Placement and Size dialog box appears. 

3. Specify Placement (Left, Top), Size (Height, Width), Units (Pixel, Inches, and Centimeter) and 

Rotation (Angle) and click OK to save. 

 

 
Figure 16.32 
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19.8 Cell format copy and paste 
Copying format of a cell of a table and pasting the copied format either to another cell of the same table 

or to the entire cell of another table. 

 

Table Format to Cell Format of another Table 

1. Drag and drop a table on the canvas. 

2. Open its property (Table Properties). 

i. Go to General tab, enable Set Format and click on Copy Format link. 

 

 
Figure 16.33 

 

3. Now, drag and drop another table on the canvas and open its property. 

i. Go to General tab and uncheck the Set Format checkbox. 

 

 
Figure 16.34 

 

ii. Go to Cell tab →Appearance tab. 

iii. Select any cell of the table copy. 

iv. Click on Apply Format link. 
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Figure 16.35 

 
v. Click on Apply Format link. The cell format of this cell will be changed to the format of the 

previous table format. 

 

 
Figure 16.36 
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One Cell Format to another Cell Format of the Same Table 

1. Go to the Cell tab and select a cell of the table copy. 

2. Open Appearance tab and click on Copy Format link given in the Font section. 

 

 
Figure 16.37 

 

3. Now, select another cell of the table copy. Open Appearance tab and click on Apply Format link given 

in Font section. 

 

 
Figure 16.38 

 

4. Click Apply Settings link given at the bottom of the table properties. 

 

One Cell Format of a Table to another Table 

1. Go to the Cell tab and select a cell of the table copy. 

2. Open the Appearance tab and click on the Copy Format link given in the Font section. 
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Figure 16.39 

 

3. Now, select another table and open its properties. 

i. Go to the General tab and check the Set Format checkbox. 

ii. Click on Apply Format link. 

 

 
Figure 16.40 

 

iii. Save the table properties. 

 

19.9 Table alignment and positioning 
To keep selected tables in one alignment 

1. Drag and drop two tables of different width. 

2. Press Ctrl+A keys together to select both the tables/all tables. 
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Figure 16.41 

 

3. In the Toolbar, click on  

i. Left Align  button to align left. The tables will be left-aligned. 

 

 
Figure 16.42 
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ii. Right Align  button to align right. Both the tables will be right-aligned. 

 

 
Figure 16.43 

 

iii. Make Same Width button to make both the tables of the same width. 

 

 
Figure 16.44 
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iv. Top Alignment 

• Drag and drop two tables of different width and press Ctrl+A keys. 

 

 
Figure 16.45 

 

• Click on Top Align  button. Both the tables will be top-aligned on the basis of last selected 

control. 

 
Figure 16.46 

 
v. Bottom Alignment 

• Select the tables. 
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• Click on Bottom Align  button. Both the tables will be bottom aligned on the basis of last 

selected control. 

 

 
Figure 16.47 

 
Table Positioning: Removing vertical spacing 

1. Drag and drop multiple tables on the canvas (three tables are shown here). 

2. Press Ctrl+A keys to select all the tables. 

3. Click on Remove vertical spacing  button. 

 

 
Figure 16.48 

4. A message box appears prompting you to save the selected report. 

• Click on OK to save the report and close the message box. 
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5. After saving the Report, another message box appears. 

• Click on Yes to continue. 

6. Notice that the vertical space between the tables has been removed. 

 

 
Figure 16.49 

19.10 Cell border removal 
Removal of borders on the canvas when the cell borders are removed: 

1. Draw a table. The below figure shows a table without applying any change in cell border  

 

 
Figure 16.50 

 

2. Select the table and open its properties. 

3. Go to General tab and uncheck Set Border checkbox. 
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Figure 16.51 

 

4. Click on Cell tab. 

i. Select the desired cell of the table. We are selecting the first cell. 

ii. Click on Cell Format tab. 

iii. Uncheck the Right Border checkbox given in Borders section. Here, we are removing the right 

border of the first cell. 

 

 
Figure 16.52 

 

5. Click OK. Notice that the first and the second cells are merged as a result of removal of the Right 

Border of the first cell. 

 
Figure 16.53 
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6. Similarly, Left Border, Top Border and Bottom Border of the selected cell can be removed. 

19.11 Nested table 
A Nested table is a process of defining a table within a cell. To define a table within a cell, carry out the 

following steps:- 

1. Open Table Properties and go to Cell tab. 

2. Click on the Appearance tab, in the right pane. 

3. Select Content Type as Table and click on Define to define table properties. 

 

  
Figure 16.54 

 

4. Table Properties dialog box appears. Define the properties as described in the section Table. 

5. Click on OK to save the defined properties. The table defined within the selected cell appears as 

shown in the figure below: 

 

 
Figure 16.55 
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The designed nested table on the canvas appears as shown in the figure below: 

 

 
Figure 16.56 

 

19.12 Mapping table to RTF or HTML labels 
OmniOMS Composition Designer allows you to map the tables cells to RTF or HTML labels. You must 

select the content type (RTF or HTML) and the labels containing content. When previewing a report, you 

can view the content retrieved from an RTF or HTML label. But real-time fetching of the content occurs 

during batch generation. 

 

NOTE: 

To know add, modify, delete, or fetch external content in the RTF or HTML labels, refer to the OMS external content library 

section in OmniOMS 12.0 Developer Guide. 

 

To map table to RTF or HTML labels, follow the below steps: 

1. Create a table. The Table Properties dialog appears. 

 

NOTE: 

To know how to create a table, refer to the Table section. 

 

2. Click Cell to open the related tab. 

3. Select the required cell in the table and then click Appearance. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 452 

4. Select Content Type as External Content using the dropdown. 

 

 
Figure 16.57 

5. Select Type as: 

• RTF – to map the table cell to RTF labels. 

➢ Select the required RTF Label Name. 

• HTML – to map the table cell to HTML labels. 

➢ Select the required HTML Label Name. 

 

 
Figure 16.58 
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6. Click OK to complete mapping. 

 

19.13 Apply URL shortening in a table 
CDG allows you to apply URL shortening to content added to a table in the following ways: 

• Apply URL shortening to data field added to a table cell 

• Apply URL shortening using macro fields 

• Apply URL shortening using hyperlink 

 

19.13.1 Apply URL shortening to data field added to a table cell 
To apply URL shortening to a data field added to a table cell, follow the below steps: 

1. Open the required report.  

2. Insert a new table. The Table Properties dialog appears. 

Alternatively, right-click an existing table on the canvas and select Properties. 

3. Open the Cells tab and click the required cell to select it. 

4. In the right-pane of the dialog, open the Data Fields tab.  

5. Expand the required table node and select the required data field. It gets added to the selected 

table cell. 

6. In the right-pane, open the Appearance tab.  

7. From the Content Type dropdown, select the Data Field option. 

8. Select the Shorten URL checkbox to shorten the URL value mentioned in the selected data field.  

9. Click OK. The URL shortening gets applied to the selected data field. 

10. Click the save icon . A dialog asking to save the changes made to the report appears.  

11. Click Yes to confirm. 

 

19.13.2 Apply URL shortening using macro fields 
To apply URL shortening to using macro fields in a table , follow the below steps: 

1. Open the required report.  

2. Insert a new table. The Table Properties dialog appears. 

Alternatively, right-click an existing table on the canvas and select Properties. 
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3. Open the Cells tab and click the required cell to select it. 

4. In the right-pane of the dialog, open the Appearance tab.  

5. From the Content Type dropdown, select the Static Text option.  

7. Right-click the rich text box and select Macro Fields. The Database Field Browser appears. 

8. Expand the required table node and select the required data field. 

9. Select the Shorten URL checkbox to shorten the URL value mentioned in the selected data field.  

10. Click Select. The macro field gets added to the table cell.  

11. Click OK. The URL shortening gets applied to the selected data field. 

12. Click the save icon . A dialog asking to save the changes made to the report appears.  

13. Click Yes to confirm. 

 

19.13.3 Apply URL shortening using hyperlink 
To apply URL shortening to using hyperlink in a table , follow the below steps: 

1. Open the required report.  

2. Insert a new table. The Table Properties dialog appears. 

Alternatively, right-click an existing table on the canvas and select Properties. 

3. Open the Cells tab and click the required cell to select it. 

4. In the right-pane of the dialog, open the Appearance tab.  

5. From the Content Type dropdown, select the Static Text option.  

6. Select the required text in the rich text box. 

1. Right-click the selected text and select Hyperlink. The Hyperlink dialog appears. 

In the Name field, the selected text appears. It is modifiable.  

2. Select the Type as Macro Field to hyperlink the text to a dynamic data field. In this case, the web 

address or URL can change. The Target field appears disabled. 

3. Click the horizontal browse icon . The Database Field Browser appears. 

4. Expand the required table node and select the required data field. 

5. Select the Shorten URL checkbox to shorten the URL value mentioned in the selected data field. 

6. Click Select. The selected data field now appears in the Target field. 

7. Click Ok. The selected text gets hyperlinked and added to the table cell. 
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8. Click the save icon . A dialog asking to save the changes made to the report appears.  

9. Click Yes to confirm. 

 

20 Data security compliance 
The Data Security Compliance is a set of requirements designed to ensure that companies that process, 

store, or transmit credit card information maintain a secure environment. 

 

NOTE: 

Data Security Compliance feature is only possible on those cabinets in which this feature is enabled during cabinet 

registration. 

 

To enable Data Security feature in Dataset of DB Type, carry out the following steps:- 

1. Select New Category-Dataset tab. 

2. Select Dataset Collection and Right-click to select New Dataset. 

3. At Relationship Manager Wizard, select the Available DSN [cabinet_name] and provide the 

username and Password then click on 'Next'. 

4. Select the table and click on Finish. 

5. Check the Define Relations window. 

6. During dataset creation, while defining relation, click on 'Secure Data' button. 

 

 
Figure 17.1 
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7. Secure Data Details screen appears. 

 

 
Figure 17.2 

 

8. Select the checkbox present in front of the required Dataset Fields. 

9. Move them to the right table. 

10. For rest of the Input Fields, refer the following table:- 

 

Input Type Permissible Values Comment 

Masking Character TextBox One character other than a 

placeholder 

Character to show in output on the masked 

character of input. 

PlaceHolder TextBox One character other than masking 

character 

While applying a masking pattern, the value 

corresponding to the position of Place 

Holder will not be changed. 

Masking pattern TextBox Can use only masking character and 

placeholder 

It is used to define a masking condition. 

Variable Length Data CheckBox Checked, Unchecked Select it, if the field can have variable-

length data. 

Apply Pattern ComboBox Start From Left 

End to Right 

It specifies from where to start applying the 

pattern on input data. 



NewgenONE OmniOMS Composition Designer User Guide  Version: 12.0 Page 457 

Replace Remaining Data ComboBox Two Choice : 

Keep Same 

With Masking Character 

It decides how to show data where the 

pattern is not applied. There are two 

options either mask all those character 

positions which are not under pattern or do 

not change them. 

Sample input TextBox String Specify data to be masked. 

Sample Output TextBox String Output when preview Button is clicked. 

Preview Button  Click on this button to have an output of the 

inputs provided. 

 

11. Once all the inputs are provided, click on the Apply button. 

12. Click on OK to save the specified details and close the screen. 

13. After Masking, while designing a report, add Sample Key (this option appears on right-click on the 

inserted data field) for any CHD field.  

 
Figure 17.3 

 

To enable Data Security feature in Dataset of XML Type, carry out the following steps:- 

1. Create XML dataset. 

2. Before applying check-in, select Secure Data option from the right-click menu. 
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3. Modify Relation screen appears. The tables appear disabled. 

4. Click on Secure Data. 

 
Figure 17.4 

 

5. Secure Data Details screen appears. 

 
Figure 17.5 

 

6. Select the checkbox present in front of the required Dataset Fields. 

7. Move them to the right table. 
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8. For rest of the Input Fields, refer the following given box:- 

 

Input Type Permissible Values Comment 

Masking Character TextBox One character other than a 

placeholder 

Character to show in output  on the 

masked character of the input 

PlaceHolder TextBox One character other than 

masking character 

While applying a masking pattern, 

the value corresponding to the 

position of Place Holder will not be 

changed. 

Masking pattern TextBox Can use only masking character 

and placeholder 

It is used to define a masking 

condition. 

Variable Length Data CheckBox Checked, Unchecked Select it, if the field can have variable 

length data 

Apply Pattern ComboBox Two choices: 

Start From Left 

End to Right 

It specifies from where to start 

applying the pattern on input data. 

Replace Remaining 

Data 

ComboBox Two Choice : 

Keep Same 

With Masking Character 

It decides how to show data where 

the pattern is not applied. There are 

two options either mask all those 

character positions which are not 

under pattern or do not change 

them. 

Sample input TextBox String Specify data to be masked 

Sample Output TextBox String Output when preview Button is 

clicked. 

Preview Button  Click on this button to have an 

output of the inputs provided. 

 
9. Once all the inputs are provided, click on the Apply button. 

10. To close the screen, click on the OK button. 

11. After Masking, while designing report add Sample Key for any CHD field. 
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Figure 17.6 

 

21 Integrating Amazon S3 and MS Azure sites 
OmniOMS integration with Amazon S3 and MS Azure sites facilitates temporary storage of the generated 

communications in the respective sites. Storing the generated communications in cloud environment 

helps OmniOMS with High Availability (HA).  

 

NOTE: 

• To create an Amazon S3 Site, go to Admin Workspace → Connections → Amazon S3 sites 

• To create a MS Azure Site, go to Admin Workspace → Connections → MS Azure Sites 

 

To configure the integration with Amazon S3 or MS Azure sites and execute it, follow Mapping the sites 

in jobs 

 

21.1 Mapping the sites in jobs 
To map an Amazon S3 or MS Azure site in jobs, follow the below steps: 

1. Open the required type of job. For example, Print-Job, Mail Job, Message Job, and so on. 

2. Go to the Settings tab and select the Enable Cloud Storage checkbox to enable cloud storage 

settings.  

3. Select the Storage Type as Amazon S3 Sites or MS Azure Sites. 

• For Amazon S3 Sites,  

➢ Select the Site Name and click Get Buckets.  
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➢ Select the Bucket Name.  

➢ Enter the OutputFilePath and click OK. 

• For MS Azure Sites,  

➢ Select the Site Name and click Get Containers.  

➢ Select the Container Name.  

➢ Enter the OutputFilePath and click OK. 

• Cloud Storage settings for Email Job: 

 

 
Figure 18.1 

 

• Cloud Storage settings for the Print Job: 
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Figure 18.2 
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• Cloud Storage settings for the Message Job: 

 

 
Figure 18.3 
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• Cloud Storage settings for the WhatsApp Job: 

 

 
Figure 18.4 
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• Cloud Storage settings for the On Demand Job: 

 

 
Figure 18.5 
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NOTE:  

When user enables the Cloud Storage Settings, then path for Output and External Doc get treated as Amazon S3 or MS Azure 

site path and must follow the below rules: 

• Folder must always end by '/' 

• In case of nested folders then every folder across levels must separate by '/'  

For example: Folder1/Sub-Folder1/Sub-Folder2  

The above input for Output Path creates the generated communications in the Folder1/Sub-Folder1/Sub-Folder2 path that 

is, in the Sub-Folder2.  

The above input for External Doc Path considers all the files in the Sub-Folder2 folder and send these as attachments in the 

communications. 

 

NOTE: 

In case of any OnDemand Job, if you enable cloud storage, the tags filePath and attachmentsLocation in the webservice 

request corresponds to Output Path and External Doc Path. The inputs to these tags must adhere the above said rules for 

Output Path and External Doc Path. 

 

Once the generation of files from the Amazon S3 or MS Azure site is successful, you can view the 

communications generated around the provided path that is configured at the job. 

 

NOTE: 

Import and Export of Jobs does not support the configurations of Cloud Storage, as these are environment specific. Also, 

import and export of S3 Bucket Site Configurations to other environments is not supported. 
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22 Importing PDF in CDG 
The Import PDF feature in Desktop CDG creates a copy of the PDF elements from an imported PDF file 

with static content. This reduces the time and effort involved in designing from scratch. The replica of 

these elements is available to modify on a canvas. 

The benefits of the Import PDF feature are as follows: 

• Designer users need not start designing the PDF from scratch 

• Significantly reduce designing time and effort 

• Additional options to align, resize, position, and merge pdf elements to make the design process 

effortless 

 

22.1 PDF objects supported in import 
CDG allows importing of the following PDF objects with certain limitations: 

• Text 

• Images 

• Rectangle 

• Table 

• Line 

When importing, users have the option of selecting to import table objects, selecting the page ranga of 

the input PDF for import, as well as the password, if the PDF is password-protected. 

 

22.2 Procedures of importing PDF 
The activities for importing a PDF into the CDG can be mapped into three phases. 

• Pre-Import Activities 

• Import PDF 

• Post-Import Activities 
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22.2.1 Pre-import activities 

You can check the following PDF elements in a PDF input before importing it and implementing the 

actions recommended. It is advisable to view the PDF in Adobe Acrobat Reader DC. 

 

Recommendation: 

Use Adobe Acrobat Reader DC to view the PDF. 

 

PDF Element Description Conditions Action/Outcome 

Fonts Check the fonts embedded 

in the PDF. 

Open the PDF in Adobe 

Acrobat DC > right click > 

Document Properties -> 

Fonts. 

If the PDF contains third-

party (private) fonts which 

are not installed in the 

system (Designer & App 

Server). 

Outcome: The text with (private) 

owned fonts cannot be imported. 

Action: Install the third-party 

(private) fonts on the designer server 

and app server. 

Alternatively, users can convert the 

input PDF using MS Word. 

 

Position this input PDF using MS 

word procedure as a separate 

section. 

  

Apply PDF conversion.  

• To convert the original PDF, refer 
to the steps mentioned in the 
section Converting the input PDF 
using MS Word.  

• Import the converted PDF  
 

The text content enables to import 

with the font style set by MS Word. 

Watermarks In PDF, a watermark is a text 

or an image that appears 

either in front of or behind 

existing document content, 

like a stamp. 

If watermark is present in 

the Input PDF and is 

selectable by the selection 

tool in Adobe Acrobat 

Reader DC. 

The watermark import as an 

Image/Text on the design canvas is 

possible. 
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Multi-layered 

Objects 

In PDF, if one element 

overlaps other elements 

then such a PDF is said to be 

a multi-layered PDF. 

When Ctrl+ A is pressed on 

a multi-layer PDF, objects 

that are not selected are 

considered to be on 

another layer. 

The unselected overlapping 

elements are not imported into the 

design canvas. 

The selected objects can be 

imported into the design canvas. 

Images Image content in a PDF When an image with a 

transparent background is 

selected in Adobe Acrobat 

Reader DC. 

Image is imported onto the design 

canvas with a dark background. 

Tables Tabular content in PDF Data is represented in a 

tabular format (rows and 

columns) 

Depending upon the users selection 

to enable/disable the table object 

import, the design gets created on 

canvas. If Table object import is 

enabled, then the tabular content 

imports as table object in designer 

canvas. If Table object import is 

disabled then each cell is treated as 

rectangle and it gets imported as a 

rectangle object on the canvas. 

Fillable PDF PDF containing Fillable 

objects like Input Text Box, 

Radio Buttons, Check Boxes, 

List Boxes, and so on. 

If the PDF contains the 

fillable objects where end 

users can fill the data. 

Designer cannot import Fillable PDFs 

and this is not supported. 

 

An idea of the attainable results through PDF import can be accessed from the above conditions, actions, 

and outcomes. 

 

22.2.2 Importing a PDF 

After you have decided to import the PDFs, follow the below procedure to acquire the design on the 

canvas: 

1. Select the default layer. 
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Figure 19.1 

 

2. Go to the File menu and select Import PDF File. The Import PDF Wizard screen appears. 

 

 
Figure 19.2 

3. Select the option Overwrite Data if required or select the option Append Page then Import Data. 

4. Click Next. The Import PDF File screen appears. 
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Figure 19.3 

 

5. Click the select file to import ellipsis button to import the selected PDF. 

6. Navigate to the file that you want to import and click Open. 

7. Add password of the PDF file. 

8. Specify Page Options whether you want to import: all pages, particular pages, or page range. 

 

 
Figure 19.4 
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9. Select Import PDF Object to import the selected PDF objects. You can import any one or all the 

objects. 

10. Enter Password and select one of the following import options under Import Range Option: 

• Import All Pages 

• Import Page No 

• Import Page Range and 

• Import Comma Separated Page 

11. Click Finish to complete the import process. A confirmation message for the successful PDF 

import appears. 

 

 
Figure 19.5 

 

22.2.3 Handling PDF import errors 

An error message appears if any error occurs in importing the PDF. 

 

 
Figure 19.6 
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To view the error details, click the click hyperlink given in the message. The Error.log file appears. 

 

 
Figure 19.7 

 

There are two possible scenarios for the errors: 

• Objects with Negative Coordinates 

For Example - Unable to import Text, Image, Line, Rectangle, Round-Rectangle, or controls due 

to negative coordinates. 

• Unavailability of the fonts embedded in the PDF 

In this case, the font style of the text content changed to Arial by default. 

The above method resolves the errors of negative coordinates and adjusts the font to the nearest font 

family (if unavailable) and generates the PDF. 

 

22.3 Review of the imported template 
Once the template is successfully imported, you can review the imported PDF design on the canvas and 

compare it with the input PDF file. You can also check formatting issues such as alignments, spacing, 

positioning of objects, and so on. 

Upon the successful PDF import, the possible scenarios are: 

• Improper alignment of the objects 

• Text objects extracted line-by-line 
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22.3.1 Improper alignment of the objects 

To properly align multiple objects on the canvas, first select an object which is properly aligned by 

holding the CTRL key. This enables formatting options in the toolbar. 

 

 
Figure 19.8 

 

To ease the designing tasks after importing the PDF, a few formatting options for objects on alignment, 

sizing, and positioning are provided. 

Click any of the Left, Center, Right or Top, Middle, Bottom alignment to set the alignment of the selected 

improper objects to the properly aligned object. 

You can click the Format menu in the Toolbar for options such as Alignment, Making Same Size, and 

Equal Spacing between the objects. 

 

NOTE: 

To learn about the alignment of objects, refer to the section 4.5 Format Menu in the OmniOMS 9.0 Designer – User Guide. 

 

Example: The right indentation of selected text in the figure below is slightly different. To solve this type 

of indentation and alignment issues, alignment and positioning options are available on the toolbar. 

 

 
Figure 19.9 

 

Select multiple objects that are misaligned. 
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Figure 19.10 

 

Click the right alignment option on the toolbar to align them with the right margin. 

 

 
Figure 19.11 

 

 
Afterward, the right alignment of the selected objects is successful as shown below: 

 
Figure 19.12 

 

To solve alignment, positioning, and sizing issues, you can select multiple objects and click any of the 

alignment options such as Left, Center, Right, or Top, Middle, Bottom from the toolbar. 

 

22.3.2 Text objects extracted line-by-line  

You might encounter multiple text objects in the canvas that is arranged in a line-by-line fashion. The 

context Merge Text feature enables you to merge text objects for an efficient design. 

Merge Text:  

 

The Merge Text feature enables multiple text fields to merge depending upon the coordinates of the 

text fields. This works differently in the scenarios discussed below: 
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• If the selected text objects have the same top coordinates, then click  for merging the text 

objects into one text box horizontally. 

• If the selected text objects have the same left coordinates, then click  for merging the text 

objects into one text box vertically either as a paragraph or as line by line depending upon the 

user selection. 

• If the selected text objects have either different left or top coordinates, then upon clicking on 

 for merging the text objects it results in a warning. 

➢ In this scenario, use the alignment options to set the top and left coordinates accordingly as 

mentioned in section 5.1. 

 

Example: Post import the PDF design on the canvas looks like below for a sample PDF file import. 

 

 
Figure 19.13 
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When the text objects are selected, they look disjointed with line-by-line text boxes as below: 

 

 
Figure 19.14 

 

Since the above-selected text objects belong to the same paragraph in the original PDF, you can select 

those text objects and choose the Merge Text option on the canvas toolbar. 

 

 
Figure 19.15 

 

After clicking the Merge Text icon in the toolbar, click Yes to confirm merging the selection as a 

paragraph. 

 

 
Figure 19.16 
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On confirmation to merge as a paragraph, the selected text objects are merged into one text object as 

below: 

 
Figure 19.17 

 

Similarly, the selection of multiple text objects and merging them as a paragraph or as line-by-line text 

content inside a single text object is attainable. 

 

22.3.3 Mapping customer data to the data fields 

After successful import of the PDF, the PDF design elements from the imported PDF comprise of 

customer data. To map the respective customer data to a data field, you can delete the appropriate text 

objects and drag and drop the necessary data fields from the dataset onto the canvas design wherever 

applicable. 
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22.4 Converting the input PDF using MS Word 
To convert the input PDF, refer to the steps listed below: 

1. Open the PDF in Adobe Acrobat DC editor. 

2. Save it as a Word (.docx) file. 

3. Open the saved Word (.docx) file in MS Word 

4. Save it as a PDF (.pdf) file. 

 

For the above scenarios, convert and save the input PDF using MS Word as mentioned in the section 

Converting the input PDF using MS Word. Import the saved PDF (.pdf) file in CDG as described in section 

Importing a PDF. 

 

NOTE: 

By performing the above PDF conversion using MS Word, sometimes the fonts embedded in the PDF are automatically altered 

to the available system fonts due to the unavailability of fonts. Additionally, modification is available if required. Some of the 

text content can get transformed into an image. 

 

22.5 Limitations of importing a PDF 
The import PDF feature has the following limitations: 

• If the coordinates of certain images and text objects are not perfect, then such images and 

objects are not imported properly. 

• Highlighted text or text with background color does not get imported as expected. 

• A rectangle with boundaries of multiple linewidths cannot be drawn on the canvas. 

• In some instances, the underline can be read as a rectangle with no fill color or no line width. 

• If a text is underlined, it gets imported without the underline style. 

• Images with a transparent background in the PDF are imported with a black background. 

• The alignment of an entire paragraph may not be appropriate after import. 

• Tables without borders will not be imported as table objects in the designer. 
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Annexure 
Limitations of Accessible PDFs 

When creating accessible PDFs (PDF reports, Letters , and fillable PDFs), the following limitations apply: 

• Support for adding Submit buttons to fillable PDFs. 

• Support for providing format or boundary validation for form elements in Fillable PDF. 

• Support for specifying a different language (used for read out loud) for each passage in a PDF 

containing passages in different languages. 

• Support for providing headings by marking content in PDFs. 

• Support for adding list tags in PDFs. 

• Support for providing consistent page numbers while creating annexures in PDFs. 

• Support for adding labels for interactive form controls used in tables in PDFs. 

• Support for providing format or boundary validations for form elements in Fillable PDF. 

• Support for Indicating required form controls in PDF forms. 

• Support for providing labels for interactive form controls in tables in PDFs 

• Support for charts in PDFs. 

• Support for Annexures in the PDF. 

• Support for correct tab and reading order of the content inside the container. 

• Support for HTML content inside a table in the PDF. 

• In fillable PDFs for item list, the read out loud feature reads all the text at once. There is a limitation 

in PDF Reader that causes this to occur. 
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